Manjaro architect 0.9.2

manjaro-architect

#21

Once I tried to install Antergos and they didn’t include Iran either. So that’s why I asked.


#22

Yes, not on purpose. As noted, there are many countries not listed too.
When 17.0.2 was in testing using grub, there were lots less languages too. But we can request that the languages be included. Perhaps it is just ‘what’s in the mind’ of the developers, which is understandable.

The good thing is that, even if any language is not in the install list, we can include it in the option, if it is in grub modules (which ‘ir’ is). You might find it interesting to note that Korean [1] is not in grub module and Mongolian is. Most linux developers are receptive to requests (except putting intel-ucode in kernel :rofl: ); case in point, I (an insignificant user :yum:) requested an ‘insignificant’ feature (halt) to the grub developers and it was done in a couple of days.

[1] To be fair, the grub developers had requested Korean users to help in translation for the modules. And I still wonder why f2fs is not in the grub capabilities (f2fs is a Korean innovation).

Ah, I talk too much. Cheers.


#23

Nah, it is just a faulty method of generating locale list. We inherited this part from original architect installer. I’ll just adjust the way it filters the locales. Maybe instead of

| sed 's/ UTF-8//g' | grep .UTF-8

Just

| awk '/UTF-8 / {print $1}' 

Or something. Then we should get all UTF-8 locales.


#24

I wonder why Arabic with all Arab countries are listed. We have common alphabet.
Does’nt this UTF-8 exclude them?


#25

No idea. Afaik UTF-8 should include multiple alphabets.

now it looks like this:


#26

How install Manjaro 17.03 RC1 with Manjaro architect 0.9.2? Thanks.


#27

Others can confirm, but RC is merely a snapshot of a recent stable release. (see main 17.0.3 RC thread)

To answer your question directly, ensure you choose ‘stable’ mirror when using Manjaro-Architect, and you should have something identical, if not very close to, RC1


#28

Just install with manjaro-architect. Your grub won’t say rc, but it is really the same thing. When prompted for full/minimal, choose full version, that’s what the release candidate uses.


#29

Testdisk, ddrescue, a terminal version of gsmartcontrol ( I dont know of one…), and a terminal based av program I can run on mounted windows volumes.


#30

BTW, used this today to install manjaro in a VM…I love this thing! I am really thinking of reinstalling Manjaro on my laptop just so I can play with it more! :grin:


#32

Ooh, I missed your post, but these would make sense for the system rescue menu.


#33

Hi, maybe I overlooked it, but would it be possible to include file system labels when creating the partitions?
Most filesystems use the -L switch for that.


#34

Could you elaborate?


#35

When I create partitions, I like to give them names, so instead of having a “250 GB drive” showing up in Dolphin/Thunar, it would show “root” or “data” or whatever name you gave to it.
With lots of drives and partitions, it’s much easier to keep track of everything if you give names to your partitions.


#36

Okay. Are you suggesting adding label option in partitioning or formatting?


#37

Formatting. I think it’s already possible to use labels in partitioning with cfdisk and the likes.


#38

I’m trying to install a i686 Manjaro system with Manjaro-Architect 17.0.4 ISO, manjaro-architect shows v0.9.3. I’m getting the error

[clone profiles repo][127]
/usr/lib/manjaro-architect/util-base.sh:
line 25: git: command not found

Edit: Nevermind, it was a user mistake due to heavy tweaking of /var.

Edit2: I would suggest to replace yaourt + base-devel with pacaur + base-devel.


#39

It broke anyway, installation failed.
:: pacman-mirrors and pacman-mirrorlist are in conflict. Remove pacman-mirrorlist? [y/N] error: unresolvable package conflicts detected

@Chrysostomus, @oberon, is there a way to remove pacman-mirrorlist from the list of packages to install? Where does m-a git-clones that list on the file system?


#40

Modifying the git profiles is not a good solution. The best option for troubleshooting shooting the package list is at the moment of custom package selection. Check /mnt/.{base,desktop} for offending packages.

Also, it seems that the git profiles need to be updated…


#41

I’m trying to install again, it is working now. The installation proceeds.

Edit: It almost worked, now an error with libxml2 signature of Christian Hesse is invalid and parted invalid or corrupted package.
Edit2: Installing the new version of archinux-keyring in TTY2 resolved the issue.