Manjaro-architect 0.8


#361

Okay, I now got systemd-boot and refind working reasonably. Both have succeeded in booting from normal ext4 root and from btrfs subvolume root. Refind has been tested to work with encrypted root when ESP is mounted to /boot (therefore, no encrypted /boot). I also updated the bootloader descriptions a bit so user can make a more informed choice.

I updated the PKGBUILDs and made agithub release, so when @oberon or one of the other packagers has time to build it, it shall be available in the repos. This would be 0.8.11.


#362

I’ll test as soon as there is an updated iso.


#363

Thanks. I hope someone tests if the new bootloaders work when installed to the hard drive. In my experiments they work otherwise, but using encrypted root gives me usb errors. Would be good to know if the issue is limited to removable devices.


#364

So, I have rebuild the architect ISOs and now also uploaded them to a proper place on the community’s sourceforge-account:
https://sourceforge.net/projects/manjarolinux-community/files/architect/


#365

I get this error when I try to set the keymap to de with the current version 0.8.9.

System locale works fine…


#366

Manjaro Architect ISO doesnt work. It is literally impossible to partition device. Program detects 0 size, so it doesnt allow you to put any value, except to leave partition setup.
On the other hand, launching manjaro architect from Manjaro LiveCD is fine and working without quirks.


#367

https://itsfoss.com/manjaro-architect-review/?utm_source=newsletter&utm_medium=email&utm_campaign=linux_owns_supercomputers&utm_term=2017-06-28


#368

I’ve just compiled the git version, now running 0.8.16.r1.g96c4793-1.
an error occured when trying β€œInstall custom system” -> β€œinstall base system” -> linux412, yaourt, base-devel
Edit: The same with β€œinstall core system”

Manjaro Architect Installer v0.8.16 - UEFI (x86_64)
 ──────────────────────────────────────────────────────











                                 β”Œβ”€β”€β”€β”€β”€β”€β”€β”€β”€ Error ───────────┐
                                 β”‚                          
                                 β”‚ [install basepkgs][255]   β”‚
                                 β”œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€
                                 β”‚         <  OK  >          β”‚
                                 β””β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”˜

...


==> Creating install root at /mnt
  -> Installing packages to /mnt
:: Synchronizing package databases...
downloading core.db...
downloading extra.db...
downloading community.db...
error: target not found: utter
==> ERROR: Failed to install packages to new root

Must be a typo, cutter, butter.

Name            : manjaro-iso-profiles-base
Version         : 17.0.2-3

manjaro-iso-profiles-* are from current, up-to-date Unstable.


#369

Ok, so for some reason it tries to install package β€˜utter’ and fails because there is no such package. Investigating tonight, if kids sleep.


#370

``b43-fwcutter might be the closest guess, but I haven’t selected linux*-broadcom-wl if that is related.


#371

I thought so too. It is part of Packages-Root, so it is installed on every system.

Testing now installation. I didn’t get that error… I


#372

@Chrysostomus
I have downloaded the ISO with the Architect installer, booted it in a VM, started the installer (which was updated before starting) and I could choose a million and 1 different things before the installer started to do its job.
Close to the end I received an error and things stopped. I have found a log file called: basetrap.log in /tmp.

Are there more log files you would be interested in to see what went wrong?
How do I get the log file from a terminal only system running in a VM to my host system?
I’ll keep the VM running.


#373

For such things it is better to use an ISO with a DE, install manjaro-architect on it and have a browser, a text editor, file manager. Or if you have Manjaro installed on the machine you can best use this install to install with manjaro-architect to a different partition.
For a CLI environment the command script can be useful:


#374

/var/log/m-a.log

Just check the error, full log is probably unnecessary. I suspect a faulty package name in some list.


#375

Thank you, I will do it again, cause I switched off the VM and the PC itself overnight.

[EDIT]: Now I received an error in a different part of the installation. This time it was in the base system, first time was during, or just after installing the DE. Took a screenshot (something I didn’t think about yesterday):


Does this help in any way?

[EDIT-2]: I stopped the installation of the base system and returned to the menu. I then restarted the same and now I did install it all. But when installing the KDE desktop I got the same error as yesterday:


Both pictures show something with perl. Could that be it?


#376

There seems to be some problem with the perl package in the repos. Reformatting and then using different mirror or branch might help.


#377

I started over and instead of using only the servers in The Netherlands, I also chose some in Belgium and Germany. I also chose kernel 4.9 instead of 4.12, no idea if that makes any difference.

The installation went well with one remark: I chose to also install the virtualbox guest addition since I run this version in a VM. But after booting into the new installation I wanted to install the guest additions but it could not find the ISO file. I had to download it straight from the Virtualbox website, which worked.
Now I can use the new OS after a successful installation. Thank you.


#378

Yeah, vbox support is a bit hit and miss, because it is not tested and coded by same people. Same holds true for a few other features too.


#379

If it is still the same bug as from long ago, when you choose the vbox modules with the kernels it is not installed unless you choose to install the drivers through the rest of the installation.


#380

A post was merged into an existing topic: Good experience with btrfs
I posted in the wrong topic. - eugen-b