Manjaro-architect 0.8


Ok, thanks for the info.

No luck, unfortunately. I got the following (strange) error, multiple times, that after downloading the base packages, it says all of them are corrupted or have invalid signatures. I did choose the pacman-refresh-keys option beforehand, shouldn’t have I done it? Or is it related to something else?


Switching branches might help as temporary measure.


Let’s also make sure the ISO downloads are properly checked, and then burnt to disc with ‘dd’ or DD or whatever we are using correctly. I use the collective ‘we’… :smiley: :smiley: :smiley:


Fixed few bugs (chroot notification was not shown, bootloader check always failed) and did some work with systemd-boot. It should now mostly do what the old installer did, except detect manjaro kernels instead of hardcoding kernel names + detect and add intel microcode. Not available in the menu yet, but should be available in a few days.

This is what the generated menu entries look like:

title   Manjaro Linux 4.11-x86_64
linux   /vmlinuz-4.11-x86_64
initrd  /intel-ucode.img
initrd  /initramfs-4.11-x86_64.img
options root= rw


I dont install custom packages. I try it in russian & english languages. Whats wrong? Thanks.


Manjaro-architect is missing fzf from its dependencies, thank you for reporting. It should work if you install fzf.


I readded now systemd-boot as a bootloader option. It might not yet work reliably, but it generates right looking boot entries and installs. I had some trouble with it when installing to USB device, but it seems it might not be root cause of that problem.

Anyway, now refind and systemd-boot are available to test with the git package. Please test.


Can it be possible to have a monthly (ideally each stable update) update of the architect iso on sourceforge?
At least we will be sure to only test the architect package and not other components (pacman-mirrors, kernels, …).


There is no need. When you run the ISO, it’ll auto update it to the latest version. The ISO is just to start the installer, once you get it running, everything is up-to-date.


No it update the latest package not other components, hence my question.
pacman-mirrors is still in development.


What do you mean by that?

Manjaro Architect is currently at 0.8.9. When you run the one off of Source Forge, it’ll auto-update to 0.8.9.


There are some bugs on install due to package download, syncing. Development is done on latest components from unstable. What we are testings is based on components from several weeks ago. A basic in testing is to test 1 component only.


The idea makes sense for the developement phase of manjaro-architect once it is feature complete and stable, the iso can be left unattended for longer periods of time, but up to date isos are beneficial at this stage.

@oberon, what’s your take on the matter?


yes, exactly that.

Why do you mean? manjaro-architect isn’t even installed on the ISOs. The latest availble stable version - so currently 0.8.9 will be downloaded when you use the launcher! :slight_smile:
Also apart from that not a lot of other packages are installed on the ISO either. Updating it will just be important when there are some manjaro-system updates that can cause problems.
Of course I will rebuild the ISO every now and then. I can do that now but don’t really see a necessity for it, do you?


Not necessarily necessary, but potentially useful for testing. See reasons given by @Onf in preceeding conversation.


Ah. So more concerning pacman-mirrors development, right! That’s true :slight_smile:
Will update the ISOs later today.


Please, anybody answers to me. Thanks.


@chapa I thought I already did. Did I misunderstand you? Может быть я не правильно понял ваш вопрос? I thought that you meant that the option “Install custom packages” does not work when you try it. It should start working after you install the package fzf.

sudo pacman -Sy fzf
sudo manjaro-architect 

This is a bug that should be fixed in the next release.


Chrysostomus [quote] This is a bug that should be fixed in the next release. [/quote]
Thanks. Sorry for my bad english. Good luck.


Okay, my tests indicate that systemd-boot doesn’t work yet. On btrfs subvolumes it falls to detect the root right, and on plain ext4… It seems work, config files look right to and there are right menuentries in the menu, but initramfs fails to mount the root.

EDIT: the problem was that the initramfs could not detect filesystems on the removable device, even though the bootloader did. The same thing happened with refind occasionally. Disabling autodetect, effectively making all initramfses fallback ones, fixes this.

Oddly enough, there is no such issue with grub, and refind also worked on its own if it was installed beside grub, in a situation where it otherwise would not have. Grub does behind the scenes something that other options do not.

Anyway, I set refind and systemd-boot functions to disable autodetect hook if they are installed on a removable device. That should work on removable device better anyway, if you are moving between computers. It might also make sense to disable the creation of fallback images in this case to save time and space. But that would be messy and would not apply to new kernels.