Manjaro-architect 0.8


#281

Thanks’ !!! Very interesting.


#282

Error [255]. Yesterday I installed a small portable using M-A to replace an old Linuxmint installation. Nothing special, all normal, but the “Error [255] phantom” appear another time: impossible to install the KDE Full.
I tried 3 times, no way. Really close to the desperation (almost…) I choose to install XCFE Full and… no error. Redo the same with LXQT, no error. Retry with KDE Full: ERROR!

At that point I create a small USB Key (16Gbyte) dedicated to m-a, to replace the “old” ISO image USB Key and… KDE Full is installed perfectly without any problem!

I suspect that, when m-a is used as iso image installed on a USB Key, there is a problem of disk space when installing complex environment like KDE Full. Just an idea, but confirmed from the behaviours of the previous test :slight_smile:


#283

#284

The first custom named subvolume gets created but not mounted. It is probably the command in line 992

            mount mount -o $(cat ${MOUNT_OPTS}),subvol="$(awk '{print $1}' /tmp/.subvols)" /dev/"$(cat /tmp/.root_partition)" /mnt

in https://github.com/Chrysostomus/manjaro-architect/blob/master/lib/util-disk.sh.
I see the typo: the word mount is two times!!!


#285

Thanks! I wonder if that was the part I wrote on cellphone or the part I wrote when I should have been sleeping… Fixed now :slight_smile:

It seems also that @papajoke may have fixed one of the issues causing 255 errors. Running git version may be a good idea now. I’m hoping we can make a new release soonish. Fix some bugs, get subvolumes going, maybe add some simple features like chrooting and package selector…

I have also been working with adding support for refind, but it needs a significant amount of work still.


#286

If you want I can help and test it. If it works for refind it will also “almost” work for UEFI installs, the difference is very small in the configuration files.


#287

What do you mean by UEFI installs? Using just the efistub without any bootmenu?


#288

Yes the config files is almost the same.
Just need to call bootctl install instead of installing refind.


#289

Aah, so systemd-boot instead of pure efistub boot. Yeah, they are mostly the same, just a slightly different config format containing the same info. Systemd-boot is actually easier to script, because refind uses by default root UUID of the live system even when run in chroot, so that needs to be amended. Systemd-boot does not have this problem afaik.


#290

I’ll make a new m-a-dev package tonight for easier testing.

What would really need fixing is that/how crypttab and fstab get written for LUKS partitions. Also mkinitcpio for these cases is probably not ok. This still doesn’t work at all without manual user intervention. I think if we don’t fix it, we should remove LUKS support for now.


#291

manjaro-architect-dev-0.8.8.r11.ge60af31 is now available on unstable branch. You can directly install it with

sudo pacman -U https://www.uex.dk/repos/manjaro/unstable/community/$(uname -m)/manjaro-architect-dev-0.8.8.r11.ge60af31-1-any.pkg.tar.xz

#292

I just want to say explicitely that it is a great thing and a big step foreward that you achieved to implement btrfs subvolume creation. Several users have already asked for it.


#293

Well it was one of the two reasons I forked Architect. I wanted an installer without qt dependencies and with btrfs subvolume support. The cli-installer had both, but with it gone…

This is way simpler implementation though. Original had maybe 10+ complicated functions and support for raid. This one is just one short function.


#294

I am tempted to try btrfs - last time I tried it was like being sucked into a blackhole.


#295

I tried it on a different distro (opensuse). After two crashes with data loss in a 4 month period I got rid if it. Its very hard to determine how much disk you have left, or where all your storage went. And the sequence of things you have to do in exactly the right order when (not if, but when) is rather exacting and obscure.

So I’ve decided to give it a 5 year time-out. There’s actually nothing it does that I need done. It makes the simple very complex.


#296

That is the blackhole my diskspace got sucked into - I am not so tempted anymore.


#297

This is because OpenSuSe creates snapshot per Snapper every time you do sth with Yast. And deletion of old subvolumes trails behind.
Im using btrfs in 32GB SSDs and never got any issues with space. I don’t use Snapper, create snapshots manually in terminal.

@Chrysostomus Root subvolume creation and mounting works now. If the user chose not to format the followinig command will set custom mount options
sudo mount -o remount,… -t btrfs /dev/sda1 /mnt


#298

I’m using Snapper, but turned off the timeline creation. Saves a lot of resources!


#299

In case this is still actively developed, with the newest Testing / Unstable updates, desktop install is now broken (something about xorg-utils not in repo)


#300

Yes, this is because the manjaro-tools-iso-profiles has not been updated to match. Use development profiles under the advanced menu.