Manjaro-architect 0.8


#221

I’m happy that it has been of use to you


#222

Hi, I detected an issue that there is a possible syntax error in creating /etc/pacman-mirrors.conf:


The problemis it writes a slash ‘/’ after the branch value.
.m-a.log

    :: manjaro-architect 0.8.0-3 ::

03/17/17 00:52:22 system: UEFI, init: systemd nw-client: nmtui 
03/17/17 00:53:10 refresh database 
03/17/17 00:53:33 loadkeys de 
03/17/17 00:59:59 rm 1 on /dev/sda 
03/17/17 00:59:59 /dev/sda is 
03/17/17 00:59:59 /dev/sda mklabel gpt 
03/17/17 00:59:59 create ESP on /dev/sda 
03/17/17 00:59:59 set boot flag for /dev/sda 
03/17/17 00:59:59 create ext3 100% on /dev/sda 
03/17/17 01:19:12 --------- [lsblk] ------------
03/17/17 01:19:12 /dev/sda1 256M
03/17/17 01:19:12 /dev/sda2 29.6G
03/17/17 01:19:12 /dev/sdb1 529M
03/17/17 01:19:12 /dev/sdb2 46M
03/17/17 01:19:12 /dev/sdc1 2.5G
03/17/17 01:19:12 /dev/sdc2 5G
03/17/17 01:19:12 already mounted: sdb1
03/17/17 01:19:13 ignore crypted: /dev/sdc2
03/17/17 01:19:13 in partitions delete item /dev/sdb1 no: 4 / 5
03/17/17 01:19:13 partitions: /dev/sda1 256M /dev/sda2 29.6G /dev/sdb2 46M /dev/sdc1 2.5G /dev/sdc2 5G
03/17/17 01:19:13 in partitions delete item /dev/sdc2 no: 8 / 9
03/17/17 01:19:13 partitions: /dev/sda1 256M /dev/sda2 29.6G /dev/sdb2 46M /dev/sdc1 2.5G
03/17/17 01:19:43 create mountpoint /mnt 
03/17/17 01:19:43 mount /dev/sda1
mount: wrong fs type, bad option, bad superblock on /dev/sda1,
       missing codepage or helper program, or other error

       In some cases useful info is found in syslog - try
       dmesg | tail or so.
03/17/17 01:20:01 --------- [lsblk] ------------
03/17/17 01:20:01 /dev/sda1 256M
03/17/17 01:20:01 /dev/sda2 29.6G
03/17/17 01:20:01 /dev/sdb1 529M
03/17/17 01:20:01 /dev/sdb2 46M
03/17/17 01:20:01 /dev/sdc1 2.5G
03/17/17 01:20:01 /dev/sdc2 5G
03/17/17 01:20:01 already mounted: sdb1
03/17/17 01:20:02 ignore crypted: /dev/sdc2
03/17/17 01:20:02 in partitions delete item /dev/sdb1 no: 4 / 5
03/17/17 01:20:02 partitions: /dev/sda1 256M /dev/sda2 29.6G /dev/sdb2 46M /dev/sdc1 2.5G /dev/sdc2 5G
03/17/17 01:20:02 in partitions delete item /dev/sdc2 no: 8 / 9
03/17/17 01:20:02 partitions: /dev/sda1 256M /dev/sda2 29.6G /dev/sdb2 46M /dev/sdc1 2.5G
03/17/17 01:20:15 create mountpoint /mnt 
03/17/17 01:20:15 mount /dev/sda2
mount: wrong fs type, bad option, bad superblock on /dev/sda2,
       missing codepage or helper program, or other error

       In some cases useful info is found in syslog - try
       dmesg | tail or so.
03/17/17 01:20:37 mkfs.vfat -F32 /dev/sda1 
03/17/17 01:20:44 create /mnt/boot/efi 
03/17/17 01:20:44 mount /dev/sda1 /mnt/boot/efi 
03/17/17 01:22:02 unmount /mnt/boot/efi 
03/17/17 01:22:02 --------- [lsblk] ------------
03/17/17 01:22:02 /dev/sda1 256M
03/17/17 01:22:02 /dev/sda2 29.6G
03/17/17 01:22:02 /dev/sdb1 529M
03/17/17 01:22:02 /dev/sdb2 46M
03/17/17 01:22:02 /dev/sdc1 2.5G
03/17/17 01:22:02 /dev/sdc2 5G
03/17/17 01:22:02 already mounted: sdb1
03/17/17 01:22:03 ignore crypted: /dev/sdc2
03/17/17 01:22:03 in partitions delete item /dev/sdb1 no: 4 / 5
03/17/17 01:22:03 partitions: /dev/sda1 256M /dev/sda2 29.6G /dev/sdb2 46M /dev/sdc1 2.5G /dev/sdc2 5G
03/17/17 01:22:03 in partitions delete item /dev/sdc2 no: 8 / 9
03/17/17 01:22:03 partitions: /dev/sda1 256M /dev/sda2 29.6G /dev/sdb2 46M /dev/sdc1 2.5G
03/17/17 01:22:18 mount /dev/sda2 as mkfs.btrfs -f. 
03/17/17 01:22:18 create mountpoint /mnt 
03/17/17 01:22:55 mount /dev/sda2 compress-force=lzo,noatime,ssd
03/17/17 01:23:22 mkfs.vfat -F32 /dev/sda1 
03/17/17 01:23:27 create /mnt/boot/efi 
03/17/17 01:23:27 mount /dev/sda1 /mnt/boot/efi 
03/17/17 01:41:12 rank_mirrors branch unstable
03/17/17 01:41:50 update profiles pkgs 
03/17/17 01:41:58 init systemd
03/17/17 01:42:21 selected: linux410
03/17/17 01:42:33 modules: KERNEL-acpi_call
03/17/17 01:42:33 filter_packages 
03/17/17 01:42:35 packages to install: linux410 b43-fwcutter bash btrfs-progs bzip2 coreutils crda dhclient diffutils dmraid dnsmasq dosfstools e2fsprogs ecryptfs-utils efibootmgr exfat-utils f2fs-tools file filesystem findutils gawk gcc-libs gettext glibc grep grub gzip inetutils intel-ucode iproute2 iptables iputils ipw2100-fw ipw2200-fw jfsutils less licenses linux-firmware logrotate lsb-release man-db manjaro-firmware manjaro-release manjaro-system man-pages memtest86+ mhwd mhwd-db mkinitcpio-openswap nano ntfs-3g os-prober pacman pciutils pcmciautils perl procps-ng psmisc reiserfsprogs sed shadow s-nail sudo sysfsutils acpid cpupower cronie cryptsetup device-mapper dhcpcd haveged lvm2 mdadm nfs-utils rsync systemd-sysvcompat tlp wpa_supplicant tar texinfo usbutils util-linux which xfsprogs zd1211-firmware nilfs-utils 
03/17/17 01:53:22 install basepkgs ==> Creating install root at /mnt
03/17/17 01:53:22 copy vconsole.conf
03/17/17 01:53:22 set target branch unstable 
03/17/17 01:53:22 base installed succesfully.
03/17/17 01:53:35 update profiles pkgs warning: manjaro-iso-profiles-base-17.0-2 is up to date -- reinstalling
03/17/17 01:53:42 selected: [Manjaro-bspwm]
03/17/17 01:53:42 filter_packages 
03/17/17 01:53:56 selected 'full' profile
03/17/17 01:53:58 packages to install: acpid adwaita-maia-gtk3 alsa-firmware alsa-plugins alsa-utils atool b43-fwcutter bash bc bmenu brandr breeze-maia-icon-themes bspwm-manjaro bspwm-ruler bspwm-scripts bspwm-wallpapers btrfs-progs bzip2 clonezilla compton coreutils cpupower crda cronie cryptsetup dash dconf delayed-hibernation desktop-file-utils device-mapper dfc dhclient dhcpcd diffutils dmraid dnsmasq dosfstools downgrade dunst e2fsprogs ecryptfs-utils efibootmgr exfat-utils f2fs-tools feh file file-roller filesystem findutils gawk gcc-libs gedit gettext glibc gnome-disk-utility grep grub gufw gvfs gzip haveged hibernator htop i3lock inetutils intel-ucode inxi iproute2 iptables iputils ipw2100-fw ipw2200-fw jfsutils lemonpanel less libdnet libnotify licenses lightfirefox limepanel linux410 linux-firmware logrotate lsb-release lvm2 lxappearance-gtk3 maia-console man-db manjaro-architect manjaro-bspwm-settings manjaro-firmware manjaro-release manjaro-system manjaro-zsh-config man-pages mdadm memtest86+ mhwd mhwd-chroot mhwd-db mhwd-tui mkinitcpio-openswap moc morc_menu mpv mygtkmenui nano ncdu networkmanager networkmanager-dispatcher-ntpd nfs-utils nilfs-utils ntfs-3g openresolv os-prober pacli pacman pciutils pcmciautils perl perl-file-mimeinfo poppler procps-ng ps_mem psmisc ranger reiserfsprogs rootmenu rsync sed shadow s-nail spacefm speedtest-cli st-manjaro sudo sxhkd sysfsutils systemd-sysvcompat tar terminus-font texinfo thermald tlp tmux tree udevil usbutils util-linux which wpa_supplicant xcursor-breeze xdg-su xdg-user-dirs xdg-utils xf86-input-elographics xf86-input-evdev xf86-input-keyboard xf86-input-libinput xf86-input-mouse xf86-input-void xfsprogs xlogin xorg-server xorg-server-utils xorg-xinit xorg-xprop yaourt zathura-pdf-poppler zd1211-firmware zenity zsh-completions 
03/17/17 02:05:21 install desktop-pkgs ==> Creating install root at /mnt
03/17/17 02:05:21 copy overlay 
03/17/17 02:05:21 copy root config 
03/17/17 02:05:22 enable cronie
NetworkManager
tlp
tlp-sleep
systemd-fsck@
systemd-fsck-root Created symlink /etc/systemd/system/multi-user.target.wants/cronie.service -> /usr/lib/systemd/system/cronie.service.
03/17/17 02:05:23 disable pacman-init 
03/17/17 02:05:23 no DM installed.
03/17/17 02:06:52 basestrap -i /mnt pamac pacui fish fisherman zsh zsh-completions manjaro-zsh-config bmenu manjaro-tools-base ==> Creating install root at /mnt
03/17/17 02:07:15 Install free drivers 
03/17/17 02:08:07 uefi_bootloader grub ==> Creating install root at /mnt
03/17/17 02:08:11 grub-install --target=x86_64-efi Installing for x86_64-efi platform.
03/17/17 02:08:17 grub-mkconfig Generating grub configuration file ...
03/17/17 02:08:32 Install GRUB 
03/17/17 02:08:44 generate_fstab 
03/17/17 02:09:02 set_hostname 
03/17/17 02:09:32 set_locale 
03/17/17 02:09:52 set_xkbmap de 
03/17/17 02:10:00 set_timezone Europe/Berlin 
03/17/17 02:10:01 set_hw_clock 
03/17/17 02:10:16 set_root_password New password: Retype new password: passwd: password updated successfully
03/17/17 02:10:26 default shell: [/usr/bin/zsh]
03/17/17 02:10:42 add user to groups 
03/17/17 02:10:43 create user pwd New password: Retype new password: passwd: password updated successfully
03/17/17 02:13:01 exit installer.

Update: It is probably caused by the new pacman-mirrorlist package


#223

For some reason you seem to not be using the latest version, which would be 0.8.1.
We fixed some issues with setting the branch lately. I don’t think the faulty slash is related to pacman-mirrorlist updates.
However, please wait with trying again. I need to check if maybe it will be a good idea to update the stable m-a package again, anyway … :wink:


#224

0.8.2 is in unstable now. Would be great if you could test again with that one :slight_smile:


#225

manjaro-architect-dev-0.8.2.r11.g1172ed5 has now automatic keymap setting with the option to change it.

Also, if you run the installer for a 2nd time on the same host it will show you your last settings and ask if you want to change them (in case you made a mistake the first time … :wink: ) or not.

Please check if everything is working as expected - afaics it works as intended.


#226

I used the last version to install a flat KDE+openrc and I’ve this error:

03/22/17 14:22:48 ERROR [install basepkgs][255] ==> Creating install root at /mnt
03/22/17 14:22:56 exit installer.

just before to start to install the base package. The same error with the 8.1-1, 8.2-1 and the last version in the git. Very strange: I never got this kind of problem.

I was able to complete the test installation with an old version 8.0, that I saved on a USB key where I installed a manjaro version to test the m-a.
After booting the KDE I wasn’t able to login for a dbus sync error that was never present in previous installation I did with m-a.

I’ll retry and more info asap and I’ll try to use the m-a iso.


#227

Unfortunately these kinds of error messages are not very informative :wink:
Did you format the partition before installing? Are you sure your network connection was stable?
I’m right now running another test install with v0.8.2 and just went through base-pkg install without issue…


#228

@oberon, I know that its not very informative but… its all I know and I was able to recover from the log.
The news are that: I repeat the installation after upgrading the USB key (aligned with unstable repo) and:

  • the previous error [255] disappear
  • apparently all is correct and the installation is completed, but
  • when I logjn, from sddm, appear a dialog box with: " Could not sync environment to dbus" and no way to start Plasma GUI.
    I can login in a tty session, but…

The previous error (03/22/17 14:22:48 ERROR [install basepkgs][255] ==> Creating install root at /mnt) is yet present if I launch m-a inside the standard environment (aligned with the stable repo, Plasma-openrc-btrfs and last m-a version). Very strange cause I never got similar error and, I installed at least 30 different environments, in testing, without any kind of problems.

Something changed, but I’m not able to understand what is changed. If you have an idea about the info I can send you, tell me and I do. I was using m-a to install testing environment, with openrc, to test elogind.


#229

@oberon, some more info.

USB key with manjaro-architect-iso. I did the installation using the iso with the unstable repo and elogind yet present (!!!): all right.

Only a small error during the boot: “Cannot open the font file ter-118n”

So, probably the previous error with dbus I suppose that is related with a mixed installation: consolekit/elogind, the boot key with consolekit, the installed environment with elogind and something went wrong. Which is the script that generate the error [255]? I suppose that 255 is the shell program line :slight_smile:

Anyway its a strange error: I restarted always with a clean disk (a new disk partition, old BIOS partition for me), no problem with the internet connection (a full 50Mbit).

Question: is it possible to “configure” the m-a iso to work with the stable environment? Simply define the stable repo in pacman-mirrors.conf?


#230

terminus-font is not installed by every profile - we need to think about how to handle that…

Error 255 is an undefined exit code “out of range” - it shows for example when a package could not be downloaded - we will not know for what reason exactly…
Regarding repo branch: When you use the pacman-mirrors function of the menu, the branch you choose will be used for the target. If you don’t use it, the branch of the host will be used. Current manjaro-architect ISO was built against unstable branch, so it will be unstable branch if you don’t change anything. This will change soon, and the ISO will use stable branch in the future, making this the default automatically.


#231

@oberon, thanks for the fast answer! A question: is possible to understand which is the shell program that generated the [255] error?

It is generated immediately after starting the Install base and after the alignment of the repo.

I’ll retry, later, to repeat the installation with different environment just to try to understand the why of the error. :slight_smile:


#232
$ pacman -Qi manjaro-architect-dev
Name            : manjaro-architect-dev
Version         : 0.8.2.r12.gdf8a4f3-1

I like this.

But I think the default button selected should be No, instead of Yes.

I still don’t understand why the virtual console is selected at installer startup, instead of remaining a part of Prepare Installation. If a user has a non standard keymap, or accidently select the wrong one, they would have to exit m-a and launch it again simply to change the keymap.

Having a keymap automatically linked to the selected language should remove the need to change it for a vast majority of users.

At the very least this setting needs to be re-included in Prepare Installation -> Change Virtual Console, otherwise the keymap cannot be changed without the “logout -> login” dynamic.

Previously there were more DEs that were systemd only, now only Gnome. Is this correct?

Just confirming that DEs like Budgie and Deepin are now openrc compatible, and thus will need to be tested once the new menu structure is implemented?

Given Gnome is now an official flavour is work being done to make it openrc compatible?

I assume this display driver duplication is being worked on, just including it for completeness sake.

Install KDE systemd successful, will wait until the new menu structure fully implemented before giving it a serious thrashing again, unless there is new functionality that requires spot testing, which I’ll keep an eye out for.


#233

Openrc profiles moved to using elogind instead of consolekit. Which seems to be basically logind, but without systemd dependence. This can potentially make budgie and possibly even gnome work with openrc. But I don’t think that they are still thoroughly tested. The reason that some profiles are no longer listed as openrc incompatible, is that openrc tags were added to them. We don’t yet know if they work with openrc or not.

Keeping vconsole selection also in preparation menu seems reasonable to me. The user will not need to type anything before that.


#234

I don’t understand the advantage of waiting with vconsole settings until later. If the user makes a mistake then, he will still have to relaunch the installer and then do all the steps again until he can correct vconsole settings. Isn’t it better to have that immediately at the beginning where restarting will not be a big deal?


#235

Ah. now I get it. Sorry :wink:


#236

Hi oberon, is there a new m-a ISO in the pipeline?


#237

Something is still not right with our list. Deepin should definitely be listed with Gnome :wink:
edit: The list is correct from what is now actually in the profiles .


#238

'LLo,

I virtually tried it with E & after 2/3 trials works nicely, congrats !
Nice to see connman which is the one E prefers.
It sounds syslinux still appears as alternative bootloader in the dedicated box instead of grub + os-prober


#239

Not for me

Is it possible that you are using an old version of the installer?
Or you mean, you would like to have the alternative back? It needs some more work in the future… :wink:


#240

Ah :laughing: Now I see what you mean! :wink: :stuck_out_tongue:
We need to change that text, yes.