Manjaro-architect 0.8

pacman -Qi sddm-elogind
error: package 'sddm-elogind' was not found

I’m afraid I don’t know much about these packages. but I would assume, since @artoo is the expert for exactly that his lxqt profile will certainly be configured correctly with packages.

I don’t know and don’t have hardware to test the issue. My gut feeling is that it installs only graphics drivers.

Would you like to test it? If it installs network drivers, they are probably installed only with nonfree option.

Yes. I have no idea why we have both. sddm-elogind was just the only package where I could grep anything about pam … :wink:

In any case, new -dev package 0.8.0.r57.g0912cff is in unstable.

1 Like

artoo is testing the elogind packages as a replacement for consolekit: Switch from consolekit to elogind

1 Like

I’ll install a test systemd system, login, remove all mhwd drivers, then run mhwd -a to test.

Don’t want to mess around with my host systems.

mhwd -a pci free/nonfree 0300
installs graphics card drivers!

0300 is the ID for graphics cards. As the mhwd command develops, new ids will be used for other hardware devices

(Manjaro Wiki) :wink:

@sueridgepipe @Chrysostomus

1 Like

Yeah, that’s where the gut feeling I mentioned came from. Is there a code that automatically installs network drivers?

Ah well! But you can do, as I just realize:

mhwd -a pci free/nonfree 0200

for network drivers! :laughing:
Never heard of that before!
I just looked up the classid for network drivers and typed it in :wink: Seems to work.

1 Like
$ sudo mhwd -a pci free 0200
[sudo] password for bernhard: 
> Skipping already installed config 'network-broadcom-wl' for device: 0000:02:00.0 (0200:14e4:4359) Network controller Broadcom BCM43228 802.11a/b/g/n
> Skipping already installed config 'network-r8168' for device: 0000:03:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
1 Like

Good find on the mhwd -a network drivers, @Chrysostomus this should make network card installs easier now… :slight_smile:

Same issue as with LxQt system, new KDE openrc install hangs on boot, so probably issue with new polkit-consolekit as last week’s install successfully booted.

The KDE system doesn’t have an /var/log/auth.log file though, unlike the LxQt system, so I can’t find the same log message.

From sddm.log

$ cat sddm.log
...
[13:53:31.277] (WW) DAEMON: Auth: sddm-helper exited with 6
[13:53:31.277] (II) DAEMON: Greeter stopped.
[13:54:16.419] (WW) DAEMON: Signal received: SIGTERM
[13:54:16.419] (II) DAEMON: Socket server stopping...
[13:54:16.419] (II) DAEMON: Socket server stopped.
[13:54:16.419] (II) DAEMON: Display server stopping...
[13:54:21.424] (II) DAEMON: Display server stopping...
[13:54:21.437] (II) DAEMON: Display server stopped.
[13:54:21.437] (II) DAEMON: Running display stop script  "/usr/share/sddm/scripts/Xstop"

You can check with the following commands

If it shows the same output, then maybe it is rather an issue with the profile which is being adapted at this very moment. It can be fixed, but probably not worth the effort, as artoo is switching to elogind and will be dropping consolekit.

Thanks, same output with the getent commands after chrooting into the lxqt and kde systems, so as you suggest best to wait until elogind switcheroo is complete, then re-install to test.

I just installed xfce systemd on a Dell Optiplex 3020. I plan on using it as my family pc. I need to redo one of my laptops but I wnat to be Openrc so I will wait on it. I had it on unstable and stupid me I updated it even though I knew I wasn’t supposed to so it won’t boot at all. Oh well Reading is fundamental. :disappointed::grimacing:

Just pushed out new -dev packages of the current git situation:
manjaro-architect-dev-0.8.0.r85.gb369839 plus
manjaro-architect-dev-launcher-0.8.0.r85.gb369839

Latest fixes, additions and changes include:

  • keymap selection now happens immediately at the beginning, together with language selection.
    Like that we have one less menu entry in ‘prepare’ section and your keyboard (aswell as a matching font for your selected language) is configured correctly right from the start, also in a live session.
  • drivers installation logistics is still not 100% what it will be I think, but in any case network drivers menu needed a fix in regards of being able to select multiple entries (LAN plus wireless …)
  • We played around a little with error handling during package installation. So abortion or failure should now work and be handled properly.
  • some more polishing of dialogs and feedback - also in German :wink:
  • Cancel action of UEFI /boot mount needed a fix
  • filtering already mounted devices was fixed
  • under the hood we have now started to integrate a cool feature proposed and supplied by @papajoke: system and user choice information can now be collected and reused with an ini file. This has great potential for the future, like what we have already been discussing, collecting all information before applying all the needed action in the best logical order at the end.
    Or also even: provide the installer with a configuration file to (re)produce a certain chain of action/apply a predefined set of configuration - really exciting!

Have fun with more testing!
If all goes well we might point-release a 0.8.1 stable package very soon.
Today I bravely installed a Manjaro-Deepin system on a spare partition of my production laptop and all went well, yeah! :wink: - well, the Deepin desktop is terribly buggy these days, but that’s certainly not the installer’s fault :laughing:

7 Likes

Tried yesterday an i3 installation with OpenRC in a vbox, changed the branch in the pacman-mirrors.conf into stable. Everything went well, very neat project!

2 Likes

Two hours ago I did a new install on a Centrino Duo Laptop.
(not the last version that was released 45 min ago…)

Installed kernel 4.8 (this is the last one I can use on this laptop)
Installed OpenRC
Installed Mate
Installed wingo (tiling window manager)
Installed conky

All is good.

Awesome work guys/gals :slight_smile:

3 Likes

Not sure what’s going on there @sueridgepipe. I just made a testinstall lxqt, which includes sddm of course and it is working fine. No issues … hm.
I used Manjaro profile straight forward install in vbox.
@Chrysostomus I like the automatic network driver install in the background and video-driver selection at the end very much!

For the advanced menu we could refine the manual network menu function further by adding free/nonfree options.

2 Likes

Forum kindly sponsored by Bytemark