Manjaro and RockPro64 no WiFi?

With pleasure I’ve installed Manjaro on my Sdcard for my RockPro64.

But now my WiFi isn’t working? Although the bluetooth is working. I already tried the to install some of the AP6**** drivers available on the AUR resp. And I did rebooted the RockPro after each time I installed a driver. But no luck.

Anyone a clue what might be wrong?

Can you share the exact model of the wifi chip? Ap6???

We have it’s firmware package in our repo i suppose.

I will be getting mine next week so I can test it out.
Off to sleep now so will reply tomorrow.

Thanks for your quick reply. I’ve just seen that the Wifi board they sell now on is different then the one that I have. I’ve got mine a couple years now and it’s this one:

Note: This module compatible with ROCKPro64 SBC.
Based on AMPAK AP6359SA Combo Module and made specifically for the ROCKPro64 SBC.
This module has simultaneous dual band – which is critical for low latency wireless streaming for gaming
IEEE 802.11 AC/A/B/G/N dual band 2.4GHz/5GHz 2T2R MIMO WiFi with Real-time Simultaneous Dual Band (RSDB) and Bluetooth 4
Support SDIO Interface and HS-UART Mixed Interface.

1 Like

Can you point me to the pkgs you have tried ?

Also share the output for the following command
dmesg | grep brcm

Will give you the information tonight :slight_smile:

1 Like

We don’t have the firmware for the ap6359sa chip. Sorry.

Looks like ap6359SA uses the Broadcom chipset BCM4359 and support was supposed to be in the kernel according to mrfixit here in this dated thread. He found one source for firmware that works and gave a link. There are 3 “Add AP6359SA firmware” files there. I do not have the addon module to test as it is not available anymore. I do not know if just adding the 3 firmware files to /usr/lib/firmware/brcm/ will now work or not or if the .dts also needs to be modified or time has passed this chipset by.


Hmmm… I’ve downloaded those files and wanted to copy to them to that directory. But it won’t let me.
And looked around in that directory and there seems already a file for that BCM4359.

Sorry just a beginner with Linux…

sudo cp complete-name-of-file /usr/lib/firmwar/brcm/

Repeat until you get all 3 files copied over and then reboot.

You where bit too early :smiley: I’ve just found out that worked instead of dragging. Still no luck with the Wifi firmware. Do I maybe need to change some register file to load the firmware?

I do not know what or if anything can be done. None of us dev’s have that obsolete module.

I see. Then the best thing is looking for a simple WiFi USB dongle and going to try that.

Thanks a lot for your help folks! :smile:

Good choice. It just is not feasible for us to support any device that is obsolete. As time goes by with the newer kernels the support for the obsolete devices will disappear.

1 Like

Can you share what exactly did you do with the firmware files?

Maybe we need to rename one of the file.

I’ve downloaded the 3 files ( for example nvram_ap6359sa.txt ) and copied them into the /usr/lib/firmware/brcm/ directory.

Try renaming it to something like pine64,rockpro64.txt.

1 Like

Will try it tomorrow. Had to fish the WiFi board out of the trash can since I already removed it from the RockPro64 and thrashed it lol…

I used this command and it seems something isn’t right.

These are the files i’ve copied to the directory:

  • BCM4359C0.hcd
  • fw_bcm4359c0_ag.bin
  • fw_bcm4359c0_ag_apsta.bin
  • nvram_ap6359sa.txt


I know the Debian image for the Rockpro64 it’s WiFi is working. Is it possible to find the drivers there and copy them to Manjaro?

copy this file to this directory with the name

Depending on the dtb you’r using, check that from /boot/extlinux/extlinux.conf but looking at the dmesg it is using v2.1 are you sure your board is v2.1 ?


I tried this :
copy this file to this directory with the name

Now the network Icon right side taskbar does say more things like WiFi Networks. But can’t make a connection.