Manjaro acting very slow

I have been using manajro for almost a month and what i most liked i it was the speed it got.But weirdly it has become sluggish from last 3 days.Everything is super slow despite rebooting many times and running the update command.Please help me to make it better again.The most important points are bellow :

  • Brave browser is super slow especially in youtube despite reinstalling and even changing the branch from stable to beta and then again to stable along with clearing data and resetting everything.
  • Zoom client is super slow.It even gets the trailing window shadows when dragging a zoom window.

DIstro details :

Operating System: Manjaro Linux
KDE Plasma Version: 5.19.4
KDE Frameworks Version: 5.73.0
Qt Version: 5.15.0
Kernel Version: 5.8.3-2-MANJARO
OS Type: 64-bit
Processors: 4 × Intel® Core™ i7-7500U CPU @ 2.70GHz
Memory: 7.4 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 620

can you return

inxi -Fza 

I tried to paste here but it says “Sorry, you can’t include links in your posts.”

  Kernel: 5.8.3-2-MANJARO x86_64 bits: 64 compiler: N/A
  parameters: BOOT_IMAGE=/vmlinuz-5.8-x86_64
  root=UUID=eb1b3616-27ac-418c-9754-9ff4a3e014a2 rw quiet apparmor=1
  security=apparmor udev.log_priority=3
  Desktop: KDE Plasma 5.19.4 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM
  Distro: Manjaro Linux
  Type: Laptop System: Dell product: Vostro 14-3468 v: N/A serial: <filter>
  Chassis: type: 9 serial: <filter>
  Mobo: Dell model: 0VCX0K v: A00 serial: <filter> UEFI [Legacy]: Dell
  v: 2.6.0 date: 05/15/2018
  ID-1: BAT0 charge: 28.8 Wh condition: 29.1/41.4 Wh (70%) volts: 17.2/14.8
  model: SMP DELL VN3N047 type: Li-ion serial: <filter> status: Charging
  Topology: Dual Core model: Intel Core i7-7500U bits: 64 type: MT MCP
  arch: Amber Lake family: 6 model-id: 8E (142) stepping: 9 microcode: D6
  L2 cache: 4096 KiB
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  bogomips: 23209
  Speed: 1569 MHz min/max: 400/3500 MHz Core speeds (MHz): 1: 1160 2: 1168
  3: 1120 4: 1245
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
  IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel HD Graphics 620 vendor: Dell driver: i915 v: kernel
  bus ID: 00:02.0 chip ID: 8086:5916
  Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
  bus ID: 1-5:2 chip ID: 0c45:6a05
  Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: intel
  unloaded: modesetting alternate: fbdev,vesa display ID: :0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0")
  s-diag: 414mm (16.3")
  Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 112 size: 310x170mm (12.2x6.7")
  diag: 354mm (13.9")
  OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.1.6
  direct render: Yes
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus ID: 00:1f.3
  chip ID: 8086:9d71
  Sound Server: ALSA v: k5.8.3-2-MANJARO
  Local Storage: total: 465.76 GiB used: 27.87 GiB (6.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda vendor: Toshiba model: MQ01ABF050 size: 465.76 GiB
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
  rotation: 5400 rpm serial: <filter> rev: 2D scheme: GPT
  ID-1: / raw size: 44.91 GiB size: 43.96 GiB (97.87%)
  used: 15.14 GiB (34.4%) fs: ext4 dev: /dev/sda8
  ID-2: /boot raw size: 6.00 GiB size: 5.84 GiB (97.39%)
  used: 126.0 MiB (2.1%) fs: ext4 dev: /dev/sda4
  ID-3: /home raw size: 71.04 GiB size: 69.42 GiB (97.72%)
  used: 11.14 GiB (16.0%) fs: ext4 dev: /dev/sda14
  ID-4: /opt raw size: 26.42 GiB size: 25.88 GiB (97.96%)
  used: 1.48 GiB (5.7%) fs: ext4 dev: /dev/sda15
  Kernel: swappiness: 60 (default) cache pressure: 100 (default)
  ID-1: swap-1 type: partition size: 7.45 GiB used: 0 KiB (0.0%)
  priority: -2 dev: /dev/sda10
  System Temperatures: cpu: 48.0 C mobo: 44.0 C
  Fan Speeds (RPM): cpu: 0
  Processes: 200 Uptime: 5h 03m Memory: 7.44 GiB used: 1.73 GiB (23.3%)
  Init: systemd v: 246 Compilers: gcc: 10.2.0 clang: 10.0.1 Packages:
  pacman: 1337 lib: 363 flatpak: 0 Shell: Zsh v: 5.8 running in: alacritty
  inxi: 3.1.05

you need to update your bios

and be careful on UEFI[legacy]
that means i should boot EFI , and for some options in bios, it failback to Legacy

think to put SSD for plans

1 Like

Sucsessfully updated the mentioned BIOS update but active destop corners are still not working… what should i do now?

You should try to add a SSD to your computer.

then check in journal log

sudo journalctl -b0 -p4 ( option -b -1 boot before , etc... )


I have the same problem. Freshly installed Manjaro XFCE on a beefy laptop with powerful CPU, SSD, tons of memory and GTX 2080. Everything is super slow and laggish: typing on keyboard, starting applications, moving mouse pointer. What is funny, I first tried the same distro on a virtual machine running on this laptop. It was very responsive.

@schiks, update your Manjaro OS by

sudo pacman-mirrors -f && sudo pacman -Syyu

When the system is sluggish open htop from a terminal window and let us know what tasks are taking your CPU time.


I am not that ignorant. The system is fully updated. CPU load is near zero. Besides, the CPU has 8 cores. It’s nearly impossible to load it in manner it would really mater for the UI to be that sluggish.

I found out that the problem manifested itself only in a scenario where I use an external monitor. It was solved by removing “video-hybrid-intel-nvidia” and installing “video-nvidia” driver.

1 Like

Check for baloo file indexer. I had the same issue where Manjaro KDE was very slow. So I just disabled and deleted this file indexer. The only downside to this is that you won’t be able to search file in Dolphin and those categories on the left side left side will be disabled.

1 Like

How you updated the bios please tell
I don’t know, but I would like to know