Manjaro 32 Bit will not start from today

I don’t know what happened but Manjaro-32 bit KDE doesn’t boot and I cannot see the login screen, even Manjaro Live USB will not boot

What could I do? How can I reach my desktop?

Any help would be much appreciated

Arch (except for multilib packages) and Manjaro dropped 32bit support. A list of distribution with 32bit support on x86 hardware can be found in this thread:

It was discussed in the old forum already in detail.

https://archived.forum.manjaro.org/t/dropping-32-bit-support-again/130608/39

1 Like

It was working an hour ago but now it will not even reboot.

At least I need to save my files by chroot but now I am not even able to :frowning:

To save your files you only need to mount the partitions, chroot is not needed for that.

1 Like

But I cannot reboot manjaro-32 kde, I’ve tried all of those kernels that’s installed but it will not boot and it only shows manjaro green logo and Manjaro Live USB kde will not even boot :frowning:

I didn’t update it for a while maybe a security issue I am not sure but I have to save my files :frowning:

OK, then you really have a problem. :worried:

I would try to get a way to produce any 32bit live iso, so that you can at least mount your partitions to save your files. What Linux distro does not matter, see the link I posted. You might need another computer for that work, of course.

1 Like

There is something odd here.

Manjaro32 have not had a package repo for months - the 32-bit branches was replaced with Manjaro ARM project.

So - as it cannot be an update nor a package installation - it must be hardware related.

If the system is a 32-bit system - then a Manjaro live ISO will not work.

You need a distribution supporting 32-bit.

2 Likes

You could try to mount via a Live distribution on USB. I cant attach links, but try some of the ones intended for older systems like puppy linux.

Failing that, move your storage to a different computer and boot the live-usb there.

1 Like

I don’t know why the system stopped working itself but maybe @philm could help me with this :frowning:

Jonathon left the building - and I don’t think Philip has time for this.

1 Like

@Wollie @linux-aarhus

I would appreciate it guys

If I cannot login to my manjaro-32 anymore, how can I save my files on desktop because I am not able to use Manjaro 32 bit kde Live USB right now

For example if I can use Puppy Linux distro Live USB to save my files on manjaro, how can I do that? because that ssd partition event could ruin my files :frowning:

Waiting for your help man :frowning:

Okay… I’m guessing there’s a bit of base knowledge here missing.

Linux is a collection of tools, utilties, programs and such that are bundled into distributions. Manjaro is one of those, Arch is another as is Debian, RedHat, etc, etc, etc. They all have differences, but a lot of similarities too.

What you are looking for is a linux distribution that will boot on your hardware that can read the filesystem on your original disk that wont boot. Most likely your original disk has a filesystem something like ext4 which is fully supported on basically every available linux distribution today.

So, without getting into a step-by-step, I’d recommend you simply try a few lightweight live linux distributions aimed at older hardware (32-bit) like puppy or slax or dsl or… there are many.

when you boot you will quickly be able to tell if it can see your disk (fdisk -l) and if you can mount it properly (mount /dev/yourdeviceidhere /somedirectory) – and this is assuming the GUI doesn’t do it for you automagically.

The last piece of the puzzle is the question – where do you want to put your data? Is it on another USB stick? Is it on a network NAS?..

2 Likes

If I understand it right, now I am creating a Puppy Linux Live USB and then booting with it via USB and then when I see Puppy Linux desktop I will be able to see my files on manjaro-32? Am I wrong? What if Puppy Linux Live USB doesn’t boot? because of manjaro-32 kde :frowning:

1 Like

At a high level, that’s correct.

You havent provided a lot of detail so I am working on the assumption that your system wont boot because of the 32/64-bit stuff and that your hardware has not actually failed.

If that assumption is correct, puppy should be able to boot, should be able to mount your disk/access your data and comes with ability move the data somewhere you want it.

Now, if your hardware has failed… lets go over two possibilities:

  1. your hardware has failed but your disk is healthy – the usb boot may or may not work depending on what’s failed. Another option is moving your disk to a different (working) computer and accessing it there.
  2. your disk has failed – in this case, puppy will boot, but will not be able to see/mount your disk. In this case you go to your backups (which i am guessing you do not have) or go to data recovery services. <-- there are live distributions dedicated to recovery of data, but if the data is truly irreplaceable and you are not an advanced user, I’d pay for the services to ensure you do not make it worse.

Now again, I am working on little information here… there are other situations that would make your disk unreadable to other distributions such as corruption and human error (ddd if=/dev/random of=/dev/sda or rrm -r / – anybody? :D) <-- seriously do NOT do those and i intentionally broke the commands in the nasty examples on how to make your disk unreadable to prevent a copy-paste mistake… or even by design such as full disk encryption.

All I am suggesting is it doesnt hurt to try booting with a live distribution and see if you can see your disk and get to your data. :slight_smile:

2 Likes

Will give it a try man, Big Thanks

Will be in touch :raising_hand_man:

Hello guys @lrissman @linux-aarhus

It didn’t work :frowning_face:

I created a bootable Puppy Linux Tahrpup 32 Bit USB using UNetbootin but it didn’t automatically boot I mean the computer closed itself after a while :frowning_face:

I tried Bodhi Linux and the same happened I mean I clicked on “Try Bodhi Linux without installing” and the computer closed itself again. (I don’t know if it’s the PAE thing)

I’ve no idea what caused this and Manjaro KDE did (I didn’t update Manjaro KDE for months because of some issues) but I need to take my Manjaro KDE back to save my files immediately :frowning_face:

Seeking your help guys

Can you be specific what you mean by “The computer closed itself after a while”?

Or more specifically, when you made the USB boot, and tried to boot the computer with it:

  • Did you use the F9, Del, F12 or whatever hotkey your computer needs to choose to boot from USB vs disk?
  • did it start to boot?
  • how far along the boot process did it make it? (if at all) Eg… Did it make it through the text boot and then crash on the graphical portion? Not at all?
1 Like

I mean shutdown without booting into live desktop login

I know how it works because I used to boot Manjaro 32 KDE Live USB I mean I could try it without installing it you know

I don’t know man maybe UNetbootin isn’t able to create bootable USB? :frowning_face:

Can you walk me through what you see step-by-step?

Eg… 1) I see the system post (Asus logo, or bios logo or something)
2) I hit the hotkey to choose boot menu
3) I choose the USB
4) It starts boot of the USB…

You can also test the USB on the system you created it on – i am guessing you have another computer handy.

If the live boot usb doesnt work on the working computer, i’d try a different tool. for linux I use dd. For windows, I’ve had good luck with rufus.

And here’s a thought… if the broken computer and the computer you created the USB on are both desktops, you can probably move the disk from the broken to the working computer. If the working computer is linux, it should just read. If the working computer is windows, then you can find tools to read ext4 on windows (there are a few that you can search and find) or use the boot usb to access both the linux and the windows disks… …

anyway, i’m getting ahead of myself. Start with describing what you see please.

1 Like