Manjaro 21.1.0 clean install no touchpad Lenovo IdeaPad S540 13-ARE

First time Manjaro (KDE Plasma) user, coming from Ubuntu Budgie.
On a Lenovo IdeaPad S540 13-ARE with AMD 4800U, I choose BTRFS as filesystem.

My touchpad is not recognised. I tried:

sudo libinput list-devices 
sudo cat /proc/bus/input/devices    

Nothing related to my touchpad is found. I also tried sudo ls -al /sys/bus/acpi/devices but the output does not make much sense to me.

Strangest thing: when booting from the USB disk, into the live environment, the touchpad worked just fine!

How can I solve this?
I am coming from Ubuntu Budgie which had no proper fractional scaling support for HiDPI screens. That is no issue for Manjaro.

The only other issue is backlight β€œ-” button, β€œ+” works fine to increase backlight, but β€œ-” turns screen off, while it also lowers the backlight setting but I can’t see anything until I hit β€œ+” again.
Touchpad issue is a big dealbreaker, I hope I can solve this with some help from the forum.

Hello and welcome,

This is a good place to start investigating Lenovo IdeaPad S540 13ARE - ArchWiki

1 Like

Thanks! I thought I was 1 step closer by installing xinput, but after rebooting, the touchpad worked immediately! Even backlight β€œ-” works without turning off my screen. WOW!

It feels like I bought a new laptop :slight_smile:
Now I am not certain if I should stick with KDE Plasma, or switch to something simpler like XFCE. At least working hardware makes it a pleasure to expore Manjaro further.

1 Like

Well, that laptop seems to be powerful enough to install VirtualBox and test different DEs in a virtual machine. Once you do those tests, you can decide what works best for you.

For a stable system, do not mix DEs on the same install with the same user.

KDE Plasam has the versatility to be tweaked to look like XFCE or Gnome, or even appear as if is just a WM (like i3wm), as for resources, all DEs now are very close.