Manjaro 20 Gnome Boots To a Black Screen


I performed a fresh installation of Manjaro 20 Gnome about 3 weeks ago and it’s been running great on my custom built Asus Tuf Gaming desktop.

However, after an update today my system boots to an all black screen.

To get into the system and get the GUI I have to hold down Ctrl + Alt + F2 and login.
Once I log in I have to type startx and than I am able to use my system.

How to I fix it so that I don’t have to keep logging in through tty and run startx?

1 Like

Most likely it is GDM playing some tricks on you. You can try to use Wayland to be used by GDM. Go to /etc/gdm/custom.conf and edit the file like this:

1 Like


Thanks for the quick response. :slightly_smiling_face:

I just uncommented that line in the /etc/gdm/custom.conf and I’m off to reboot.
I’ll let you know how things go when I come back to the forum.

I edited that file and rebooted.

BTW I didn’t have anything Wayland in that file.

The system still boots to a black screen.

Any ideas?

I’ve been having a similar issue with fresh Manjaro Gnome installs recently on a laptop with a nvidia 1050ti. My temporary solution has been to ctrl + alt + f2 and startx into the gui and then use the hardware configuration tool in Manjaro Settings to Auto-Install Open Source Driver. While I no longer have easy access to the discrete gpu (which isn’t critical to my use case), GDM now works when I first boot up so I can log normally now. From what I’ve gathered from other places on the internet, there is some compatibility issue between recent kernels and the proprietary nvidia drivers.

Thanks for sharing.

Funny thing is I don’t have a Nvidia GPU.
I checked and the correct driver for my Radeon gpu is installed.

I wonder if it’s just gpu drivers in general just not loading with the new kernel?

My Gnome desktop manager is working yet it still boots to a black screen.
I used systemctl to check on the gdm.service and it’s running.

I’m out of ideas.

I found out that there is a gitlab issue.

Packages in the update that were effected were: gdm, gnome-session, gnome-shell and gnome keyring.

When I checked the journal I got unable to locate daemon control file.

I was able to fix the problem by installing lightdm.

sudo systemctl disable gdm

sudo pacman -S lightdm lightdm-gtk-greeter

sudo systemctl enable lightdm

Than I rebooted.
At reboot I was able to login normally.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.