Manjaro 20.2 Nibia got released

A post was split to a new topic: Manjaro 20.2 doesn’t start on Tuxedo Laptop

My Intel wifi is barely working booting on this iso. I get just a few Mbit up/down
Booting on the older 20.1.2 iso i get 160Mbit up/down

Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: f040 bus ID: 02:00.0 chip ID: 8086:24fd

do people normally reinstall manjaro every new releases?

hmm I usually only reinstall when disaster happened, but every reinstall there is usually new applications introduced. If not because reinstalling I would never know about gamemode and dynamic wallpaper for gnome (which is pretty cool)

I wonder if reinstalling is normal thing.

No you don’t need to reinstall anything with a new release… you can explore our app list here ( for gnome )


or install bmenu from our repo and run in a terminal
bmenu and type 9
or run releasecompare
3 Likes
sudo pacman -Rdd evolution-data-server

But

  1. The calendar probably won’t work without it
  2. Next update will automatically install evolution-data-server back

Just adding your info to this thread :wink:

Sound is getting muted everytime I restart my machine…gnome…fresh install 20.2

Dumb question. What is the difference with this vs. stable branch?

It is just a re-imageing of the iso for use as fresh install for people to install for first time.
That install will be at same stage as those that keep their system upgraded from previous versions.
In other words its just a snapshot of the stable branch at time of creation of the iso.
(If i’m wrong feel free to correct me)

1 Like

Due to an issue with user-manager package we had to rebuild all KDE ISOs. A script to fix installs with 201203 ISOs will come later.

1 Like

I’ve got the same version of Plasma (5.20.4) on my other computer (also Manjaro) and there are no issues there. The only difference is that I upgraded the system there while on my laptop (where I have issues) I installed it fresh - so my guess is it has to do something with the current Manjaro edition. Plasma is basically unusable: not only is it laggy, but some items cannot be selected, some applications cannot be added to favourites in Application Dashboard, and sometimes windows freeze and I have to force-close them. Plasma also seems to overload the system as the fans are often working excessively even when there are no serious processes running (and KSysguard shows Plasma taking up resources).

Thanks for the iso with Linux LTS Kernel :smiley:

@pawelx @Yupy @TechXero

The culprit has been found.

To immediately fix any affected install see related issues/solutions like this:

I tried Manjaro Gnome 20.2 Nibia and it works well under Wayland. Now with the final version, I can use Libreoffice-fresh with Wayland without problems. I encountered a system freeze yesterday, but otherwise there is no problem. I will try that version on my 2-in1 pc in the next days to see how it works (note: I have two laptops).

Once again, thanks for your work.

Note: If Gnome-layout-switcher and Manjaro-application-utility would be translated, it will be great.

The script has helped. Thanks!

Is there an upgrade method?

I ran the script - the Dolphin interface still locks up in the same way I demonstrated in this thread. Dolphin browser & Taskbar frequently hangs, locks up, since Nibia 20.2

Worth noting, the script had an error, attica-git was still present and so was in conflict with attica. I saved the output below (note I had already removed user-manager-git as per the instructions from a post above).

Updating package databases
:: Synchronizing package databases...
 core                  169.5 KiB   277 KiB/s 00:01 [##################] 100%
 extra                1999.3 KiB  1968 KiB/s 00:01 [##################] 100%
 community               6.3 MiB  3.81 MiB/s 00:02 [##################] 100%
 multilib              189.4 KiB  7.71 MiB/s 00:00 [##################] 100%
Removing git-packages from your system
error: target not found: user-manager-git
Installing needed stable packages to your system
resolving dependencies...
looking for conflicting packages...
:: attica and attica-git are in conflict. Remove attica-git? [y/N] 
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: attica and attica-git are in conflict
Your system should been fixed now. A reboot is recommended.

So I manually removed attica-git and added attica, with the same commands the script used, and it succeeded that time. I rebooted and still get the same lockup. Looks like I’ll have to re-install with the new ISO.

Man that was unlucky for me, I downloaded the ISO on Dec 6th and it was fixed on Dec 8th. Just spent a whole day setting up with all my software…

“touch support in dolphin”

I’ve been running Nibia for over a week on my Surface Pro 4. Touch support is not working in the Dolphin file manager. My Dolphin version is 20.08.3-1. Is there something special I need to do to enable it?

Edit: Will you folks please fix the announcement for Nibia? Manjaro 20.2 Nibia shipped with KDE Applications 20.08. Touch support was not officially added to the Dolphin file manager by the KDE Plasma Team until KDE Applications 20.12. Since KDE Applications 20.12 is currently in the unstable branch and was not released for Nibia, your announcement is not true.

Dood Do you reinstall the driver ?

Hi,
I had a small issue “removing linux58 broke dependency linux58 required by linux58-nvidia-455xx”
I have : sudo pacman -R linux58 linux58-nvidia-455xx linux58-r8168 before updating.

Take care and happy new year :earth_asia: :tada: :fireworks:

1 Like