Manjaro 20.2 does not boot

Hi, Manjaro 20.2 live usb does not boot in my Asus laptop. During boot I get lot of
[FAILED] Failed to start Load Kernel Modules errors
I didn’t found any solution to this and think this could be due to the fact that linux kernel version in live USB is not compatible to my laptop.
As a solution to this I checked archive download page to download an older version of ISO but the page there says Installation using an archived ISO may succeed but impossible to update due to ABI changes.
So wondering whether I will be able to update to latest packages if I install using 20.1.
Would you recommend to install using Manjaro testing branch?

So were you able to start the system with an older iso? If so could you please provide some general information regarding the device with inxi -Fazy?

No, didn’t tried older iso, just wanted to know whether it is a good idea to do it since the page there advice against it.
But using Kubuntu right now, here’s the inxi -Fazy output
Not able to post full output due to restrictions.

Kernel: 5.8.0-33-generic x86_64 bits: 64 compiler: gcc v: 10.2.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.8.0-33-generic
root=UUID=9ca6bc8d-76e9-4272-a400-18f26d7ec2b7 ro quiet splash
vt.global_cursor_default=0 nvidia-drm.modeset=1 vt.handoff=7
Desktop: KDE Plasma 5.19.5 tk: Qt 5.14.2 wm: kwin_x11 dm: SDDM
Distro: Ubuntu 20.10 (Groovy Gorilla)

Type: Laptop System: ASUSTeK product: X541UJ v: 1.0 serial:
Mobo: ASUSTeK model: X541UJ v: 1.0 serial:
UEFI: American Megatrends v: X541UJ.310 date: 04/18/2019

Info: Dual Core model: Intel Core i3-6006U bits: 64 type: MT MCP
arch: Skylake family: 6 model-id: 4E (78) stepping: 3 microcode: E2
L2 cache: 3072 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 15999
Speed: 800 MHz min/max: 400/2000 MHz Core speeds (MHz): 1: 771 2: 752 3: 790
4: 790
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected

Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: ASUSTeK driver: i915
v: kernel bus ID: 00:02.0 chip ID: 8086:1916
Device-2: NVIDIA GK208BM [GeForce 920M] vendor: ASUSTeK driver: nvidia
v: 455.38 alternate: nvidiafb,nouveau,nvidia_drm bus ID: 01:00.0
chip ID: 10de:1299
Device-3: IMC Networks USB2.0 VGA UVC WebCam type: USB driver: uvcvideo
bus ID: 1-6:3 chip ID: 13d3:5a01 serial:
Display: x11 server: X…Org 1.20.9 compositor: kwin_x11
driver: modesetting,nvidia unloaded: fbdev,nouveau,vesa display ID: :0
screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 98 s-size: 355x199mm (14.0x7.8")
s-diag: 407mm (16")
Monitor-1: eDP-1 res: 1366x768 hz: 60 dpi: 101 size: 344x193mm (13.5x7.6")
diag: 394mm (15.5")
OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 20.2.1
direct render: Yes

By all means, please try older ISO and see if you can catch a regression.

Tried testing ISO, its booted and installed fine.

Great. See if you can fully update your system so you have it 100% updated and working. If system fails after updating one of the packages you will know what caused the problem and can revert that one package.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.