Manjaro 20.1 - Windows partition mount issue

Hello,

I have installed Manjaro 20.1 (Gnome) in my laptop alongside Windows 10. My partition table is like below:

256 GB SSD - Windows 10
870 GB HDD - Data (Music, photos etc.) (/dev/sda1)
60 GB HDD - Manjaro (/dev/sda4)

    Filesystem      Size  Used Avail Use% Mounted on
dev             3.4G     0  3.4G   0% /dev
run             3.4G  1.7M  3.4G   1% /run
/dev/sda4        59G  7.7G   48G  14% /
tmpfs           3.4G   75M  3.4G   3% /dev/shm
tmpfs           4.0M     0  4.0M   0% /sys/fs/cgroup
tmpfs           3.4G   47M  3.4G   2% /tmp
/dev/sda2       511M  332K  511M   1% /boot/efi
tmpfs           696M   60K  696M   1% /run/user/120
tmpfs           696M   88K  695M   1% /run/user/1000
/dev/sda1       870G  680M  869G   1% /run/media/abhi/F62277A22

Each time I boot Manjaro, I need to mount this /dev/sda1 partition (NTFS) by clicking it from file manager, it’s not automatically mounting.

How Can I automatically mount this NTFS partition (/dev/sda1) during boot?

I have my music collection in that partition and adding those to Rythombox each time after boot is a pain. I need to keep this partition mounted during boot.

Thanks in advance.

Add the partition to /etc/fstab. Simply create a mountpoint ─ i.e. a “folder” ─ for it under your $HOME, e.g. /home/abhi/music. Then, edit /etc/fstab and add the following line…

/dev/sda1   /home/abhi/music   ntfs-3g  auto,defaults,uid=1000,gid=1000,umask=022,utf8   0   0
1 Like

This can change. Better to use UUID, which can be retrieved with lsblk -f

1 Like

It won’t change if there’s only one drive. :wink:

1 Like

Solved :slight_smile:
many thanks.

1 Like

Hello,

The partition is no longer write enabled, it’s read-only :frowning:

This is my /etc/fstab:

/dev/sda1 /home/abhi/Data ntfs-3g auto,defaults,uid=1000,gid=1000,umask=022,utf8 0 0

previously it was write enabled when I mount it by clicking it, now it’s auto-mounting…but read-only.

Do you have Windows Fast Boot enabled? If so, disable that, or else the kernel will regard the filesystem as dirty and will mount it read-only.

I also recommend adding rw as a mount option to the filesystem, like so… :arrow_down:

/dev/sda1 /home/abhi/Data ntfs-3g auto,rw,defaults,uid=1000,gid=1000,umask=022,utf8 0 0

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.