Manjaro 20.0 installation failed: The installation failed to create partition on disk

I got this error when installation.


My pc is MBR Legacy Bios supported
Uefi is unsupported
So i need help. Can anyone plz...

Is it because of this ?
2

If u want to know what are the partition config. then....

you cant have more than 4 partitions on MBR
in order to do that fisrt backup windows on other disk
format in GPT disk and resinstall windows

after you can install any distro linux
we do not support lvm partition with calamares manjaro

title adjusted to the correct iso version

I'm worried about losing data from other partitions. I don't care about losing windows. If i make it gpt will i lose all data? Besides my motherboard don't support uefi and its old too. Will it support gpt?
Motherboard : Gigabyte g41m combo

changing MBR to GPT is like formating disk
so first dont forget to backup
and second have you done your backup ?

last version of Bios date 2012/10/26 rev FB
windows 7 appears in 2007-2008 with EFI

Tnx for replying. I don't think i will be going to gpt any time soon :sweat_smile: but i have some questions

  1. Mbr allow only 4 partitions. But i have more then that :thinking:
  2. Where did u find my motherboard rev version "fb"?
    My motherboard official site with model
    I thought it was up to rev 2.0
1 Like

check carefully your version revision motherboard
always goes in bios section



I did checked. They never released any efi support :disappointed_relieved: infect my cpu don't even have any vt-x support

I just solve this problem :grin:
I think there's a problem with the installer. Whenever i delete any partition and recreate partition it gives me an error. Good thing is it gave error after recreating partition. So next time when i try i didn't delete partition. Instead i just format it and then it just works like usual

1 Like

BIOS can work with GPT partition scheme.

Just remember to create a 1MB 8MB bios-grub partition in Calamares. Calamares will take care of the rest.

1 Like

If I am not mistaken, it should be an un-allocated space flagged as bios_grub and not a partition.The bootloader should still be installed in the drive (/dev/sdX) and not a partition.

1 Like

Are you sure? You can use GPT with a BIOS schema.

The bios-boot partition is not formatted but it is a partition you create separately. It is also how you define it in Calamares where you assign the bios-boot partition type (0xef02) - Calamares requires it to be 8MB.

It is also used when you create a hybríd-boot device - using the multiboot script e.g. this guide

If you dissect the script it is creating a 1MB partition with the 0xef02 flag.

EDIT:

Archlinux has an archived article on the subject

2 Likes

Yes, you are right! I was mistaken about it being un-allocated space. It should, as you mentioned, be a partition but left un-formatted. The below confirms also your explanation, sorry for the nuisance.

Some newer systems use the GUID Partition Table (GPT) format. This was specified as part of the Extensible Firmware Interface (EFI), but it can also be used on BIOS platforms if system software supports it; for example, GRUB and GNU/Linux can be used in this configuration. With this format, it is possible to reserve a whole partition for GRUB, called the BIOS Boot Partition. GRUB can then be embedded into that partition without the risk of being overwritten by other software and without being contained in a filesystem which might move its blocks around.

When creating a BIOS Boot Partition on a GPT system, you should make sure that it is at least 31 KiB in size. (GPT-formatted disks are not usually particularly small, so we recommend that you make it larger than the bare minimum, such as 1 MiB, to allow plenty of room for growth.) You must also make sure that it has the proper partition type. Using GNU Parted, you can set this using a command such as the following:

parted /dev/disk set partition-number bios_grub on

https://www.gnu.org/software/grub/manual/grub/html_node/BIOS-installation.html#BIOS-installation

1 Like

No problem - I got to refresh my memory :slight_smile:

2 Likes

Same here!

:slightly_smiling_face:

2 Likes

This topic was automatically closed after 90 days. New replies are no longer allowed.

Forum kindly sponsored by