Manjaro 18.1.5 boot freeze on TLP (MSI Gl62m 7Rex)

Hello the community ! I need your help..
I wanted to switch from win10 to linux and I wanted to try Manjaro (as it seem to be a good one for programmer !??)... But as I still need some s.hit from win, I will dual-boot from 2 different storage.

The laptop is an MSI GL62m 7Rex i5 gen7 with nVidia GTX 1050Ti and 32gb RAM.
Win10 is installed in legacy mode on an HDD 2.5 sata (the stuff that come with the pc)
And for linux (as it will be my main os) I have a Samsung 970 EVO NVMe M2 1tb (in GPT mode and nothing on it).

So to be honest I directly jump into it, first I checked the Bios, disabled fastBoot, secureBoot, and put UEFI.
Then restart and boot from the usb, setup everything (non-free driver) and boot Manjaro, but the boot process stop and freeze on LTP startup/shutdown... (I tried with the free driver too, same result)

I tried to look for some info, but found only older issue who got solved by installing the last Manjaro 18.1.0 (at that time)..

So first question... If I want dual-boot with that legacy win10, should I install Manjaro in legacy mode aswell?? or UEFI will work too?
And second question, How to bypass that error ??!

Thanks a lot !!

(PS: what size should I gave to the root byTheWay? as a game dev, I use godot, blender, krita, gimp, VScode... as a webDev I need Apache.... And library stuff for some languages !!)

This doesn't answer your question but it's just an advice.
If possible I'd recommend to reinstall Windows using UEFI mode and also if possible to do it on the SSD instead of the HDD. You would see huge speed improvements in Windows by making these two changes.

You can do either.
Just remember that when mixing bios-legacy and uefi, trying to boot will require you to first go to bios or boot setup to select the option you want to boot up.
[ Manjaro's grub will not have Windows entry for you to boot to.]

Others will have to help you on this.
I don't usb install and I avoid answering questions on it.
But you should tell us how you make the install media.
Rufus? Is it with 'dd' not 'iso'? Etcher? Or others?
I'll leave you here.

I used Rufus 3.8p, and the manjaro-kde-18.1.5-191229-linux54.iso (I checked the SHA1) !! As I can't change setting, it's in default MBR.

In using Rufus, there is a selection to choose 'dd' or 'iso'. That is what I meant. You must choose 'dd'. Or you can try using etcher. Search this forum for Rufus and Etcher.
But as said, I don't use either and I have to leave this subject.

There isn't DD option in the last Rufus 3.8 !!
I will try with Etcher !!

Okay, as said, I had never used rufus or etcher or...
maybe this option is removed. I don't know and I should not continue in things I don't know.

And, regarding your TLP (not LTP, I presume - a correct description will have people helping out) issue,
you might want to look into this topic. Again, this is another topic that I declare not be conversant with and I'll again attempt to leave you here. :wink:

But if you do not have much help from others from now onwards (and I sympathize with you), I would suggest you start a new topic with a better heading than just 'need help'. (I looked into this topic because you mention 'dual-boot' which I answered). I recommend your header include 'TLP startup/shutdown' and another new topic on 'burning install media' if you need help on it.

Good luck and hope you get answers for which I cannot provide.

1 Like

Ok...

So I tried with Etcher and add the param acpi=off to the process, and it fully boot, but the keyboard is not working... So it's hard or impossible to do stuff !! (like install the damn thing)
(I think I remember to read a post with the same issue on similar laptop, but can't find it back)

Don't leave me ^^ !!

:rofl:
At least I'll do my best to get other people I know can and will help.

@bogdancovaciu
@linux-aarhus

Please help here. Thanks.

1 Like

For the issue of writing a Manjaro USB from Windows - the only tool that will work is Rufus. Rufus no longer has the DD option - instead it detects if it is a Manjaro ISO based on Manjaro specific files being on the ISO.

Don't mix - prefer UEFI - Reinstall Windows if you have to.

I have no idea

Search the forum for TLP https://forum.manjaro.org/search?q=TLP


1 Like

I can't just reinstall windows... First to do so is a ■■■■■■■ Pain is the ass !! Second the whole point of a dual boot is to keep your windows installed and with all your settings !!
So why not just install linux in legacy aswell ? (if possible) And if not for no I will keep it like this and go through the bios to go back on win10)

@others
we answered the dual boot bios-legacy/uefi and I think OP got passed the 'stuck at TLP' stage with
acpi=off . Now he cannot get his keyboard to work.

short simple suggestions
o if usb keyboard, try another usb port?
o if wireless keyboard, connect a wired keyboard, (if you have).

Over to @others.

This is what i also recommend, so, @Loky - once you do that, for Manjaro install use
acpi=force reboot=acpi
as kernel boot parameters. The acpi=off is not the way to go for that laptop model.

You can do exactly as prefer.

My reason for recommending UEFI is - it is so much easier to maintain - you don't get one system messing with the other system's boot record.


You could install Manjaro to your SSD then use VirtualBox with your Windows disk as raw image - You don't have to reinstall and one of the benefits is you don't have to reboot and if your Windows is MBR then the VirtualBox setup is minimal.

Ok I will try that parameter....
@gohlip And for the keyboard, it's a laptop dude !!

You mean I can access my win10 install through virtualbox or did you mean I can install a virtualbox with win10 on it ??

Did i stutter?

Now that we are dudettes i'll make myself an exit from here. :wink:

I mean exactly what I said.

You create a VM and attach the physical disk to it.

One forum-member does exactly this

@Loky

We all (including I) recommend you stick with either only uefi or only bios-legacy.
But I personally will not insist what other people should do as long as they are made aware.
I assume you have been made aware and I am personally satisfied with my answer.

Good luck with your keyboard.

Yeap But that not my issue here.... I get it it's better in UEFI, but I can't reinstall win10 in UEFI mode !!!
So my choice about that is to install Manjaro in UEFI and go to the bios to go back to win10. Or as Aarhus said, use virtualbox !! (or install Manjaro in legacy)

But for now, I can't even install a linux distro so.....
So yeap I will try the parameter that @bogdancovaciu gave me !!

Again, that is entirely up to you (and I mean it in a good way, funny, some people take it badly :slightly_smiling_face:).
Personally, I have no objections to whatever what others want to do with their systems or to themselves.

Have you got the keyboard working?

Forum kindly sponsored by