Manjaro 18.1.4-rc2 is online now!

use 4.19 or 5.3 kernel for now until iwlwifi gets fixed upstream
https://bugs.archlinux.org/task/64703

Battery and power efficiency for me are specially important metrics to control the usage.

I had two laptops with burned GPUs in the past, one due to problems with a "performance" switch and the other I couldn't even narrow down the reason but the GPU killed the whole motherboard (technician said). It gets even worse considering I'm in a tropical country. I even considered an actual desktop but I don't have the space.

One thing you have to accept when buying a laptop with dedicated GPU is that they are short lived and the more power they use, the hotter they get, the faster they will die, no matter how much engineering they get going on laptops.

I understand that most people don't really care enough usage, power efficiency or buying another one but laptops and electronic in general are extremely expensive in my country, at least twice the international price, so saving a bit of money by extending the lifespan is very beneficial, specially in situations like this were it's just wasted watts for no reason.

1 Like

thanks for info, not very happy about it... I hope AMD APU support will get better soon.

Yep, there is a regression of that WLAN driver...

1 Like

Hey DGLT, if I may ask a question?

I've been holding off on the update out of worry it'll make my laptop (iGPU/dGPU gtx1060) wonky after you recently helped me get Prime set up for it.
You helped me set up switching and I'm wondering how badly this update is going to kick my laptop for my needs.

From what I've learned, Prime Sync prevents screen-tearing similar to V-sync, but I don't quite understand how this compares to Render Offload?

In slightly simpler terms, for a laptop, what are the issues that are happening with the loss of Prime Sync? Is there nothing else to pick up the slack for screen tearing? Sorry for the newbie style question :sweat_smile:

The xfce edition still wont start (black screen, as reported here) on my laptop.

I've been waiting for this release for a refresh of my ThinkPad X1 Extreme (gen1). I plan to run it in dedicated GPU mode (GTX 1050) full time and disable the onboard video.

Am I correct in my understanding of this thread that I'm gonna have a bad time unless I continue to run the 4.19 kernel? I was hoping 5.4 would improve operations overall (was specifically waiting for a new LTS) but it's not sounding like that's going to be the case here.

then prime sync wont be an issue, it's only needed to sync the nvidia output to the integrated gpu, if you have the option to use nvidia exclusively then use it and avoid the optimus bs.

there's no need to hold off on updates, you can still update and continue to use the other kernels like 4.19 or 5.3 until it gets figured out. i notified nvidia of the issue but no response other than they are working on it. you can have more than 1 kernel installed at the same time.
https://devtalk.nvidia.com/default/topic/1068045/linux/5-4-kernel-breaks-prime-synchronization-/post/5410668/#5410668

Updated and done, fairly new user here so take my experience with a pinch of salt, but nothing seems broken. If anything, something feels just a 'touch speedier', maybe it's just me

Bearing in mind that I'm running Prime Switch with my GTX1060 at all times, so can't comment on the Prime Sync issues

██████████████████  ████████   alexander@alexander-pc 
██████████████████  ████████   ---------------------- 
██████████████████  ████████   OS: Manjaro Linux x86_64 
██████████████████  ████████   Host: TUF GAMING FX504GM_FX80GM 1.0 
████████            ████████   Kernel: 5.4.2-1-MANJARO 
████████  ████████  ████████   Uptime: 4 hours, 11 mins 
████████  ████████  ████████   Packages: 1251 (pacman) 
████████  ████████  ████████   Shell: bash 5.0.11 
████████  ████████  ████████   Resolution: 1920x1080 
████████  ████████  ████████   DE: Plasma 
████████  ████████  ████████   WM: KWin 
████████  ████████  ████████   WM Theme: Sweet-Dark-transparent 
████████  ████████  ████████   Theme: Breath [GTK2], Sweet-Dark [GTK3] 
████████  ████████  ████████   Icons: candy-icons [GTK2/3] 
                               Terminal: konsole 
                               Terminal Font: Noto Mono 11 
                               CPU: Intel i7-8750H (12) @ 4.100GHz 
                               GPU: NVIDIA GeForce GTX 1060 Mobile 
                               GPU: Intel UHD Graphics 630 
                               Memory: 5177MiB / 7817MiB 

1 Like
xrandr --prop 

if it shows PRIME Synchronization: 0 under your laptop display, prime sync is not working.

Seems to be the case.

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
HDMI-0 disconnected (normal left inverted right x axis y axis)
        CscMatrix: 65536 0 0 0 0 65536 0 0 0 0 65536 0 
        BorderDimensions: 4 
                supported: 4
        Border: 0 0 0 0 
                range: (0, 65535)
        SignalFormat: TMDS 
                supported: TMDS
        ConnectorType: HDMI 
        ConnectorNumber: 2 
        _ConnectorLocation: 2 
        non-desktop: 0 
                supported: 0, 1
eDP-1-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 193mm
        EDID: 
                00ffffffffffff000daef41500000000
                061b0104a52213780289a5ae4f44ac26
                10505400000001010101010101010101
                010101010101596f80a070383e403020
                6a0058c110000018000000fe004e3135
                364848452d4741310a20000000fe0043
                4d4e0a202020202020202020000000fe
                004e3135364848452d4741310a20001a
        PRIME Synchronization: 0 
                supported: 0, 1
        scaling mode: Full aspect 
                supported: Full, Center, Full aspect
        max bpc: 12 
                range: (6, 12)
        Broadcast RGB: Automatic 
                supported: Automatic, Full, Limited 16:235
        link-status: Good 
                supported: Good, Bad
        CONNECTOR_ID: 86 
                supported: 86
        non-desktop: 0 
                range: (0, 1)
   1920x1080    120.00*+  60.01    59.97    59.96    59.93  
   1680x1050     59.95    59.88  
   1400x1050     74.76    59.98  
   1600x900      59.99    59.94    59.95    59.82  
   1280x1024     85.02    75.02    60.02  
   1400x900      59.96    59.88  
   1280x960      85.00    60.00  
   1440x810      60.00    59.97  
   1368x768      59.88    59.85  
   1280x800      59.99    59.97    59.81    59.91  
   1152x864      75.00  
   1280x720      60.00    59.99    59.86    59.74  
   1024x768      85.00    75.05    60.04    85.00    75.03    70.07    60.00  
   1024x768i     86.96  
   960x720       85.00    75.00    60.00  
   928x696       75.00    60.05  
   896x672       75.05    60.01  
   1024x576      59.95    59.96    59.90    59.82  
   960x600       59.93    60.00  
   832x624       74.55  
   960x540       59.96    59.99    59.63    59.82  
   800x600       85.00    75.00    70.00    65.00    60.00    85.14    72.19    75.00    60.32    56.25  
   840x525       60.01    59.88  
   864x486       59.92    59.57  
   700x525       74.76    59.98  
   800x450       59.95    59.82  
   640x512       85.02    75.02    60.02  
   700x450       59.96    59.88  
   640x480       85.09    60.00    85.01    72.81    75.00    59.94  
   720x405       59.51    58.99  
   720x400       85.04  
   684x384       59.88    59.85  
   640x400       59.88    59.98    85.08  
   576x432       75.00  
   640x360       59.86    59.83    59.84    59.32  
   640x350       85.08  
   512x384       85.00    75.03    70.07    60.00  
   512x384i      87.06  
   512x288       60.00    59.92  
   416x312       74.66  
   480x270       59.63    59.82  
   400x300       85.27    72.19    75.12    60.32    56.34  
   432x243       59.92    59.57  
   320x240       85.18    72.81    75.00    60.05  
   360x202       59.51    59.13  
   360x200       85.04  
   320x200       85.27  
   320x180       59.84    59.32  
   320x175       85.27  

1 Like

I have Vega 8. I just tested manjaro-xfce-18.1.4-191210-linux54.iso and the graphics are messed up. The gnome edition is fine however (manjaro-gnome-18.1.4-191210-linux54.iso) and so is my cinnamon install with kernel 54.

[manjaro@manjaro ~]$ inxi -Fxxxza --no-host
System:
  Kernel: 5.4.2-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_GB keytable=gb tz=UTC 
  driver=nonfree nouveau.modeset=0 i915.modeset=1 radeon.modeset=0 
  misobasedir=manjaro misolabel=MJRO1814 quiet systemd.show_status=1 
  apparmor=1 security=apparmor 
  Desktop: Xfce 4.14.1 tk: Gtk 3.24.12 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Desktop System: Gigabyte product: A320M-S2H V2 v: N/A 
  serial: <filter> 
  Mobo: Gigabyte model: A320M-S2H V2-CF v: x.x serial: <filter> 
  UEFI: American Megatrends v: F1 date: 10/16/2018 
CPU:
  Topology: Quad Core model: AMD Ryzen 3 2200G with Radeon Vega Graphics 
  bits: 64 type: MCP arch: Zen family: 17 (23) model-id: 11 (17) 
  stepping: N/A microcode: 810100B L2 cache: 2048 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 27957 
  Speed: 1420 MHz min/max: 1600/3500 MHz boost: enabled Core speeds (MHz): 
  1: 1421 2: 1437 3: 1446 4: 1441 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  disabled, RSB filling 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] 
  vendor: Gigabyte driver: amdgpu v: kernel bus ID: 09:00.0 
  chip ID: 1002:15dd 
  Display: x11 server: X.Org 1.20.6 driver: amdgpu,ati unloaded: modesetting 
  alternate: fbdev,vesa resolution: 1600x1200~60Hz 
  OpenGL: renderer: AMD RAVEN (DRM 3.35.0 5.4.2-1-MANJARO LLVM 9.0.0) 
  v: 4.5 Mesa 19.2.7 direct render: Yes 
Audio:
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel 
  v: kernel bus ID: 09:00.1 chip ID: 1002:15de 
  Device-2: AMD Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel 
  v: kernel bus ID: 09:00.6 chip ID: 1022:15e3 
  Sound Server: ALSA v: k5.4.2-1-MANJARO 

same results with option Free Drivers ?
if possible edit command on boot ( E) and change :

parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_GB keytable=gb tz=UTC
driver=free nouveau.modeset=0 i915.modeset=0 amdgpu.modeset=1 radeon.modeset=0
misobasedir=manjaro misolabel=MJRO1814 quiet systemd.show_status=1
apparmor=1 security=apparmor

Yeah, it makes no difference. I tried just changing the iso boot option to free:

parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_GB keytable=gb tz=UTC 
  driver=free nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 
  misobasedir=manjaro misolabel=MJRO1814 quiet systemd.show_status=1 
  apparmor=1 security=apparmor 

and the exact command line you specified. Same result.

when you get to the desktop, go to settings and disable the compositor. "widow effects" i think xfce settings calls it and see if the screen corruption is gone

"Windows Manager Tweaks"
:wave:t3:

1 Like

i had "window" correct. :grin:

2 Likes

Yep, it's the compositor. There's no problems when it's off.

after you get manjaro installed you can switch from xfwm's compositor to picom (formerly compton).

Thanks but I use cinnamon, I was just trying it out.

1 Like

Forum kindly sponsored by