Manjaro 18.0 XFCE, Conky doesn't work with transparency

Out of the box, did not install anything else.
So Compton is not installed.

There are how-tos in the wiki and elsewhere for replacement.

But to check, you can simply turn off XFCE compositor, and run compton, and see if it is the same.

Thx, but first I would like to know why it does not longer work out of the box :slight_smile:

It works out of the box for me. Have you turned on the xfwm4 compositor? I am using Conky 1.10

Fair enough. What is your system info:
inxi -Fxxxz
And, as asked - do you have compositor on or not ? If ON, then do you see failures elsewhere, such as any other windows that should have transparency?

As I said, I did not change a single thing.
I installed conky and conky-manager and I get a black box around each window which annoys me.

System:
Host: AnakinSkywalker Kernel: 4.19.28-1-MANJARO x86_64 bits: 64
compiler: gcc v: 8.2.1 Desktop: Xfce 4.13.2git-UNKNOWN tk: Gtk 3.24.3
info: xfce4-panel, plank wm: xfwm4 dm: LightDM 1.28.0
Distro: Manjaro Linux
Machine:
Type: Desktop Mobo: ASRock model: X99 Extreme6/3.1 serial:
UEFI: American Megatrends v: P3.50 date: 04/06/2018
CPU:
Topology: 6-Core model: Intel Core i7-5820K bits: 64 type: MT MCP
arch: Haswell rev: 2 L2 cache: 15.0 MiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 79200
Speed: 1799 MHz min/max: 1200/3600 MHz Core speeds (MHz): 1: 1453 2: 1200
3: 1201 4: 1200 5: 1200 6: 1200 7: 1200 8: 1200 9: 1501 10: 1200 11: 1201
12: 1200
Graphics:
Device-1: AMD Baffin [Radeon RX 460/560D / Pro
450/455/460/555/555X/560/560X]
vendor: XFX Pine driver: amdgpu v: kernel bus ID: 03:00.0
chip ID: 1002:67ef
Display: x11 server: X.Org 1.20.4 driver: amdgpu FAILED: ati
unloaded: modesetting alternate: fbdev,vesa resolution: 1920x1200~60Hz
OpenGL: renderer: AMD Radeon RX 460 Graphics (POLARIS11 DRM 3.27.0
4.19.28-1-MANJARO LLVM 7.0.1)
v: 4.5 Mesa 18.3.4 direct render: Yes
Audio:
Device-1: Intel C610/X99 series HD Audio vendor: ASRock
driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:8d20
Device-2: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / RX 560/560X]
vendor: XFX Pine driver: snd_hda_intel v: kernel bus ID: 03:00.1
chip ID: 1002:aae0
Sound Server: ALSA v: k4.19.28-1-MANJARO
Network:
Device-1: Intel Ethernet I218-V vendor: ASRock driver: e1000e v: 3.2.6-k
port: f020 bus ID: 00:19.0 chip ID: 8086:15a1
IF: enp0s25 state: up speed: 100 Mbps duplex: full mac:
Device-2: Qualcomm Atheros QCA8171 Gigabit Ethernet vendor: ASRock
driver: alx v: kernel port: d000 bus ID: 05:00.0 chip ID: 1969:10a1
IF: enp5s0 state: down mac:
Drives:
Local Storage: total: 14.50 TiB used: 5.79 TiB (39.9%)
ID-1: /dev/nvme0n1 vendor: Kingston model: SKC1000960G size: 894.25 GiB
speed: 31.6 Gb/s lanes: 4 serial: rev: E7FT04.6 scheme: GPT
ID-2: /dev/sda vendor: Crucial model: CT500BX100SSD1 size: 465.76 GiB
speed: 6.0 Gb/s serial: rev: MU02 scheme: MBR
ID-3: /dev/sdb vendor: Kingston model: SHSS37A480G size: 447.13 GiB
speed: 6.0 Gb/s serial: rev: 00.Y scheme: GPT
ID-4: /dev/sdc type: USB vendor: Toshiba model: HDWN180 size: 7.28 TiB
rotation: 7200 rpm serial: scheme: GPT
ID-5: /dev/sdd type: USB vendor: Western Digital model: WD30EFRX-68AX9N0
size: 2.73 TiB serial: scheme: GPT
ID-6: /dev/sde type: USB vendor: Western Digital model: WD30EFRX-68EUZN0
size: 2.73 TiB rotation: 5400 rpm serial: scheme: GPT
Partition:
ID-1: / size: 862.05 GiB used: 578.24 GiB (67.1%) fs: ext4
dev: /dev/nvme0n1p2
ID-2: swap-1 size: 17.15 GiB used: 19.5 MiB (0.1%) fs: swap
dev: /dev/nvme0n1p3
Sensors:
System Temperatures: cpu: 31.0 C mobo: N/A gpu: amdgpu temp: 38 C
Fan Speeds (RPM): N/A
Info:
Processes: 305 Uptime: 1d 3h 00m Memory: 15.58 GiB used: 4.65 GiB (29.9%)
Init: systemd v: 241 Compilers: gcc: 8.2.1 Shell: bash v: 5.0.0
running in: xfce4-terminal inxi: 3.0.32

Oh. well, we have no way of knowing how your conky is configured, unless you post it.
We also, again, do not know if this is conky-specific, or a failure of the compositor. Please check.

[thanks for output. In the future, please use the </> button to wrap output for readability]

In your conky.conf, you can try:

own_window = true
own_window_type = 'normal'
own_window_transparent = false

Works for me (XFCE, xfwm4 compositor = ON).

Below works for me on i3 (compton compositor = ON):

own_window = true,
own_window_type = 'override',
own_window_transparent = true,

Most conky in conky-manager are totally outdated using old code so they need updating

5 Likes

just as it is.
did not change a thing.
using manjaro for 1.5 years and in any version it worked out of the box.
now it doesn’t.

1 Like

I want to have own_window_transparent = true
The scripts worked for 1.5 years without any problems.

But it is not transparent, it’s a black box.

Ok then…whatever.

It doesn’t make a difference what the settings are… it’s never transparent, it’s always a black box…

but it did work before new install.
it was the same conky version as of now.
don’t understand it.

I have trouble with this conky transparent thing too. Been searching around and tried many purmintations of my window settings. Cutently:

#-----Window settings
own_window yes
own_window_transparent yes
own_window_argb_visual yes
#own_window_argb_value 0
own_window_type normal
#own_window_type desktop
#own_window_type override
own_window_colour 000000
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
own_window_class Conky

I think the issue is with the compositor or lack there of.
Where is this setting?

I have mucked around in the GUI menus and the configs are something I want to be carefull with.

Thanks in advance …

Ok I guess it is Menu > Settings > Window Manager Tweaks > Compositor > Opacity of inactive windows (slider) . That helped with most of the conky.
I have an image that is still oh 50% transparent.

${execpi 7200 cd /home/kmartin/moonphase/ && ./moonphase}
${image /home/kmartin/moonphase/todaysmoon.png -p 30,60 -s 220x220}

It just runs a program and loads a phase of the moon today .png for the conky.

It used to be opaque but I just have to find the tweaks. :man_shrugging:

Hi,

just changing
own_window_argb_visual
to
yes
did fix the issue :slight_smile:

Thanks a lot :smiley:

Eliot

1 Like

I guess you could also try using xfce4-composite-editor from the AUR. It’s in GTK-2, but it worked for me with XFCE4-gtk3.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by