Manjaro 18.0 lxde stopped booting with lightdm error, after the latest update

manjaro32

#1

hello everybody, i am a newbie to manjaro.

i have been using manjaro lxde 32-bit, since its release 17.0.5 until now 18.0, so far so good. but after the latest update a few days ago, today, manjaro stopped booting with lightdm error (screenshot attached).

0_lxde

i had googled and found this :

so i edited xfce4-session.xml as mentioned in that post.
but even after i did that, it still stops booting with the same error message.

your help is appreciated.

thanks in advance,
nubipengen


#2

hello, does anybody know the solution to this issue ?


#3

Did you try running the command it mentions from another TTY?
systemctl status lightdm

I suspect it’s a gpu driver issue.


#4

thanks for responding, sir.

i am a newbie manjaro user.
i was unable to type any command. i tried pressing any keyboard button but it was just frozen, no response at all.

i don’t quite understand what you meant by “running the command from another TTY”.


#5

You probably got the problem with Xorg 1.20 + nvidia graphics driver.
Do you have a Manjaro live USB?


#6

thank you, sir.

i will burn the live USB.
should i download the same release (18.0), or can i just download any release ?
what should i do with the live USB ?


#7

There is no 32bit 18.0 release. The latest is https://osdn.net/projects/manjaro32/storage/xfce/17.1.7-rc1/
You boot the live USB, then give us some system information
inxi -Fxxz
Then access /var/log/Xorg.0.log on the installed partition and poste it via hastebin.com, give us the hastebin link then.


#8

that confuses me too, sir.

i have been using manjaro lxde 32-bit, starting from its release 17.0.5, been updating and upgrading it until the latest 18.0. therefore, my latest installed manjaro is release 18.0

since there is no 32-bit 18.0 release, can i just use the old 17.0.5 for the live usb and execute the commands you wrote above ?


#9

yes, you can


#10

On Manjaro-32 we use Xorg-Server 1.20. What kind of graphic card do you use? Some drivers are known not to work with that xserver. Please look here for Nvidia drivers. Also looking into this forum section might help.


#11

The official iso released to this date, even when switched to the unstable branch will not become 18.0 but only 17.1.10, unless there is something different on manjaro32, or you don’t use manjaro32 and you installed the alpha iso that was posted here:


#12

thank you, sirs.

i just realized there is something weirder here in my case.
i began using manjaro with the 32-bit version 17.0.5 (a stable version ?).
later, i have been updating and upgrading it, and the latest release i am using is 18.0 alpha or beta.

here are some files on manjaro root partition (this is a multiboot computer; i accessed manjaro partition from another boot distro) :
/boot/initramfs-4.14-i686.img
/boot/vmlinuz-4.14-i686

i am not sure whether it would be better for me to just fresh-install manjaro lxde with its release 17.1.8, but i do not see the download link of its 32-bit version.

or should i use the 64-bit version instead ? i prefer a better performance on this old computer. my hardware specification :
cpu : intel core2duo 3 ghz
ram : 4 gbytes
gpu : nvidia geforce 9300

what would you recommend, sirs, in order for me to get the stable, final (not alpha/beta) version of manjaro lxde ?

thanks again, sirs.


#13

IIRC this is a 64bit capable CPU. If it is, your system is more than capable to run 64bit installations.
You have nothing to lose, if you check.


#14

yes, sir, i know that it is a 64-bit cpu.
i use multiboot distros on this computer :

  • debian buster lxde 32-bit
  • sparkylinux xfce 32-bit
  • deepin 15.5 64-bit
  • fedora 28 kde 64-bit
  • geckolinux 423 lxqt 64-bit
  • manjaro 18.0 lxde 32-bit

with 4 gbytes maximum RAM installed on this computer, i noticed the 32-bit distros perform better, slightly more responsive, than the 64-bit ones. please correct me if this is wrong, sir.

if the 64-bit one actually performs better (on this old computer), i think i will download manjaro 17.1.8 lxde.


#15

This is your answer. Your system. I couldn’t know. My experience is not based on benchmarks, just my own perception/illusion, that 64bit SW is, if not equal, better functioning. Then it’s the EOL of 32bit Linux on Arch, which in time may force you to some restrictions.
Good luck.


#16

wow, i did not know it is the EOL of 32-bit arch-based linux, sir.

so it leaves me no other option.
i think i will have to install manjaro 17.1.8 lxde 64-bit.

thanks again, everybody.


#17

xfce edition will be better than lxde IMHO


#18

Thanks, I just successfully installed Manjaro 17.1.10 Xfce 64-bit, so I think I’ll just close this case and make a new thread for another issue.


#19

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.