Зависает при установке manjaro 17.1.0

hardware
nvidia
installation

#1

Железо: ноут MSI gp72 6qf
Подобная проблема была со всеми дистрами, но всегда решалась тем, что в опциях загрузки (live образа при установке и при первом запуске) прописывал nomodeset, ставил дрова и всё работало отлично.
С manjaro вожусь уже несколько часов.
Во время уже установки зависает на 80% на этапе configure hardware намертво.

Что пробовал:
nomodeset
systemd.mask=mhwd-live.service
Ставить не free драйвера в настройках образа в начале
acpi=off (скриншот прилагаю)

В остальных случаях запускался только при nomodeset, но зависал при установке, в остальных - зависает на том же этапе что на фотке.

В общем голову уже сломал, уже и не знаю в какую сторону гуглить. Явно ноги растут из драйверов intel или nvidea, но как фиксить не пойму. С deb дистрами решалось как и описал выше - nomodeset


Manjaro + Asus Z53J
#2

Приветствую на форуме!
Можно inxi -Fxxz с дистры, где работает? И /var/log/Xorg.0.log


#3

С радостью, если подробнее объясните как предоставить это :slight_smile:

Я не на столько разбираюсь в этом. Лишь стремлюсь :slight_smile:


#4

inxi -Fxxz
это команда в терминале, на Ubuntu нужно сначала установить пакет inxi.

/var/log/Xorg.0.log
это текстовый файл


#5

linux никакого не стоит на машине, так что догадываюсь что данные не полные.
После команды inxi -Fxxz live-cd monjaro зависает намертво.

Xorg.0.log или похоже нет, так что привожу ниже текст файлов pacman.log и mhwd-live.log возможно поможет:

pacman:


[2018-01-05 00:12] [PACMAN] Running 'pacman --noconfirm --cachedir /var/cache/pacman/pkg --config /opt/pacman-mhwd.conf --root / --needed -Sy bumblebee xf86-video-nouveau xf86-video-intel lib32-primus linux414-bbswitch'
[2018-01-05 00:12] [PACMAN] synchronizing package lists
[2018-01-05 00:12] [ALPM] transaction started
[2018-01-05 00:12] [ALPM] installed primus (20151110-7)
[2018-01-05 00:12] [ALPM] installed bumblebee (3.2.1-18)
[2018-01-05 00:12] [ALPM-SCRIPTLET] Adding user 'manjaro' to user-group 'bumblebee'
[2018-01-05 00:12] [ALPM] installed xf86-video-nouveau (1.0.15-2)
[2018-01-05 00:12] [ALPM] installed libxvmc (1.0.10-1)
[2018-01-05 00:12] [ALPM] installed xf86-video-intel (1:2.99.917+802+gaf6d8e9e-1)
[2018-01-05 00:12] [ALPM-SCRIPTLET] >>> This driver now uses DRI3 as the default Direct Rendering
[2018-01-05 00:12] [ALPM-SCRIPTLET]     Infrastructure. You can try falling back to DRI2 if you run
[2018-01-05 00:12] [ALPM-SCRIPTLET]     into trouble. To do so, save a file with the following 
[2018-01-05 00:12] [ALPM-SCRIPTLET]     content as /etc/X11/xorg.conf.d/20-intel.conf :
[2018-01-05 00:12] [ALPM-SCRIPTLET]       Section "Device"
[2018-01-05 00:12] [ALPM-SCRIPTLET]         Identifier  "Intel Graphics"
[2018-01-05 00:12] [ALPM-SCRIPTLET]         Driver      "intel"
[2018-01-05 00:12] [ALPM-SCRIPTLET]         Option      "DRI" "2"             # DRI3 is now default 
[2018-01-05 00:12] [ALPM-SCRIPTLET]         #Option      "AccelMethod"  "sna" # default
[2018-01-05 00:12] [ALPM-SCRIPTLET]         #Option      "AccelMethod"  "uxa" # fallback
[2018-01-05 00:12] [ALPM-SCRIPTLET]       EndSection
[2018-01-05 00:12] [ALPM] installed lib32-primus (20151110-3)
[2018-01-05 00:12] [ALPM] installed linux414-bbswitch (0.8-10)
[2018-01-05 00:13] [ALPM] transaction completed
[2018-01-05 00:13] [ALPM] running '60-linux414.hook'...
[2018-01-05 00:13] [ALPM] running 'systemd-update.hook'...

mhwd-live:

Running MHWD...
e[1me[31m> e[mUsing config 'video-hybrid-intel-nouveau-bumblebee' for device: 0000:00:02.0 (0300:8086:191b) Display controller Intel Corporation HD Graphics 530
e[1me[31m> e[mInstalling video-hybrid-intel-nouveau-bumblebee...
e[0;32mwarning: database file for 'core' does not exist
e[me[0;32mwarning: database file for 'extra' does not exist
e[me[0;32mwarning: database file for 'community' does not exist
e[me[0;32mwarning: database file for 'multilib' does not exist
e[me[0;32mUsing default
e[me[0;32mHas lib32 support: true
e[me[0;32mSourcing /var/lib/mhwd/db/pci/graphic_drivers/hybrid-intel-nouveau-bumblebee/MHWDCONFIG
e[me[0;32mProcessing classid: 0300
e[me[0;32mSourcing /var/lib/mhwd/scripts/include/0300
e[me[0;32mwarning: database file for 'core' does not exist
e[me[0;32mwarning: database file for 'extra' does not exist
e[me[0;32mwarning: database file for 'community' does not exist
e[me[0;32mwarning: database file for 'multilib' does not exist
e[me[0;32m:: Synchronizing package databases...
e[me[0;32mdownloading mhwd.db...
e[me[0;32mresolving dependencies...
e[me[0;32mlooking for conflicting packages...
e[me[0;32mwarning: dependency cycle detected:
e[me[0;32mwarning: primus will be installed before its bumblebee dependency
e[me[0;32m
e[me[0;32mPackages (7) libxvmc-1.0.10-1  primus-20151110-7  bumblebee-3.2.1-18  lib32-primus-20151110-3  linux414-bbswitch-0.8-10  xf86-video-intel-1:2.99.917+802+gaf6d8e9e-1  xf86-video-nouveau-1.0.15-2
e[me[0;32m
e[me[0;32mTotal Download Size:   0.93 MiB
e[me[0;32mTotal Installed Size:  3.25 MiB
e[me[0;32m
e[me[0;32m:: Proceed with installation? [Y/n] 
e[me[0;32m:: Retrieving packages...
e[me[0;32mdownloading primus-20151110-7-x86_64.pkg.tar.xz...
e[me[0;32mdownloading bumblebee-3.2.1-18-x86_64.pkg.tar.xz...
e[me[0;32mdownloading xf86-video-nouveau-1.0.15-2-x86_64.pkg.tar.xz...
e[me[0;32mdownloading libxvmc-1.0.10-1-x86_64.pkg.tar.xz...
e[me[0;32mdownloading xf86-video-intel-1:2.99.917+802+gaf6d8e9e-1-x86_64.pkg.tar.xz...
e[me[0;32mdownloading lib32-primus-20151110-3-x86_64.pkg.tar.xz...
e[me[0;32mdownloading linux414-bbswitch-0.8-10-x86_64.pkg.tar.xz...
e[me[0;32mchecking keyring...
e[me[0;32mchecking package integrity...
e[me[0;32mloading package files...
e[me[0;32mchecking for file conflicts...
e[me[0;32mchecking available disk space...
e[me[0;32m:: Processing package changes...
e[me[0;32minstalling primus...
e[me[0;32minstalling bumblebee...
e[me[0;32mAdding user 'manjaro' to user-group 'bumblebee'
e[me[0;32mOptional dependencies for bumblebee
e[me[0;32m    xf86-video-nouveau: nouveau driver [pending]
e[me[0;32m    nouveau-dri: 3D acceleration features fo nouveau [installed]
e[me[0;32m    bbswitch: switch on/off discrete card [pending]
e[me[0;32m    nvidia: NVIDIA kernel driver
e[me[0;32m    virtualgl: alternative back-end for optirun
e[me[0;32m    lib32-virtualgl: run 32bit applications with optirun
e[me[0;32m    lib32-primus: faster back-end for optirun [pending]
e[me[0;32minstalling xf86-video-nouveau...
e[me[0;32minstalling libxvmc...
e[me[0;32minstalling xf86-video-intel...
e[me[0;32m>>> This driver now uses DRI3 as the default Direct Rendering
e[me[0;32m    Infrastructure. You can try falling back to DRI2 if you run
e[me[0;32m    into trouble. To do so, save a file with the following 
e[me[0;32m    content as /etc/X11/xorg.conf.d/20-intel.conf :
e[me[0;32m      Section "Device"
e[me[0;32m        Identifier  "Intel Graphics"
e[me[0;32m        Driver      "intel"
e[me[0;32m        Option      "DRI" "2"             # DRI3 is now default 
e[me[0;32m        #Option      "AccelMethod"  "sna" # default
e[me[0;32m        #Option      "AccelMethod"  "uxa" # fallback
e[me[0;32m      EndSection
e[me[0;32mOptional dependencies for xf86-video-intel
e[me[0;32m    libxrandr: for intel-virtual-output [installed]
e[me[0;32m    libxinerama: for intel-virtual-output [installed]
e[me[0;32m    libxcursor: for intel-virtual-output [installed]
e[me[0;32m    libxtst: for intel-virtual-output [installed]
e[me[0;32m    libxss: for intel-virtual-output [installed]
e[me[0;32minstalling lib32-primus...
e[me[0;32minstalling linux414-bbswitch...
e[me[0;32m:: Running post-transaction hooks...
e[me[0;32m(1/2) Updating linux414 module dependencies...
e[me[0;32m(2/2) Arming ConditionNeedsUpdate...
e[me[0;32mxorg configuration file: '/etc/X11/mhwd.d/intel.conf'
e[me[0;32mCreated symlink /etc/systemd/system/multi-user.target.wants/bumblebeed.service → /usr/lib/systemd/system/bumblebeed.service.
e[me[1me[31m> e[mSuccessfully installed video-hybrid-intel-nouveau-bumblebee
MHWD DONE

#6

раздобыл инфу про схожую модель
https://wiki.archlinux.org/index.php/MSI_GT72-6QE
https://bbs.archlinux.org/viewtopic.php?id=208340

пишет, что nouveau не работает, значит надо Manjaro USB грузить с опцией non-free


Manjaro + Asus Z53J
#7

Попробовал 2 варианта, оба провальные.
Первые, использовать non free: что успел зафиксировать вот. На последнем этапе зависает (ждал 8+ минут)

!

Во втором случае как в вики попробовал: nomodeset nohz=off clocksource=tsc - зависает так же

Да, secure отключен, если что.


#8

Алтернатива: попробовать загрузиться до терминала TTY (добавить параметр старта “3” - просто цифра три там где задавали nomodeset), там инсталировать при помощи manjaro-architect у которого хорошая русская локализация. Логин manjaro manjaro, потом sudo setup. На KDE ISO он тоже есть.


#9

Я не осилил Manjaro-Architect :confused:

Попробовал 17.1.1 которая сегодня появилась - вообще в систему не заходит live :smile:
При любых более-менее адекватных командах (nomodeset, free, non-free драйвера, всё виснет)
17.1.0 хотя бы в режиме free драйверов без дополнительных параметров запускалась с live-cd :slight_smile:


#10

попробуйте параметр ядра xdriver=vesa


#11

Нет, с этим параметром виснет (фото ниже)

Однако интересная вещь произошла - вынул рессивер от Bloody R80 и в обычном режиме (free драйвера и без доп.параметров) попал в систему, но установка так же умерла на этапе Configure hardware.

Так что всё таки intel/nvidea

Готов еще идеи попробовать (кроме Manjaro-Architect, я даже на виртуалку не смог им поставить ничего, сложно, извините).


#12

Я порекомендовал “архитектора”, потому что помню случаи, когда с ним получалось именно с конфигурациаями intel + nvidia, в то-же время с графическим установщиком Calamares не получалось.

Готов при вопросах говорить, какие опции выбирать в “архитекторе”.


#13

Другая альтернатива - отключить карту NVIDIA в BIOS или в Windows.

This notebook has a physical hardware button to switch between the Intel and discrete (Nvidia 980m) GPU. Before installing Arch, boot into Windows and use the button to switch to the Intel display adapter.
(…) After installing, boot back into Windows and use the button to switch the display adapter back to the NVIDIA GPU.
https://wiki.archlinux.org/index.php/MSI_GT72-6QE#Installation


#14

я использую manjaro в виртуалбоксе. все отлично работает.


#15

Попробуй установить 1706 версию и обновись , у меня что-то похожее было с rc версией


closed #16

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.