Manjaro 16.06-rc1 released

Finaly we are almost there. We are happy to publish our first release candidate of our upcoming stable release we call Daniella.

The Xfce edition remains our flagship offering and has received the attention it deserves. Few can claim to offer such a polished, integrated and leading-edge Xfce experience. We ship Xfce 4.12 with this release of Manjaro. We mainly focused on polishing the user experience on the desktop and window manager, and on updating some components to take advantage of newly available technologies such as switching to a new Vertex-Maia theme, we already using known as Maia for our KDE edition.

Our KDE edition continues to deliver this powerful, mature and feature-rich desktop environment with a unique look-and-feel, and with the perks of Manjaro's latest tools. We ship now Plasma 5.6 desktop in combination with the latest KDE-Apps 16.04. It was a huge step to get it all playing together smoothly and to give the user experience the same feeling as our KDE4 editions of the past.
Kernel 4.4 LTS is used for this release, such as the latest drivers available to date. Relative to the last installation media release, our tools have been improved and polished.

The Manjaro Settings Manager (MSM) now provides an easy-to-use graphical interface for installing and removing the many series of kernels we offer. Manjaro's selection of readily available kernels remains the most extensive of all Linux distribution we know of. At the time of this 16.06-rc1 release, twelve kernel-series are available directly from our binary repositories, ranging from the mature & rock-solid 3.10 series to the latest 4.6 release. Such a wide array of available kernel options results in extensive hardware support, getting the most out of your system for you, be it old or new. We also created a kcm module to integrate MSM seamlessly into System-Settings of Plasma 5. We have now several notifier for MSM to be installed optionally.

With Pamac 4.0 we have switched to CSD design. Guillaume was working for some time on this new design for pamac. Followed features you can expect:

  • click on a package name and choose details to view details.
  • in dependencies view, click on any dependency to view its details
  • you can continue browsing packages while a transaction is running

So please test this release thru and thru and let us know what you think about this release of Daniella.
We hope you enjoy this release.

Please verify the downloaded ISO files with the provided checksum before installation, or check the encrypted gpg signature:

key ID 11C7F07E "Philip Müller philm_at_manjaro.org"
(for verification you can use for example 'gpa' (Linux), 'Gpg4win' (Windows) or 'MacGPG' (OSx) )

kind regards, Philip Müller, and the Manjaro development team

16 Likes

@ Phil: I downloaded and installed it yesterday. It looks and works great, with no known issues so far. :slight_smile:

@g33zr: that is wonderful to hear. I expect that from a RC :stuck_out_tongue:

Is akonadi disable by default in KDE version? I downloaded the kde 16.06rc1 version and I’ve noted kde was using less hardware resources to run, then I looked for akonadi and it wasn’t installed. It impressed me cause I could uninstall it without broke the system and it’s a way out for those who want to use KDE DE in an old pc
Just sharing :smile:

I dont know if it was intentional or if it’s a final decision but I’ve approved it \o/

I tested KDE and Xfce. Good working. I liked KDE this release :slight_smile: :stuck_out_tongue:

Thanks Philm.

It must show the percentage of jobs working with Pamac-dev.

as Octopi..


pamac window size is too large

It should be a little smaller

@tulliana: please share your pamac UI requests within our bugtracker. Thx.

I tried manjaro-xfce-16.06-rc1-x86_64.iso.

bug:
It looks like the B43 wifi driver doesn’t work out of the box, ergo, no internet connection.
I had to install it manually using the instructions on the page at http://linuxwireless.org/en/users/Drivers/b43/ (see section: ‘If you are using the b43 driver from 3.2 kernel or newer:’):

My wifi card is a belkin which uses the BCM4318 chipset.
It worked okay, out of the box, using previous 64-bit versions of manjaro released since v15.12.

Indeed, KDE edition is really smooth and suprisingly bugfree.

1 Like

I’m pretty sure that driver is available to install via Manjaro Settings Manager->Hardware detection.

Try uninstalling the installed wifi driver in Manjaro Settings Manager -> Hardware
Then run sudo modprobe b43 and wifi should work.

1 Like

I’m using manjaro via a usbkey, so just a reboot and a ‘sudo modprobe b43’ got it working.
The driver files were already present in /lib/firmware/b43 (and /lib/firmware/b43legacy for older cards).
It’s just that the b43 driver wasn’t enabled yet.
So, you were right! :slight_smile:
Thanks for your help!

Smooth update, :relaxed:

No problems, except for Steam, even in a new OS install the LIB problem still remains

All good here:smile:

I updated before I left work today and I can’t wait to try out the xfce in the morning!

Everthing ok, except that screen edges stopped working, no matter what settings I change…

Some issues with manjaro-kde-16.06-rc1-x86_64.iso. I’m testing the KDE 16.06 RC1 on my work computer Nvidia GeForce GTX 645, on a separate SSD hard drive, which currently running on KDE Plasma 5.6.4 (up-to-date), without any problem.
1.
I had a very hard time with the grub wouldn’t load after the installation was completed. I tried UEFI, as well as Legacy, with the same result. I kept getting an error saying “no boot been detected or the disk has failed”, and as far as I can remember, I’ve never had this issue in the past with any of the previous versions. Finally I got it to work after several installations, and honestly I don’t how I got it to work. Some one else had the same issue not too long ago with the RC1.
2.
The system doesn’t save the settings for dual screen. I switched to Maui, and then to Elarun, and that seem to fixed that problem.
3.
I tried to install Kernel 41 as a backup. It completed the installation, but after a restart nothing was installed!
Update on Knotes. It’s working now after I reinstalled.

Great, thank :slight_smile:

I Tried to install manjaro-xfce-16.06-rc1-x86_64 under virtualbox.
I need to use the CLI because it allows additional locale(s).

During step 3, “Install system”, at the “Configuration in progress” part, while configuring the display manager --> fixing some applications, I get the following error:

Error openning directory ‘/etc/dconf/db’: No such file or directory

update

… system dconf databases

(The leftmost text is hidden).

After the installation is completed “successfully”, I tried to boot from the new system and get kernel panic (image attached).

This happened and was reported (on the old forum) on the previous RC version as well.

Note on Calamares:
Why isn’t it allowing additional locale/s ?
Every non-English speaker needs it.

Hello,

When I try to boot as live usb, it stops after a few seconds. Tried different boot configurations (kernel, display) with no success. I assume is something hardware related as the same USB stick worked just fine on other PC. My system is a AMD 5350 on a ASRock AM1B-ITX and a Kingston V300 SSD. Using the last stable snapshot with great success, just wanna do a fresh install to this new SSD. Please help.

Forum kindly sponsored by