Manajro Slow Boot

Hi,

I would like some help on how to solve slow boot. I've searched and couldn't find a fix to my slow boot.

I have this logs

rodrigo@manjaro Linux 5.0.21-1-MANJARO x86_64 18.0.4 Illyria
~ >>> systemd-analyze blame
1min 30.038s nmb.service
13.427s warsaw.service
11.210s systemd-journal-flush.service
10.066s NetworkManager-wait-online.service
9.890s ModemManager.service
9.853s lvm2-monitor.service
9.743s org.cups.cupsd.service
8.514s dev-sda7.device
6.313s smb.service
5.537s polkit.service
3.033s systemd-udevd.service
2.879s tlp.service
2.686s teamviewerd.service
2.509s avahi-daemon.service
2.224s NetworkManager.service
2.216s systemd-logind.service
2.206s bluetooth.service
2.201s grub-boot-indeterminate.service
1.644s systemd-modules-load.service
1.559s systemd-tmpfiles-clean.service
1.244s systemd-tmpfiles-setup-dev.service
1.193s colord.service
803ms upower.service
583ms systemd-backlight@backlight:intel_backlight.service
500ms systemd-random-seed.service
458ms udisks2.service
432ms systemd-timesyncd.service
380ms systemd-tmpfiles-setup.service
341ms systemd-journald.service
268ms systemd-rfkill.service
244ms systemd-user-sessions.service
232ms boot-efi.mount
214ms wpa_supplicant.service
168ms kmod-static-nodes.service
166ms systemd-udev-trigger.service
157ms tmp.mount
156ms haveged.service
132ms sys-kernel-debug.mount
131ms dev-hugepages.mount
131ms dev-mqueue.mount
117ms dev-disk-by\x2duuid-cbdd6a32\x2d6fbf\x2d40c8\x2d9027\x2ddbc208032250.swap
114ms rtkit-daemon.service
104ms systemd-remount-fs.service
91ms systemd-update-utmp.service
74ms systemd-sysctl.service
46ms user@1000.service
8ms mnt-timecapsule.mount
6ms user-runtime-dir@1000.service
3ms sys-fs-fuse-connections.mount
2ms sys-kernel-config.mount

Here is the dmesg file: https://we.tl/t-5MCWDAKSMB

I would like to thank any help in advance.

Regards
Rodrigo

It's probably better if you put the dmesg up on pastebin or dpaste rather than a download.

2 Likes

Thanks

Here it is: https://pastebin.com/xFXpyifp

Welcome :slight_smile:

If you not need samba service

systemctl mask nmb smb

Important knowledge

Please select the text in the terminal
Paste the text into the post
Select the newly pasted text in the post
Click the </> icon in the post toolbar

This creates nicely formatted text which is readable for other users after you.

(Text was copied from @ linux-aarhus)

Sample

sudo pacman -S pastebinit
inxi -Fxxxz | pastebinit

sudo pacman -S pastebinit
tail 200 /var/log/pacman.log | pastebinit

sudo pacman -S wgetpaste
inxi -Fxxxz | wgetpaste

ad always

1 Like

Thank you @damico and welcome to the forums. :blush:

Command line: \boot\vmlinuz-5.0-x86_64

your using a kernel thats past EOL, which also means any extramodules are going to work properly.

if you already have another kernel installed, 4.19? select it from grub then uninstall linux50
sudo mhwd-kernel -r linux50

if you dont have another kernel installed, install one > reboot >choose it > uninstall 5.0
to install:
sudo mhwd-kernel -i linux419
or linux51, linux52, etc...

if boot is still slow:
sudo systemctl enable haveged --now

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by