Managing kernels and updating system & new to zsh

Hello Everyone.

I’m very new to linux, I dabbled a bit with mint and ubuntu learning a bit about regressions and some basic terminal commands then I jump to Arch and went through months of agony (because the first time I installed Arch I didn’t even know the cd .. command) installing and configuring the system afterwards. It taught me a heck of a lot and quickly but today I had to give up on Arch because I don’t have the skills to administer the system and trouble shoot issues. Not yet anyway, hopefully I’ll return to Arch as a power user. Anyway installing Manjaro gnome today was so so so pleasant. Having a fully fledged system up and running in such a short space of time is a wonderful thing.

When I first installed there was only kernel58 installed and I had dummy output and no sound. I found a fix on stack exchange and later saw the same fix here. The fix was to edit /etc/default/grub and put snd_hda_intel.dmic_detect=0 in the grub file. When I first did it following instructions from stack exchange I didn’t put it between the two apostrophes so it didn’t work. I ended up downloading linux57 and linux-lts. The lts kernel worked and the sound was fine. Then I found the fix on the manjaro site and it explained about putting the line between the two apostrophes, now it works.

I have a couple of questions.

  1. When I downloaded the kernels I used sudo pacman -S linux... etc
  2. When I updated grub I used sudo grub-mkconfig -o /boot/grub/grub.cfg
  3. When I checked what kernels are on my system I used pacman -Q | grep linux
  4. If I wanted to delete a kernel i’d use sudo pacman -Rns linux.....

I noticed manjaro has its own way of handling kernels with commands starting with mhwd is it okay for me to manage kernels with the commands I learnt whilst on Arch?

how do I know how much space I have for kernels? At the moment I’m running linux58 but I’ve got linux57 and linux-lts I think it’s 5.4.

Before I do a full system update should I be checking Arch news?

also when I ran sudo grub-mkconfig -o /boot/grub/grub.cfg I got this warning: /usr/bin/grub-probe: warning: unknown device type nvme0n1 I found a fix on endeavour which was to sudo rm /etc/grub.d/60_memtest86+ I did that and the warning is gone. Was that okay that I did that? I’ve got timeshift sorted so I could go back, If that wasn’t the correct fix is there one?

Also I’m not used to zsh I’ve only used bash. I installed manjaro a couple of times today. The first time when I was downloading kernels the writing in the terminal all went red, why was that? but the second time I installed manjaro and downloaded kernels the writing in the terminal stayed white, so I couldn’t reproduce it. Is there any issue with me changing the shell with chsh -s /bin/bash

I apologise for any mistakes that I’ve made in this post and thank you in advance for any help.

Welcome to the forum! :slight_smile:

Manjaro is not Arch, although it sources a great deal from Arch. You should use mhwd-kernel for installing and removing kernels in Manjaro.

You have as much space as the free space on the filesystem containing the contents of the /boot directory ("folder’) offers you. So if you do not have the contents of /boot on a separate partition, then you have as much free space as there is on your root filesystem. :wink:

I don’t see why. :man_shrugging:

Manjaro is a curated rolling-release, which means that updates are bundled together and properly tested before they are pushed down into the Stable branch.

There will be an announcement about every major update under the #announcements category, so be sure to subscribe to notifications for that category. You may then also get a preview of what’s coming down the pike via the announcements for the Testing and Unstable branches.

This is normal and can safely be ignored, but it is rare to ever need to rebuild /boot/grub/grub.cfg by hand. It should suffice to simply use… :arrow_down:

sudo update-grub

… after you have modified /etc/default/grub or any of the scripts under /etc/grub.d/.

Also, you didn’t have to delete that file. Simply removing its execute permission would have sufficed.

I have no idea ─ I use bash ─ but zsh uses a lot of theming, so that may be one of the reasons.

No. :slight_smile:


Thank you very much Aragorn for answering all of my questions and so quickly.

just to confirm:

  1. From now on I’ll learn and use mhwd but was it okay that I used pacman -S and the other commands?

  2. should I go back with timeshift or is it okay that I deleted the file? If I should go back how would I remove its execute permissions?

as I always do i’ll be taking notes on everything you’ve said and learning from it.

I really think Manjaro Is the ultimate perfect distribution for me.

I haven’t learnt about chmod and chown yet but I will soon. I’m assuming I’d use those commands to changed the execute permissions

Thank you very much.

1 Like

Maintaining a Manjaro system is no different than Arch.

What sets Manjaro and Arch apart is the convenience tools like mhwd.

On Arch you need to know which package you need to supplement a given kernel - virtualbox or nvidia drivers - and you may forget something.

mhwd is a tool which handles the necessary dependencies ensuring that when install a new kernel - the necessary modules are installed automatically.


In addition to what @linux-aarhus said with regard to mhwd ─ which is a lot easier to use than individually hunting down the required packages for your kernel ─ removing the execute permission on that file is as easy as… :arrow_down:

sudo chmod -x /etc/grub.d/60_memtest86+

Thank you both for your help, time and knowledge. I don’t know if this sure go to another post.

The hair that broke the camels back for me with arch was when the wifi stopped working. What linux-aarhus said reminded me about it so I just checked sudo journalctl -b I was assuming/hoping that because Manjaro is more complete, (well its a more complete installation than what I did myself on Arch) that I wouldn’t have issues like the wifi issue. on Arch a day or so before my wifi stopped working I noticed this
Oct 30 17:24:21 The-Eagle wpa_supplicant[845]: nl80211: kernel reports: Attribute failed policy validation
Oct 30 17:24:21 The-Eagle wpa_supplicant[845]: Failed to create interface p2p-dev-wlp0s20f3: -22 (Invalid argument)
Oct 30 17:24:21 The-Eagle wpa_supplicant[845]: nl80211: Failed to create a P2P Device interface p2p-dev-wlp0s20f3

But I didn’t think much of it because my wifi was working. aaarrrrrggghhhh now I’ve just seen it again, heart dropping, lol.

I really hope my wifi doesn’t stop working because thats not something I can do without.

I tried to add the output of sudo journalctl -b to this post but I wasn’t able to as I don’t know the correct way to share large output here.

should I open a new post?

also I just notice when I do timedatectl that my system clock is not synchronized. Should I do sudo timedatectl set-ntp true and sudo hwclock --systohc

Yes, please. :wink:

And as for adding longer code or terminal output to a post, click on the </> button in the editor. You will see something like this appear… :arrow_down:

indent preformatted text by 4 spaces

Highlight that sentence (in your own post) with the mouse and paste the output in its place.

Yes. :wink:

Thank you very much i’ll open a new post.

I tried what you said in this post but it wouldn’t let me send it as it said to many characters or something.

I clicked the sign then highlighted the txt then pasted the log in its place but it didn’t work

Then the best way ─ which I use myself ─ is to type three backticks (`) on a new line, paste your output, and then type three backticks again on yet another new line.

oh my gosh, i’m sorry but that didn’t work for me either. I did:

pasted here

but it didn’t work

lol but that did work but when i paste the log it doesn’t it says its too long

it says body limit is 150,000 but my log is over 200,000 how am I meant to post a log?

That limit is there for a reason. :wink: We don’t need your entire system log. :slight_smile:

Anyway, this is off-topic. If you want help with that WiFi issue, open a new thread under the #support:network category. :wink:

okay no problem. lol I’m not used to posting online etc I only learnt recently and on Arch I posted entire logs and just put code in brackets around them. lol I get you don’t need the entire logs. Thanks again for your help time and patience.

thank you.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.