Making windows cover KDE taskbar shadow

kde

#1

Hi! I hope it’s alright to post this here…

I use KDE and have had absolutely no problem with it (thanks Manjaro devs!) I have one little niggle, though: I have the taskbar on the top of the screen and, as a result, the taskbar’s shadow is drawn over application windows. This problem is minute and I barely notice it, but it would look just that little bit better if it was possible for windows to cover that shadow.

PS: I already know to use xprop -remove _KDE_NET_WM_SHADOW for a temporary effect, but I don’t want it removed completely - I just want windows to cover it.)

Thanks!


#2

I am not sure this is possible. You dont get the shadow with panel setting ‘windows can cover’ but otherwise if it is visible and the theme has a shadow then it will appear. For now you can either remove it or have it. I havent looked around to see if there is a standing bug report or something on this.


#3

Thanks. Is there maybe a way to find the code for the ‘windows can cover’ option and copy the shadows part to the ‘always visible’ option (which I use).


#4

The add that to a script that runs at startup (make it executable too), either to ~/.config/autostart-scripts/ or create a *.desktop file inside ~/.config/autostart/ that is pointing to the script. Reboot and …


#5

Thanks @bogdancovaciu.

I would do that, only I still have to click on the menu itself for the command to take effect. Also, I don’t want to remove it completely. I only want windows to cover the shadow (like, as @cscs mentioned, the ‘windows can cover’ panel setting allows… but I don’t want maximised windows to cover the taskbar!!!

This isn’t a serious issue at all - it would be nice for there to be a fix, though.

Here’s a picture of my desktop with Firefox open. If I go to do something in the taskbar, I notice it and however small that shadow is, it looks a bit odd.


#6

It will apply globally, but you can do this:


#7

Doesn’t “latte-dock” have an option precisely for hiding panel shadow when maximized window?

That sounds like a sensible workaround somehow…


#8

Thanks @cscs. This is interesting. I was looking to change the transparency.
On the subject of the panel shadow, though, do you know where any of the code for the panel is stored? Also, there is a colors text file in the plasma theme folders with a Window Manager section at the bottom… Could I use this at all?


#9

The Latte Dock is great, @Signalrunner, but I tried it already and I’m afraid it doesn’t have this feature.


#10


Though I have the ‘Always Visible’ option selected, The window does cover the shadow if I drag it to the top of the screen and it dims the screen to show where the maximised window would be… maybe there’s a way to set this window behaviour as default?


#11

Oh, all right, my mistake. Now I get it, you want for windows to be drawn on top of the shadow even when not maximized. Then I don’t know.


#12

No problem at all @Signalrunner.

Both Windows and Mac OS do this - it’s no big deal but it makes the desktop look that little bit better…


#13

I seem to think this is achieved by disabling compositing when a window is maximised? Check your compositing settings.


#14

Thanks @jonathon
This partly solves the problem but I don’t want anything disabled. I just want windows to cover that shadow! That’s all!


#15

?


#16

Thanks for the input @jonathon, @cscs, @bogdancovaciu and @Signalrunner

I just re-downloaded the Latte Dock and it does indeed have the option to hide the panel shadow when a window is maximised, @Signalrunner. This is probably the best fix for this issue that is available, so I might mark that post as the answer.

Would it be fine, though, to leave this post up for a bit longer to see if there any other work-arounds?


#17

Use arc dark or adapta KDE theme


#18

Thanks @Shrinivas17081997 but I like the default Manjaro theme.

@jonathon I just decided to use that script from the reddit thread as it’s the best solution - I copied and pasted it into the ~/.xinitrc file but nothing happens! Am I doing it wrong?


#19

how about setting the panel to autohide? that way there’s a few extra pixels and no shadow over your application windows. all you have to do to get the panel to show again is move the cursor towards the top edge. there is a buffer to prevent it getting annoying by triggering too soon when trying to drag a window instead for example.


#20

I see you are still looking for a solution. Personally i use the Panel on top of the screen with the option Windows Go Bellow, reduced it’s size on horizontal so the default buttons on opened windows will be seen like this:


The gap you see there in the corner is because i use Quarter Tiling, and on Window Decorations i use Breeze and set the Shadows to small size. That way nothing goes in the way. Arc-Dark for Desktop Theme and color, no Kvantum on this rig, and latte-dock has for the 3 Activities different layouts.