Major Steam problems

OK, after some lockups, I reinstalled. installed steam-native, clicked the icon and it came right up. I had to add my extra Steam folders, and it crashed. Since then, it starts, executes a long disk write, and crashes. I’ve been unable to start steam-native as well as steam-manjaro.

Does anyone have any ideas?

Which are? Sounds like it worked until you did that.

I have a partition on a SSD and an external drive with games.

And, of course, Steam started after my initial post. And crashed again when I tried to add the external drive.


What file system is in use on the external drive? Ext4, NTFS?

Ext4. All my drives use that filesystem. gnome-disks showed it as being error-free.

Maybe create a new library folder on the external drive, then add each game to it one by one from the old library.

Well, I created another folder called “teamapps,” moved the contents of steamapps to it, deleted the empty folder and renamed the new folder. I cannot move apps from one drive to another unless Steam is running, and that remains problematic. :frowning_face:

If you run Steam from the Terminal, is there an error showing at crash?

1 Like

Yes, and a .dmp file was submitted. I “solved” my problem by (gulp) deleting .local/share/Steam. Adding the SSD partition works fine. Adding the external drive crashes Steam and renders it unloadable.

And now I have terabytes to redownload.

I formatted the external drive and was able to add it as a Steam folder, and am downloading games to it.

Many hours to go, but stuff happens.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.