Main language can not found by installed apps

My (up to date, ~ 4 month old) Manjaro all settings is Hungarian (main language, number/date format, time zone etc.).
Hun. language packs installed for FireFox and Thunderbird.
Despite of this, all times when FireFox update done, it become English, I have to set it back to Hungarian manually.

My second problem is to FileZilla installed English and I can not set it to Hungarian (or other language).
I have a VirtualBox machine (also Manjaro) and an installed FileZilla with the same way (sudo pacman -S filezilla).
It is Hungarian from the first launch and I can change language!

I did not found other seeting than “Settings Manager → Locale settings and Language packs”
There is not possible to went somethimg wrong with my Manjaro?
Where and how can I it repair?

Best Regards,

Hello @Imre,

whats the output from these 2 commands:

localectl list-locales
localectl status

The first is very long list (more than 160 row, if you want, I will copy all here, Hungarian is in)
localectl list-locales



localectl status
System Locale: LANG=hu_HU.UTF-8
VC Keymap: hu
X11 Layout: hu

any .pacnew in /etc/ e.g locale.conf.pacnew ?

sudo find /etc/ -name “*.pacnew”

I had saw into locale.gen.pacnew and all locale (row) is remarked (with #).

Have a look here:

1 Like

My locale.gen contains two locale enabled, so it is good.
It is changed by Calamaris during the installation process.
I do not understand why you offer the link, what need to look?

#en_SG ISO-8859-1
en_US.UTF-8 UTF-8
#en_US ISO-8859-1

#ht_HT UTF-8
hu_HU.UTF-8 UTF-8
#hu_HU ISO-8859-2

I’d not touch either one of these.
The first one:
is there because the syntax has changed - but the old syntax is still supported
and probably for quite long time
the difference is that the keywords used to be inside quotes
whereas now they are inside parentheses

no need to tend to it right now

Even less need to address /etc/locale.gen right now.
Yours should be o.k.
although you seem to have enabled all of them, instead of just the few that you want/need.

grep -v ^# /etc/locale.gen
shows which lines are enabled (are not starting with #)

As I wrote, I did not edit these files directly.
These two locale is set by settings manager:

grep -v ‘#’ /etc/locale.gen
en_US.UTF-8 UTF-8
hu_HU.UTF-8 UTF-8

sorry! I must have misunderstood this, what you posted:

it looked like all of them where enabled
instead of just a select few
which is … overkill, but still perfectly all right

and, with my post, with my interjection
I tried to clarify the relevance of the @jrichard326 post
to look at the .pacnew files.

What I was trying to say was:
this is not relevant here - ignore it :sunglasses:

I used too many words to say/explain that essence … adding to confusion rather than clarity in doing so.