Main Drive Doesn't Seem Right

Long story short, I recently just got a second drive for my Manjaro PC, and while trying to create a partition to access the drive I completely wiped my computer. Really stupid thing of me to do. While reinstalling Manjaro onto the pc, I noticed this in the BIOS.

It did not look like this before. It showed the two drives, and the option to enter setup, that’s all. I have no idea why the top two options are there. The top two both boot me into Manjaro, but the normal 970 drive doesn’t. This is absolutely not how it was before.

Also, under “Devices” in my file manager, it no longer shows my main drive that I have the OS installed onto.

This is what my drive looks like on KDE Partition Manager.

Furthermore, I’m not entirely sure if this is related, but I tried downloading Private Internet Access PIA VPN on my system. I downloaded the .run file, and tried to run in console, but was met with this.

I downloaded the .run file into a folder in my profile directory where the default folders and such are.

Is it worth a reset? Things really don’t seem right with how they are configured on the drive. Any help would be greatly appreciated.

Please contact your hardware manufacturer on how to reset the UEFI firmware (you don’t have a BIOS, you have UEFI firmware).

That’s normal: “Devices” shows the non-root devices but you have none any more: everything is allocated to Manjaro’s root FS right now.

Please read this:

Especially the section “How to install software”… :man_shrugging:

No one can answer that question, except you. However, if you do decide to reset the UEFI firmware according to your manufacturer’s instructions, you’re in for a reinstall anyway and I’d take:

  • 1G for EFI,
  • 64G for /,
  • RAM+SQRT(RAM) for swap
  • 800G for /home and leave the rest unallocated.