Macbook Pro 2011

#1

I am making this thread to hopefully get my system running correctly and also create a resource for anyone in the future trying to do the same or at least a list or reasons not to do this.

A family member gave me a Macbook Pro. Didn’t have the password and I have never really cared for Mac OS anyways so I wiped it and put Manjaro on it. Worked surprisingly well right off the bat. I have not experienced most of the common problems reported with linux on a Macbook; wifi works, touchpad works (mostly), keyboard backlight works, volume controls work (haven’t actually tested sound though). I do have the 30 seconds of blank white screen at boot but am hoping getting my hands on a Mac OS recovery disk and running the bless command will fix this. The issues I am having are:

  1. Runs crazy hot.
    I haven’t ever really used a Macbook so this could be normal but I find it hard to believe. I think this might be due to the dual graphics cards. Looks like there are two Nvidia cards. Would have thought one would be Intel like another old laptop I had.
    The bandaid for the old laptop was to disable the Nvidia card. Although that issue was battery life rather than heat output specifically and with two Nvidia cards I don’t know if the fix I used would work properly.
    I tried installing the Nvidia drivers but then the whole thing wouldnt boot. Had to reinstall the free drivers from the command line.
    I saw a link somewhere about linux macbooks with multiple graphics cards but now I can’t find it. Anyone know anything about this?

  2. Keyboard and Clicking unresponsive.
    Cursor moves around fine but clicking or typing does not produce anything on the screen. Being pretty useless I don’t have much ability to fix this. I upgraded to the latest kernel, which did nothing. I do not recall the keyboard being unresponsive while in the command line which makes me think this is maybe linked to my graphics issue or an xorg problem. Anyone have any thoughts?

  3. Battery Reads fully changed and 50% at the same time.
    This has not been a significant issue yet as I haven’t used the laptop on battery. The system says the battery should be ~70W, but shows it at ~35W. Not sure how it measures watts or charging status. I guess charging status is a current measurement and seems like capacity is just measured W / expected W. Would explain the readout I am getting but I have no idea how to go about fixing that. Or what the battery is supposed to be Watt-wise for that matter.

Thanks to anyone who can help. I will keep poking around when I get another chance and update this post with fixes or additional issues.

#2

Did you install TLP and ThermalD ?
Just look with terminal if you have that running.
For that you also need lm-sensors etc. You can find enough about that here on the forum or better on google and arch wiki.
With Psensor you kan monitor the temps

Your battery problem looks like the battery is written off. I have it also with my macbook, because he did to many cycles, and is old. You could change battery at the apple store, or live with it. And since the macbook is old (2011) i prefer to keep it this way or change the battery yourself with the https://eustore.ifixit.com/index.php?lang=1&cl=search&searchparam=battery+macbook+2011 Ifixit kit.

#3

So the MacBook doesn’t have the integrated intel GPU? I also have a MacBook Pro Late 2011 but with intel/radeon.

#4

I’ll look into the temp monitors.

I’m less concerned about the battery. If I can get everything running properly I’ll replace it.

#5

It appears I was mistaken with my identification. I googled ‘a1286’ which came back with 2011. Looks like that model was used over a span of multiple years. What I have is closer to this:

https://everymac.com/systems/apple/macbook_pro/specs/macbook-pro-core-2-duo-2.66-aluminum-15-mid-2009-sd-unibody-specs.html

The older core duo units had two Nvidia cards. will positively Id this thing tonight.

#6

I have determined this laptop is the one linked above.

Core2 Duo 2.66GHz
4GB RAM
Nvidia 9600M GT & 9400M

I wanted to install TLP and thermald. However in trying to connect to WiFi, here at home, the system crashed. On reboot I no longer have WiFi available as a connection option or have an ability to enable/disable it.

I have in the past connected my Windows laptop as a WiFi access point for my desktop (also running Manjaro). But for some reason that is no longer function with either the macbook or my desktop. Also couldn’t figure out how to get the macbook connected through Ethernet to the desktop with has WiFi.

Booting Manjaro with the live USB does not give me WiFi either. So I guess this this just fried itself when I started it up tonight?

#7

you can connect a smartphone to it by usb cable and your computer can ‘borrow’ the internet connection from your phone.
just time enough to download a wifi driver what works.
try to figure out what wifi you have onboard and google on it together with linux, or arch or manjaro. good luck

#8

it is running hot because 2 GPU's are running at the same time, I would suggest disabling 9600m GT from grub so manjaro only sees 9400m after that install nvidia drivers from system sittings>hardware configuration. you will see that your laptop will run much cooler and will save battery life you will even get rid of screen tearing when scrolling in firefox.

This helped me solve my issue

https://askubuntu.com/questions/73332/how-to-deactivate-nvidia-9600m-gt-on-a-macbookpro-5-1-5-2-5-3

this is how it looked before and after modifications.