macbook does not recognize the wifi BCM4321

hola @nuwonda wonda como estas, me comenast como hiciste para instalar el wifi en tu distro, tengo la misma macbook pro, pero no puedo hacer andar el wifi, vos pudiste?

hola @stelar ecoya @Secoya pudiste hacer andar el wifi en la mac 2008?

@tbg
hello how are you, do you know that my macbook does not recognize me the wifi BCM4321 help me to solve it?

Thread split

Try this:


Run the following commands to automatically add new kernel boot parameters and modify NetworkManager's behaviour:

sudo cp /etc/default/grub /etc/default/grub.bak && sudo sed '/^GRUB_CMDLINE_LINUX_DEFAULT=/s/"$/ ipv6.disable=1 net.ifnames=0 module_blacklist=wl"/g' -i /etc/default/grub && sudo update-grub &&  echo -e "[device]\nwifi.scan-rand-mac-address=no" | sudo tee /etc/NetworkManager/conf.d/disable-random-mac.conf

The process will take a little while to complete, and this is perfectly normal.

You may need to press the ENTER key several times to complete the commands and be returned to the command prompt.

Once the entire process is complete, reboot.

After rebooting run the following commands to load the b43 kernel driver/module:

sudo modprobe b43 && sudo systemctl restart NetworkManager

If that command works properly to start your wifi then you can automate the process with a startup service:

The b43 driver can be made to load automatically after start up with a service.

Create the following file with a root capable text editor:

/etc/systemd/system/b43.service

Add the following contents to the service file:

#/etc/systemd/system/b43.service
#sudo systemctl enable b43.service
#sudo systemctl start b43.service
#systemctl list-unit-files --state=enabled
#sudo systemctl status b43.service
#sudo systemctl stop b43.service
#sudo systemctl disable b43.service
#sudo systemctl daemon-reload

[Unit]
Description=Modprobe b43 module after start up
After=network-pre.target

[Service]
Type=simple
ExecStartPre=sleep 3
ExecStart=/usr/bin/modprobe b43

[Install]
WantedBy=multi-user.target

Once you have created and saved the service file, enable the service:

sudo systemctl enable b43.service

Then reboot the computer.

Hopefully that will fix you up.

If your connection is still not working then you will need to post the inputs and outputs of all the commands I have given.

hola, desintale todo, instale el b43, y me tomo el b43 luego de instalarlo bien corectamente, reinice y me quedo resuleto el problema. uso Archlinux ultima version. depues de buscar mucho e intentar ucho quedo resuelto. muchas gracias, me lei todo lo que ponias en los otrs post, e intente hacer todo, pero bueno ya quedo resuelto , muchas gracias buen hombre.

1 Like

Forum kindly sponsored by