Mabox Linux 17.02 - Manjaro re-spin with Openbox is ready

openbox
respin

#21

trying to install on the HP Stream but… it doesn’t seem to see my (any…) wifi network :frowning:
Checked in the settings and this is what I get:

How can I install this controller? There’s no other way to connect the Stream beside the wi-fi… obviously I could download it on another machine, but exactly what and what after that?
Thanks :smiley:


#22

Right click on network-broadcom-wl and select uninstall.
Then in a terminal run sudo modprobe b43.
This should work for the rest of your OS’s life.


#23

thanks eugen-b, working on another machine now, I’ll do it a bit later :slight_smile:


#24

OK, I will try it out then, thanks! :stuck_out_tongue_winking_eye:


#25

If Manjaro is going to continue to hide the install option on this screen, I’s recommend a clue that Install via Right-click is possible.

Careful wording should be used so as not to encourage wanton reinstalling of proprietary drivers when open source ones are working.

I have the same situation with Realtec R8168 nic. It happily uses the r8169 driver, but it will install a r8168 specific one if I click that hidden install option. The specific one is 6 time larger and provides no better service.


#26

at the end I didn’t need that, it was just from the flash usb, once I actually installed the os and booted… wi-fi recognition was there without any other effort from my side :smiley:
Thanks anyway for the reply!


#27

On a second thought, I think I’ll install it on my lower spec machine instead. My Cinnamon has received too much love from me! :blush:

Oh, and conky’s transparency is kinda bugged on amd free driver. How to fix it?


#28

How can i get steam to run its not running. With just the mesa driver. I installed mesa and lib32-gl mesa but still not running. If anybody can help me out


#29

How about starting your own thread ? be sure to include system info and what errors you encounter (steam always logs itself, but you can also try to start in terminal and copy output)


#30

“Control Center” is written in bash and uses YAD -> https://sourceforge.net/projects/yad-dialog/

Here source -> https://gist.github.com/napcok/1970e90b37ea3c66442884da228f9ab9


#31

Aah, yad! I remember trying it once long ago. How would you say it compares to zenity?


#32

YAD is zenity fork, with many improvements. I think with yad you can write a little bit more advanced forms and gui.
Anyway, after spending some time with yad, I think I should really start to learn python-gtk or python-qt :wink:


#33

Another nice review video:


#34

Hi there,
coming from crunchbang I played around with Manjaro 0.8 and ArchBang in VMs a while ago.
That brought me into the arch linux world. Much more to learn but still very interesting.
And after my crunchbang system is dying more and more the last weeks I decided finally to change to arch in some way.
After testing a lot of all the interesting LiveCDs available I stopped at the community JWM Manjaro ISO (Holmes).
So I installed it for a closer look and testing JWM which I didn’t know before and it was good.
I was close to add openbox and test it on my system and now I see this Mabox version! Yeah!

Perfect timing! Thanks a lot for it. I’m just waiting for the download to finish… ah, come on!

Edit: Testing right now the LiveCD on my notebook.
This feels really great. :grinning: Everything feels well structured.
And it has terminator as terminal, yeeesss. At all - aaah, good old feeling.
Only ‘Openbox Configuration Manager’ isn’t opening on this machine?!

Edit2: Napcok, thanks again for this Manjaro-Openbox version. This feels really sharp! :+1:
I installed it on an usb-stick today for a rescue machine (old Dell E520) which I use to ddrescue some old disks.
Before I used Caine 7.0 for that but it was a little slow. And I only need ddrescue and zfs for some new destination storage. So I decided to use this one and can check it out too.
You have done a really nice job. It’s damn’ hot fast even on that stick. :grin:
And there are a lot of helpful things if you’re not familiar with openbox and tint2. This will support users for getting into openbox a lot.
I know I will have a lot of fun with this rescue system and especially installing it on my workstation.
…sorry folks for the flipping but this one feels so great and right like ~4-5 years ago when I found crunchbang. :heart_eyes:
have fun and rock on


#35

no touchpad setting…how to enable tap on click ??? btw i love too…


#36

Great - can I fork you iso-profile some place?


#37

Finally got the time to test it. LOVE IT !!!


#38

I’ve always loved Openbox, and I did muse on installing one of the old community editions of Manjaro Openbox, back in the day but opted for XFCE OpenRC instead.

I’ve loved playing with Mabox in Virtualbox, although I simply can’t get it to install :cry:

I’ve tried the installer links from the tint bar, the menu and even tried upgrading calamares etc during the live session to facilitate an install as I would love to install Mabox as my main Manjaro OS with the forthcoming death of support for OpenRC.

Simply put Mabox is pretty much the openbox Manjaro community edition of my dreams, :heart_eyes: so not being able to currently install it to a virtualbox hard-drive doesn’t bode well for me installing it on my main box :sob:

@napcok if you can either tell me where I’m going wrong or let me a know a workaround/fix, that would be awesome!

Thanks!


#39

@cybersquid thats strange issue. You can try run sudo calamares from terminal.


#40

Hi Napcok!

Yep, your suggestion worked, mant thanks @napcok! :grin:

I also tried to replicate what happened last time when I couldn’t install. I think that some how I managed to click on the installer icon on the tint bar and calamares was trying to load but the gui wasn’t showing on screen, but it was still listed as a running process.

Anyhow your suggestion worked so was able to install it onto the Virtualbox hard drive to enjoy :grinning:

Thanks