Low frame rate with Virtio video in Gnome Guest

I installed a Manjaro Gnome virtual box on Ubuntu server. It works fine with QXL video and GUI responses fast. But after switching to Virtio video, the GUI frames refreshes slowly. I can see frames refreshes when bringing up the activities view. Is this behavior expected, or any switch to tune it? Thanks.

I don’t think mesa is compiled with the option gallium-drivers=virgl as required for guest to use vitrio …
https://wiki.archlinux.org/title/QEMU#virtio

I see…thanks. Below is dmesg output.

# sudo dmesg | grep drm  
[    0.894856] [drm] pci: virtio-vga detected at 0000:00:01.0
[    0.895227] [drm] features: -virgl +edid -resource_blob -host_visible
[    0.895769] [drm] number of scanouts: 1
[    0.895775] [drm] number of cap sets: 0
[    0.895985] [drm] Initialized virtio_gpu 0.1.0 0 for virtio0 on minor 0
[    0.896972] virtio_gpu virtio0: [drm] fb0: virtio_gpudrmfb frame buffer device
[    1.535057] virtio_gpu virtio0: [drm] drm_plane_enable_fb_damage_clips() not called
[    1.777736] systemd[1]: Starting Load Kernel Module drm...
[    1.785185] systemd[1]: modprobe@drm.service: Deactivated successfully.
[    1.785305] systemd[1]: Finished Load Kernel Module drm.

On what kernel is this? Might want to try the linux516

Guest is Manjaro Gnome with 5.15 LTS. Host is Ubuntu 21.10 with kernel 5.13. After upgrading guest to 5.16, same output as below. Does host kernel matter?

[    0.350626] ACPI: bus type drm_connector registered
[    0.861525] [drm] pci: virtio-vga detected at 0000:00:01.0
[    0.861762] [drm] features: -virgl +edid -resource_blob -host_visible
[    0.861764] [drm] features: -context_init
[    0.862254] [drm] number of scanouts: 1
[    0.862262] [drm] number of cap sets: 0
[    0.862528] [drm] Initialized virtio_gpu 0.1.0 0 for virtio0 on minor 0
[    0.863969] virtio_gpu virtio0: [drm] fb0: virtio_gpudrmfb frame buffer device
[    1.446341] virtio_gpu virtio0: [drm] drm_plane_enable_fb_damage_clips() not called
[    1.728955] systemd[1]: Starting Load Kernel Module drm...
[    1.734788] systemd[1]: modprobe@drm.service: Deactivated successfully.
[    1.734858] systemd[1]: Finished Load Kernel Module drm.

well, from what i read, but maybe i misunderstand, that drm parameter should be fixed on 5.16 kernel, but then again, not sure about mesa