Lost Plasma desktop after update


so I have this oldish laptop I keep sitting around at my workplace for occasional internet, taking notes or printing a document:
Lenovo T400, Intel Core2 Duo T9400 with Intel Mobile 4 Series Integrated Graphics, running the integrated laptop screen as well as an external monitor. Original BIOS, not converted to libreboot yet.

Last time I used it (a few days back) I must have finished by running an update, as I was now greeted by a newly designed login screen. Guessing it was updated to Plasma 5.21.1 before last shutdown.

Plasma starts, I get the graphics login screen, then a black screen with some plasma logo and info text and finally the screen goes black with a mouse cursor.

By pressing F12 I get the Yakuake drop down terminal and from this I can start applications such as the Firefox I’m writing this in, or Dolphin etc.

Figured something must have happened with the last update I ran so I ran another pamac update from the command line and indeed it updated some more stuff, but the problem persisted (after reboot). Now pamac tells me “nothing to do”.

Hence, X-Windows support for the applications seems fine with full support for both screens, but no display of a usable desktop interface, nor wallpaper or anything else (just the mouse cursor).

Any pointers as to what might have gotten bodged by the Plasma update/upgrade resulting in the loss of display of the graphical desktop environment?

Thanks in advance!

P.S. I had found threads on this forum and on the KDE forum suggesting the exact same problem being caused by having kwin-lowlatency installed and solving by replacing it with stock kwin (5.21), but my machine already is running stock kwin.

1 Like

last time this happened to me was because of a custom plasmoid i installed. if you have any installed (any non-stock plasmoid), remove them from terminal and restart. you can also finsd the cuplrit if you dive into logs and lookout for plasma errors

Thanks koshikas, but nothing fancy installed here - pretty much out of the box manjaro KDE Plasma. Everything was fine until the update to 5.21 it seems.

Not a linux guru - GUI user mostly. No idea where to look for the logs connected to starting components of Plasma.

Tried stuff like
$ kquitapp5 plasmashell
$ kstart5 plasmashell --windowclass plasmashell

Not even sure it that could be usefull at all or if it is the correct command format.

First restart it complains some but seems to go active much the same way (no desktop) anyway.

Complaints are:

QObject::disconnect: Unexpected nullptr parameter
QObject::disconnect: Unexpected nullptr parameter
kf.plasma.quick: Applet preload policy set to 1
Warning: corona package invalid
Invalid home screen package
Containment graphic object not valid
Invalid home screen package
Containment graphic object not valid

Second time I issue the kstart5 command no complaints are displayed (assuming that it’s already running and hence not trying to restart)

If I do the same via sudo it comes back with this instead:

QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to ‘/tmp/runtime-root’
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to ‘/tmp/runtime-root’

but I’m wondering if it would make any sense at all to start it as root …

Consider this solved by a fresh reinstall, update and config orgy.

Third time in just a few month now that I needed to reinstall after a regular update, because it simply takes too much time to search, read, try, repeat …
Install, update reconfigure takes its toll too, time wise and emotionally, but there’s just no point. I use computers to do things I want to do, not for the purpose of becoming a guru in interpreting cryptic log file messages. Oh well …

To be complete on the issue that caused this:

Strange observation: I just did a reinstall with the same ISO I used last time (Manjaro KDE Plasma 20.1 something). After booting into the new system I ran an update.
Same thing happened as last time (I remember it now): After updating most items from the menu under the Manjaro-logo “Start button” (bottom left) were missing, so there was no way to shut the system down via this menu.
I now remember shutting the machine off after the last update that messed things up, by pressing the hardware on/off button for 5 seconds, due to this.
Thinking this may have caused some harm I now used the Yakuakakkae-whatever to “shutdown now” from cli instead.

Next, I was expecting to get the the same “different” log in screen that had greeted me on the broken system. A pastel blue-ish screen split vertically at about 3/5th width, with a login dialogue in the right hand section.
But this this time, after the update the login screen remained the same blackish-green with orange diagonal stripe top left and green Manjaro logo center with login dialogue under it.
Checked, but Plasma is showing as 5.21.1, same as after broken update.

Possibly the difference in login screen may be related to the desktop not showing?

Well, that’s just for extra info … like I said: “Solved” by reinstall

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.