Lost Permissions for my NTFS Drives

Not sure exactly what’s happened, but I can’t copy files or create files on any of my internal NTFS partitions. When I try it complains that I don’t have permission. I did do a fresh install of Manjaro XFCE, and set up the NTFS partitions as I usually do, but still I can’t copy anything over.

My fstab reads as:

/etc/fstab: static file system information.

#Entry for /dev/sda5 :
UUID=cf498f67-4125-4c42-956b-37d0eac010a7 / ext4 defaults,noatime 0 1
#Entry for /dev/sda7 :
UUID=54bdd174-57a4-4c5e-86a1-9558b592cabf /home ext4 defaults,noatime 0 2
#Entry for /dev/sdb5 :
UUID=357982570B259A4E /media/Audio ntfs-3g defaults,locale=en_GB.UTF-8 0 0
#Entry for /dev/sdb6 :
UUID=1AC709D553338872 /media/Comics ntfs-3g defaults,locale=en_GB.UTF-8 0 0
#Entry for /dev/sdb1 :
UUID=323D83BF1578C793 /media/Private ntfs-3g defaults,locale=en_GB.UTF-8 0 0
#Entry for /dev/sda8 :
UUID=53A1537A11345C69 /media/Storage ntfs-3g defaults,locale=en_GB.UTF-8 0 0
#Entry for /dev/sdb7 :
UUID=1C3E580F45CFC162 /media/Video ntfs-3g defaults,locale=en_GB.UTF-8 0 0
#Entry for /dev/sda6 :
UUID=3595daee-57e3-4f51-b8b2-bb44fd664af6 swap swap defaults,noatime 0 0

And ls shows my permissions as:

melchizedek$ ls -l media
total 20
drwxrwxrwx 1 root root 4096 Apr 28 02:18 Audio
drwxrwxrwx 1 root root 4096 Apr 28 02:18 Comics
drwxrwxrwx 1 root root 4096 Apr 29 12:52 Private
drwxrwxrwx 1 root root 4096 Apr 28 02:18 Storage
drwxrwxrwx 1 root root 4096 Apr 28 02:18 Video

Should the NTFS partitions have root permissions, or should they have user permissions? Not sure what to do, or even what’s wrong. Any suggestions?

https://wiki.archlinux.org/index.php/NTFS-3G

2 Likes

Yeah, I already looked this page up, but I’m not sure where the problem actually lies and I’m not sure what the permissions should actually be on NTFS partitions.

Try adding to options in fstab
uid=[YOURUSERNAME],gid=users,dmask=022,fmask=133

1 Like

All the directories on my ntfs partition show root ownership also, but I have no trouble writing to them as user. I read recently that ntfs doesn’t have user/group ownership and it always shows root ownership.

1 Like

Thank you. This is interesting. I tried adding what you suggested to one of my four NTFS partitions:

UUID=357982570B259A4E /media/Audio ntfs-3g gid=melchizedek,dmask=022,fmask=133

… and I still couldn’t write to it, but it freed up my other three partition and I was able to write to them. I then reset the code back to what it was on my Audio partition, and tried it with my Video partition instead, with the same result. (Couldn’t write to the Video partition, but could write to all of the rest.)

Lastly, I tried changing the code to all four of my NTFS partitions, and ended up not being able to write to any of my NTFS partitions. Any further suggestions?

Thats not quite what I suggested, but in any case try instead:

uid=melchizedek,gid=users,umask=0022

2 Likes

That sorted it, but do you know why exactly it went awry in the first place? It wasn’t due to an upgrade or me fiddling about. I’m at a loss to explain it. Why did the original fstab suddenly stop working?

Thank you!

Makes sense. Thanks!

I’m not sure as I dont deal with this filesystem on a regular basis :wink:

But from what I’ve ascertained that the default setup -

With this method, if the parent folder that it is mounted upon has the proper user or group permissions, then that user or group will be able to read and write on that partition(s).

And then youve got them on /media which is owned by root.
So we set proper permissions for your userid , gave normal (read) permission to group users, and set all new files to 0022 because

umask is a built-in shell command which automatically sets file permissions on newly created files. For Arch Linux, the default umask for root and user is 0022. With 0022 new folders have the directory permissions of 755 and new files have permissions of 644

because theres also this

Permissions on a Linux system are normally set to 755 for folders and 644 for files.

But please also refer back to what @badbodh said in the other thread, as I believe async and other things might be of benefit on an ntfs drive (again I dont use it and cant remember)

1 Like

i just added async because it comes under defaults and looks useful for other filesystems (on permanently attached hard drives) too. Terms and conditions apply.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.