Lost network after installation, both on live USB and main os

Hello, I am totally new to Linux and this my first distro, so sorry if I am a bit clumsy.
I installed the latest version of manjaro gnome today, had internet on live USB but after the installation I did not have it on the live USB nor the fully installed os. I tryed some things I found on forums but still nothing worked
I did the following commands in order to provide more info.
CPU 6 core amd ryzen 5 1600
Kernel 5.10.26-1-manjaro x86_64
Storage 1.8tb
Proces 282 shell zsh inxi 3.3.03

Nxi - n
Network device-1 Realtek rtl8111/8168/8411 PCI express gigabit ethernet
Driver r8169

IP link

  1. Lo: <loop back, up, lower_up> mtu 65536 qdisc no queue state unknown mode default group default qlen 1000
    Link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
  2. Enp4s0 <broadcast, multicast, up, lower_up> mtu 1500 qdisc fq_codel state up mode default group default qlen 1000
    Link/ether b4:2e:99:46:6e:c9 brd ff:ff:ff:ff:ff:ff

Sorry about the formatting I typed manually on my phone
All the help is much appreciated

** To test the r8168 driver:

sudo modprobe -r r8168 && sleep 3 && sudo modprobe r8168 && systemctl restart NetworkManager
1 Like

It works now, will it work after a reboot aswell? Or I need to do this every time?

you need

  • blacklist driver r8169 ( only r8168 can works )

If you install the driver from Manjaro Settings Manager → Hardware, it will make it properly for you.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.