Lost Broadcom wifi on 2015 16.5 iMac

Hi there my step dad has Manjaro Gnome on his 2015 iMac and now lost his Wifi, it has a BCM43602 802.11ac wireless LAN SoC (Broadcom) and I have tried both Linux515-broadcom and broadcom-wl-dkms and neither of them work anymore. I still have network via Lan and using a phone to USB tether but no wifi tho it does show in Manjaro hardware when you tick show all hardware.

Hi @gameslayer9999

My experience with WiFi problems it is mainly about:

  • Linux Headers
  • Drivers
    Try to install “linux-lts-headers” and “broadcom-wl” or “broadcom-wl-dkms”

I am not sure about your hardware or your installation, but the best is to go with defaults which uses LTS Kernel.

You may check Internet connection is way too slow - #6 by limotux

I hope this helps.
Please let me know if this is of any help.
Thank you.

I have the driver and linux515-headers as I also tried broadcom-wl-dkms but neither of them are working anymore and was a couple of updates ago, I did already mention it is using the 5.15 LTS kernel and kernel driver and was working before but now it isn’t.

I am not sure I can add something of value.

So, I assume it happened after the latest update?

Maybe try install the previous LTS which is 5.10, install headers and drivers, reboot to the newly installed kernel and see if it would work.

I tried 5.10 and 5.4 and it’s still the same

Here is the hardware info

  Host: garry-imac162 Kernel: 5.4.197-1-MANJARO arch: x86_64 bits: 64
    Desktop: GNOME v: 42.2 Distro: Manjaro Linux
  Type: Desktop System: Apple product: iMac16,2 v: 1.0
    serial: <superuser required>
  Mobo: Apple model: Mac-FFE5EF870D7BA81A v: iMac16,2
    serial: <superuser required> UEFI: Apple v: 428. date: 10/27/2021
  Info: quad core model: Intel Core i5-5575R bits: 64 type: MCP cache:
    L2: 1024 KiB
  Speed (MHz): avg: 798 min/max: 800/3300 cores: 1: 798 2: 798 3: 799
    4: 798
  Device-1: Intel Iris Pro Graphics 6200 driver: i915 v: kernel
  Device-2: Apple FaceTime HD Camera (Built-in) type: USB driver: uvcvideo
  Display: wayland server: X.org v: with: Xwayland v: 22.1.2
    compositor: gnome-shell driver: gpu: i915 resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa Intel Iris Pro Graphics 6200 (BDW GT3)
    v: 4.6 Mesa 22.1.1
  Device-1: Intel Broadwell-U Audio driver: snd_hda_intel
  Device-2: Intel 9 Series Family HD Audio driver: snd_hda_intel
  Sound Server-1: ALSA v: k5.4.197-1-MANJARO running: yes
  Sound Server-2: PipeWire v: 0.3.52 running: yes
  Device-1: Broadcom BCM43602 802.11ac Wireless LAN SoC driver: N/A
  Device-2: Broadcom NetXtreme BCM57766 Gigabit Ethernet PCIe driver: tg3
  IF: eno1 state: down mac: 38:c9:86:1a:cb:1c
  Device-1: Apple Bluetooth USB Host Controller type: USB
    driver: btusb,hid-generic,usbhid
  Report: rfkill ID: hci0 state: up address: see --recommends
  Local Storage: total: 938.97 GiB used: 17.26 GiB (1.8%)
  ID-1: /dev/sda vendor: Apple model: HDD ST1000LM024 size: 931.51 GiB
  ID-2: /dev/sdb type: USB vendor: Lexar model: USB Flash Drive
    size: 7.46 GiB
  ID-1: / size: 906.86 GiB used: 17.2 GiB (1.9%) fs: ext4 dev: /dev/sda2
  ID-2: /boot/efi size: 299.4 MiB used: 288 KiB (0.1%) fs: vfat
    dev: /dev/sda1
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%)
    dev: /dev/sda3
  System Temperatures: cpu: 44.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 210 Uptime: 25m Memory: 7.65 GiB used: 1.25 GiB (16.3%)
  Shell: Zsh inxi: 3.3.17

On network device 1 it says N/A even tho the driver is installed.

I have the linux-broadcom-wl and linux-headers for kernel 5.15 and 5.10

@linux-aarhus Would you be able to help me?

I have zero knowledge on getting Apple branded hardware working with LInux and even less with the broadcom wireless so what I can only offer my thoughts.

I suppose you are familiar with the Arch wiki on the subject?

If it is a kernel regression - I suppose the system is using stable branch - it may be worth testing on unstable branch - which is not that unstable - as it comes mostly from Arch - and kernel rebuilds happen more often there - and as such kernel regressions are fixed a lot sooner.

But that only points to something you have tried.

Perhaps you can clean up the testing - remove all broadcom packages - recheck the modules-load.d and modprobe.d for possible blacklisting - then reboot and try -broadcom-wl-dkms.

Hmm damn ok, maybe @brahma can help like he did on that post you mentioned

Also to add I definitely can confirm that I have everything and even in mhwd it’s not showing the Broadcom driver but on my desktop it does for my Asus PCI wifi card that uses a BCM4360…

I checked modules-load.d and modprobe.d and this is what they look like, in modules-load.d a file named linux515-broadcom-wl.conf exists

blacklist b43
blacklist b43legacy
blacklist ssb
#blacklist bcm43xx
blacklist brcm80211
blacklist brcmfmac
blacklist brcmsmac
blacklist bcma

I tried quoting out blacklist bcm43xx but it did nothing and in the file modprobe.d it was empty with oly this quoted line

# List of modules to load at boot

uninstall everyhtin related to broadcom and dkms broadcom, undo all conf related to it, then reboot and install:
pamac install linux515-broadcom-wl - if you running 5.15 kernel
reboot and see if that helps

Alright I’ll do that and do you mean with that one edit I made?

Ok so apparently it doesn’t even need any Broadcom driver installed and uses the build in brcmfmac driver

so it works now with the build in driver?

This was the one that worked for me as in the link [SOLVED] WiFi Very Slow, Eth. Is OK(with it linux headers)

My network card

I think same as yours, both Broadcom BCM43xxx

  Device-1: Broadcom BCM4313 802.11bgn Wireless Network Adapter driver: wl

So, I believe broadcom-wl-dkms should work as it did with me…

Since your blacklist is looong, I suggest emptying it, uninstalling any- and all things broadcom related, and starting from a fresh, blank slate.


And if you need help with that blank slate, then provide usable information, not just a screenshot, please.

I only had linux515-broadcom-wl but turns out even tho it’s a Broadcom chip it only works with the build in driver and I don’t need it

Yeah but I found it wierd that this Broadcom chip doesn’t need the Broadcom driver but I much prefer it like this and must be because it’s a old Broadcom chip