Lost ALL permissions after an update manjaro openrc_64 xfce


#1

thinkpad t440p
dual boot LINUX MINT MATE
have live cd for manjaro openrc_64 xfce

any way to restore permissions running live?
my ‘webfu’ found a couple similar but didn’t help and
to be honest i got a little lost.
distro won’t ‘let me in’ to anything including NM.
console-kit says installed in pacman gui.
ty in advance for any help and timely response(s)…
just want to get some things off the distro and go ARTIX
which it is migrating to.


#2

What exactly do you mean by “distro won’t let you in”?

What are the error messages you see and what are you exactly trying to do when you see them?

Can you not log into Manjaro Openrc or Linux Mint?

If you can log into Mint, can you access your Manjaro partition from there?

Can you access your Manjaro partition if you boot from the Live CD?

Is your Manjaro partition encrypted?


#3

Consolekit hasn’t been supported by Manjaro OpenRC for quite a while (it switched to elogind in March). That’s probably the cause of your permissions problems.


#4

thank you for looking…

What exactly do you mean by “distro won’t let you in”?
yes that is vague forgive me i didn’t want to ‘guess-speak’ on it

e.g. NM(NetworkManager)
[failed to add/activate connection]
(1) not authorized to control networking

-when attempting to connect to wifi

What are the error messages you see and what are you exactly trying to do when you see them?
in addition to the above ^^^ …there are these:

when i tried to run the update (in gui):

[failed retrieving file ‘multilib.files’ from doge.ing.puc.cl: could not resolve host: doge.ing.puc.cl]

[menulibre: local (1:2.1.0-1) is newer than community 2.1.3-2]

[authentication failed]

when i do the update in the terminal it throws connection errors ‘obviously’ due to the above^^^

so i:

[code]

service NetworkManager restart

  • Stopping NetworkManager … [ ok ]
  • Starting NetworkManager … [ ok ]
    Connecting… 0s [offline]
  • Marking NetworkManager as inactive. It will automatically be marked
  • as started after a network connection has been established.
  • WARNING: NetworkManager has started, but is inactive

Can you not log into Manjaro Openrc or Linux Mint?

yes. both.
MINT is fine.
Openrc is not.
i am given root though so it accepts my user passwd to login to the DE;
and my root passwd to become root

If you can log into Mint, can you access your Manjaro partition from there?

i believe so but am not skilled in doing that to be honest.

Can you access your Manjaro partition if you boot from the Live CD?

i would like to ask for help in this please…

live CD gives me web fine and i seem to be able to move around but it wouldn’t help me try and update

Is your Manjaro partition encrypted?

no. and lvm was not used on install.

ty…


#5

yes and i ‘think’ that’s what happened it was updated and elogind was put in consolekit’s place however;
i could not find any elogind files and as i stated before the consolekit still ‘shows’ installed in the gui pkg. manager.

ty…


#6

You can try logging in as root to Manjaro OpenRC and copy the data to a USB stick or to a different partition. If you do it with the terminal command
cp -a /home/username/Documents /mnt/destination
the -a flag will preserve permission and you will not need to change them for the new user.
If you cannot log in as root, you can mount the Manjaro home partition in Linux Mint (or from live USB) session
sudo blkid
find out which is your Manajro home partition (or / partition if you don’t have a separate home partition), let’s assume it is sda4

sudo /dev/sda4 /mnt
sudo cp -a /mnt/home/username/Documents ~/Documents/fromManjaro

#7

Whether you log in with a live cd or Mint, you should be able to see, open and browse your Manjaro partition in your file manager (it should appear in the left column as a drive). If you need files from your home folder, it’s in /home/your_username/ and from there you should be able to copy them over to your Mint partition or to a usb stick/external drive/other partition.

The most you can do is to copy the files you want to keep from your Manjaro partition, don’t try to get it to work or update it because it won’t work.


#8

eugen-b
muser

thank you both…
i will try these ‘workarounds’ and come back only after doing so.

[one sidenote]
i DO need to get online with the installed manjaro openrc to get to an opera browser i was ‘test-driving’ because its interface has no option to export bookmarks[lame] only import so one has to install an extra extension to the browser which enables the exporting.
i have some bookmarks i’d really want to get off that damn browser IF AT ALL possible.
i didn’t mention this in the original postings as it seemed trivial compared to resolving the bigger issues.
then i will write over the distro with another since openrc is migrating to ARTIX and no longer supported.
if you know of ANY way i can get online on the installed openrc i’d appreciate it…
i should be able to grab the other bookmarks from chromium/firefox et al. without having a connection.

ty to ALL…
[this post will be tagged ‘solved’ once it is]


#9

I’m not sure if it would work, but you could copy your whole opera profile and load it in another OS’s Opera.


#10

i will look into that ty…


#11

OK;
[Re: Solved…in a way]
i was able to login to the manjaro openrc partition as root.

i was able to connect via wifi with NetworkManager to web as root (though you can’t run tor as root for good reasons)

for kicks i attempted another update which started and ‘looked’ like it was cleanly updating without any authentication errors but…
there were errors @ the end of ‘invalid or corrupt’ packages from same coders so…

i ‘think’ it’s because openrc is no longer supported @ ALL.

so the positive is i didn’t have to go through all the steps you guys gave me to get access to the installed version.

and those steps are here in the forum for posterity if anyone needs them ^^^.

and i have them for the future if anyone has similar problems (some folks i have turned on to manjaro have just started running it (systemd) as noobs) i can reference them…

long live LINUX/UNIX and ROOT powers!!!..

thank you everyone for trying to help…

message ends.



#12

I must note, though, that it’s a powerful sword and I only suggest using it if it’s absolutely necessary.

PS: Could you save your Opera bookmarks in the end?


#13

Re: root
indeed i don’t pull it unless i’m going to use it.

still confused as to why i can’t get user permissions back when i can log in as user or root and can do things with the DE as root including going online no problem. the consolekit to elogind switch could be the culprit as another stated before ^^^.

Re: opera bookmarks
not (or not yet).
weirdly, it showed none when i was online as root which isn’t right unless i totally spaced moving them off to an external drive (still need to check them all).
i didn’t want to postulate about it in my response as i’m still working it.
‘if’ ‘when’ i do get them i will either post back here or to your user as to how i did it…

here’s something people might benefit from:

files used by opera:
https://www.opera.com/docs/operafilesnix/#mainprofile

opera’s command line options:
https://www.opera.com/docs/switches/

ty again…


#14

Look in /home/[username] for your opera profile. Root doesn’t use that directory, so if you run Opera as root it will create a new profile in /root.


#15

OK…
thought i did when i was ‘looking around’ e.g.:

[code]
#whereis opera

but none of those locales were where you stated.

will go back and look @ that ty…


#16

You won’t find it with whereis. The profile should be in /home/[username]/.opera (to see hidden directories try CTRL-H in the filemanager).


#17

It’s where cimarronline said. But if you insist on finding it via the terminal, locate would be the command for that.


#18

OK…
will try it all…
i’m practicing my command line so i don’t have to bother you guys and can help others…

i will be in environment tomorrow where i can spend some quality time on it ALL…

back with you then ty…


#19

have you check udev, dbus and elogind services are enabled, you can check in /etc/runlevels/{boot,default}. you can re-add them:

  • rc-update add udev boot
  • rc-update add elogind boot (delete if you find elogind enable in default runlevels: rc-update del elogind default)
  • rc-update add dbus default

and check your username is in “network” group


#20

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.