Lost administration control


Since 3 days now i have lost most of operation in Manjaro OS and i should mention that is the only OS in my pc for a few months. My choice become of needing individuality and freedom. This need become fulfill with this new environment of Linux and Manjaro. Last three days, that pretty feeling is almost gone. with My continuing failures to revoke admin rights, makes me feel unable. I have two admins. One admin’s password is locked in to his home folder, with result to be unreachable and main admin have lost his sudo rights somehow. I must also mention that I am not connect Ethernet with my proper cellphone account and i am struggling with a weak hotspot. The opportunity in that place is the understanding of rolling build of Manjaro, with my system collapse without connection. Please someone have idea? I apologize about deviated rules but i am very pressured with my job. I don’t mention what i have done since now because i can’t remember. To be honest, main reason of failure, is that those operations are very new and unknown for me. Every help is precious for me.

Welcome to the forum!

See the following post for how to regain sudo access. :arrow_down:

It is perfectly possible to use Manjaro without internet, but of course, given that Manjaro is a rolling release, the idea is that you’d keep your system updated, and without an internet connection, your system may become outdated quickly if you don’t update it very often.

Some essential parts of the system may change, and then the system will continue evolving from there on, but if you haven’t updated your system in a long time, then you’d be falling behind on those necessary adaptations to still be able to update your system without any problems.

It is also always recommended to subscribe to notifications for the #announcements category of the forum, because every major update always comes with an announcement that warns of potential problems and offers ways around them.


After first failure attempt, i proceed again Sudoers.d with more caution and i noticed my two same wrong files that i will delete. The original file “10 installer”, who almost ruin before. And one more file with name " ,ctdb". There isn’t any sudoers. I’ll delete the wrong files that i made before and i will left others as it is . I can’t see how to interact with them. I write a new file with the corrections you propose, but i feel that this is not the solution.

I am about 3 weeks without then amount of data i need for my work and for me, because an idiot compnanies problem. So my company offer unlimited data, useless for wireless tech like card-terminals. So. I use them in my desktop. But since then, almost 3 days, i had very few and weak net, with result OS and pc falling down with a kind of chaotic order. It was impressive. And the momment connected properly…
Haha. It was fun. looks like have tension. like alive.

I’m afraid your feeling would be wrong then. :wink:

1 Like

I wish really i was wrong and you be true but one more time…endless adventure keeps on. Some times i feel that computing needs more time than worth it achievements. At least with this OS and with Linux in general, changes are visible and stable. New things. Not the same in their orbits. I think it have to do with the evolving.
In our words, i put the lines to file and i think i found my mistakes like that “sudoers” the wanted file, founded out of “sudoers.d” folder and it wasn’t at his content files. When i find it, needs to correct it 2-3 times until keep changes. I know that it is stupid to do the same and expect different result, but i was despaired, but also every time i hope in a tinny difference to the procedure. And…3nd maybe 4th time it did. I was proud. Almost hacker. Sudoers had change. Also, for προληπτικούς reasons, before l left live and chroot environment, i make passwd to 2nd admin user with the lost password and thanks well.
As you maybe guess i was true. At the xfce desk now, system ask from his user with sudo and root problems verification for both admins. The new passw+ord of 2nd admin i think accept it. I tried 2-3 times with mine but in vain. It ask me something else. One more clue maybe. When i log both users, with the rights of 2nd admin with the new password, in the xfce desk, i try to change level of my main one without success. Now i am afraid to verify once more. Log for 1st Admin is
{ : user NOT in sudoers ; TTY=pts/0 ; PWD=/etc ; USER=root ; COMMAND=/usr/bin/nano sudoers}
Please i need guide

[Sorry that once more i havent read rules. It will be my next thing. As, ill put my specks at my profile?. I think that i need help because with this development, new technologies will pass.]

Just want to check if your user belongs to wheel group?

I think that i am. I also check in etc/group=wheel:x:998:chaosreigns,steanos and in etc/group-=wheel:x:998:chaosreigns,steanos

id steanos

uid=1000(steanos) gid=1002(chaosreigns) groups=1002(chaosreigns),998(wheel),995(audio),991(lp),3(sys),90(network),98(power),1000(autologin)

Sorry for latency of my respond. There is a lot of things to know yet. I came blindly from despaired with other OS.

I have lost and regain administration two or three times more since then from live USB & chroot enviroment, manipulate sudoers file with above instructions and with passwd users eachother and last with {sudo su - passwd root}. Once again now i face same problem by rejections admin password and root password. When OS reject most of times we take rejection as default and we dispute our memory. But there is cases that system is wrong and this is for me. It’s been 20+ days i haven’t got stable internet. Absence of updates system collapse. And by my ignorance to ask or to push for downloadings and corrections, i believe that i make it worst. With compination that Manjaro try to preserve it functions and
image! :joy: The result is that nothing seems wrong with first sight. With my experience neither with 3nd or 4th sight. So everything seems right except bellow a lot of tasks are broke. Mirrors could’t update their data, neither reset. But i think that this is for other post. Thanks for the help. I feel that i must run a Clamscan and whatever can do more, do it offnet, and back when it comes my normal connection.
Sorry for every inconsistency but i am out of time also with my berverage shop with main connection 20 days.

I believe that this problem is solved. Via USB/ISO & live enivironment. Boot in usb through BIOS screen… and then {sudo su -} to be root.
Then {Manjaro-chroot -a} to be live (I am not sure for reason of -a).Then i
create a root password to be sure for root permition, because i couldnt remember if i was setted this, with {passwd -root (mnt_point) root} and last i give new password for my two admin users with {passwd (user)} once for each other.
I hesitate to share, because i doubt it if i had ignited a raw for new problems, who doesn’t belong to this thread.
As i said at begin, i feel in a permanent adventure with new challenges and threats. I know very well that i am new to this. I can’t clarify if i am incapable οr in a kind of pursuit or something else. Because i moving in an edge who doesn’t collapse but she doesn’t fulfill, to to my job and my needs with tranquility and focus to main subject. For sure i have already late to ask help of community with a standard and organized way.