Lost ability to boot windows drive

Windows 10 installed on nvme drive. I installed Manjaro onto another nvme drive that was installed in my system. Now when I select the w10 drive from the bios boot menu it tells me to enter the boot disk.

Reboot and Select proper Boot Device or Insert Boot Media in selected Boot device and press a key

this is the output of lsblk

sda           8:0    0   1.8T  0 disk 
└─sda1        8:1    0   1.8T  0 part /run/media/xxx/Games
sdb           8:16   0 894.3G  0 disk 
└─sdb1        8:17   0 894.2G  0 part /run/media/xxxx/Drive of Holding
nvme1n1     259:0    0 931.5G  0 disk 
├─nvme1n1p1 259:1    0 832.8G  0 part /run/media/xxxx/super fast games
├─nvme1n1p2 259:2    0    16M  0 part 
└─nvme1n1p3 259:3    0  98.7G  0 part /run/media/xxxx/86D4F88AD4F87E2D
nvme0n1     259:4    0 931.5G  0 disk 
├─nvme0n1p1 259:5    0   300M  0 part /boot/efi
└─nvme0n1p2 259:6    0 931.2G  0 part /        

sda is a 2tb drive for games, sdb is an extra drive for miscillaneous - I can disconnect them if needed

I belive nvme1n1p2 is the windows boot partition but I cannot access it. blkid gives me this:

/dev/nvme1n1p2: PARTLABEL="Microsoft reserved partition"

this is the output when I update grub

Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.15-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-5.15-x86_64.img
Found initrd fallback image: /boot/initramfs-5.15-x86_64-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Adding boot menu entry for UEFI Firmware Settings ...
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.

when I reboot my computer I don’t see the grub menu and it boots directly into manjaro.

I’m not sure why the Manjaro install would have messed with the windows efi/boot partition? I am a bit over my head lol and I’m not sure where to go next. If I need to reinstall windows and manjaro from scratch it is what it is. But I’m hoping to find a solution to be able to dual boot again. I appreciate any insight!

edit: I just wanted to add that I had previously used Pop_os in this same configuration without any issues so I’m not sure what is different this time (or what I accidentally did lol)

Try this:

$ sudo gedit /etc/default/grub
    change 'hidden' to 'menu'
$ sudo grub-mkconfig -o /boot/grub/grub.cfg
1 Like

I will give it a try later this evening once I get home and report back. Thanks!

ok that worked perfect to get the grub menu. No windows option on there unfortunately. How should I approach adding that to the grub menu?

provide output from:
sudo blkid
sudo fdisk -l

Congratulations, looks to me like you have successfully “uninstalled” Windows.


lsblk -f

What we are looking for here are ntfs partitions.

provide output from:
sudo blkid
sudo fdisk -l

/dev/nvme0n1p1: LABEL_FATBOOT="NO_LABEL" LABEL="NO_LABEL" UUID="A546-9CEE" BLOCK_SIZE="512" TYPE="vfat" PARTUUID="ffec600b-7289-524c-ab9d-63469277480e"
/dev/nvme0n1p2: UUID="7ee7ca81-4dc7-4c0c-83f5-c76beae2ba70" BLOCK_SIZE="4096" TYPE="ext4" PARTLABEL="root" PARTUUID="33fa11bc-3c0a-264b-9b0c-46720cbdf319"
/dev/sdb1: LABEL="Drive of Holding" BLOCK_SIZE="512" UUID="CC6E38BA6E389EE0" TYPE="ntfs" PARTUUID="0b92e724-01"
/dev/nvme1n1p2: PARTLABEL="Microsoft reserved partition" PARTUUID="4ac42f25-2dde-47e7-8e79-8c44fa66e167"
/dev/nvme1n1p3: BLOCK_SIZE="512" UUID="86D4F88AD4F87E2D" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="1e9c7d98-2190-4a4c-ad52-28fc20a623b8"
/dev/nvme1n1p1: LABEL="super fast games" BLOCK_SIZE="512" UUID="A022266022263BA2" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="b1500109-329a-4e34-9322-9524aefb95ba"
/dev/sda1: LABEL="Games" BLOCK_SIZE="512" UUID="50F228CAF228B5DE" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="a369624f-58ca-41f2-a181-ce95053f9778"

Disk /dev/nvme1n1: 931.51 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: WDS100T3X0C-00SJG0                      
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 761EFD22-C356-4D20-8309-2C513F54458F

Device              Start        End    Sectors   Size Type
/dev/nvme1n1p1       2048 1746452479 1746450432 832.8G Microsoft basic data
/dev/nvme1n1p2 1746452480 1746485247      32768    16M Linux filesystem
/dev/nvme1n1p3 1746485248 1953523711  207038464  98.7G Microsoft basic data

Disk /dev/nvme0n1: 931.51 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: SHGP31-1000GM-2                         
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 4B166AC1-212B-2F44-9A38-7413EA2EDBC8

Device          Start        End    Sectors   Size Type
/dev/nvme0n1p1   4096     618495     614400   300M EFI System
/dev/nvme0n1p2 618496 1953520064 1952901569 931.2G Linux filesystem

Disk /dev/sda: 1.82 TiB, 2000398934016 bytes, 3907029168 sectors
Disk model: ST2000LX001-1RG1
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: B94760BA-459B-4C41-B888-D6FBEE056A5B

Device     Start        End    Sectors  Size Type
/dev/sda1  32768 3907026943 3906994176  1.8T Microsoft basic data

Disk /dev/sdb: 894.25 GiB, 960197124096 bytes, 1875385008 sectors
Disk model: ADATA SU650     
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x0b92e724


lsblk -f

What we are looking for here are ntfs partitions.

NAME      FSTYPE FSVER LABEL           UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
└─sda1    ntfs         Games           50F228CAF228B5DE                        1.2T    34% /run/media/xxxx/Games
└─sdb1    ntfs         Drive of Holding
                                       CC6E38BA6E389EE0                      593.5G    34% /run/media/xxxx/Drive of Holding
│         ntfs         super fast games
│                                      A022266022263BA2                      536.9G    36% /run/media/xxxx/super fast games
          ntfs                         86D4F88AD4F87E2D                       25.9G    74% /run/media/xxxx/86D4F88AD4F87E2D
│         vfat   FAT32 NO_LABEL        A546-9CEE                               299M     0% /boot/efi
          ext4   1.0                   7ee7ca81-4dc7-4c0c-83f5-c76beae2ba70  855.9G     1% /

So nvme0n1 had a working install of pop_os while nvme1n1 had a working windows install. I moved to a new motherboard and just brought the drives over. Everything was booting fine but windows eventually gave me some issues so I did a fresh reinstall. After that Pop_os would not boot anymore. However I wanted to try a different distro so I didn’t put much work into getting it working again. I just used the Manjaro installer to install to nvme0n1. Could windows have used the efi partition when it was installed and then Manjaro overwrote it?

OK I fixed the problem and wanted to share in case someone else has the same issue.

on nvme0n1 there was a FAT32 partition /boot/efi. For some reason it looks like windows originally used that as its efi folder even though it was installed on a separate drive. When exploring that partition as su I found there was a /boot/efi/microsoft/boot/ that only had 2 files called BCD and BCD.LOG.

I used a windows 10 installation usb I had to repair the startup and that solved the issue. I have no idea why the installation usb was not able to see this folder or do the repair yesterday when I attempted it. I have updated grub and confirmed that I now have a windows 10 option.

I guess the next step will be to make separate efi partitions on each drive for both OSes.

No. It’s possible, and in some use cases (often unplugging/swapping drives) a good idea, but here it’s not necessary.

Many Win/Linux ‘uefi dual-booters’ make the mistake that by trying to keep existing Win on sda separate, they shy away from installing grub to the existing efi partition on sda but this is where it/all bootloaders, Win and grub, should live!

Since Win loader refuses to offer linux boot, grub needs to sit ‘in front’ of the Win loader to prevent it from booting straight to Win. That means it has to be installed ‘beside it’ to the same efi on sda after the Win loader, in order for its ‘os-prober’ to ‘find Win’ and give us, unselfishly, an option to boot it.

Every so often Win updates its loader, selfishly treating the efi partition as its own, overwriting grub and booting straight to win. Since you just repaired your Win boot that’s what happened to your grub.

Lets put the adult back ‘in charge’;

  • boot a manjaro usb drive
  • chroot into linux
  • grub-install to efi sda
    so it again sits ‘in front’ of your newly reinstalled Win loader. Fixed.

Last night after fixing the windows loader I booted into Majaro by selecting it in the bios, updated grub which added a windows option, and changed the boot order to use the partition with grub so now at every boot I get an option (at least until a windows update borks it).

Is that not the best way to go about doing it? The boot partition has both manjaro’s and window’s boot managers.

Then you have done that, just by using your bios instead of chroot to get into your system.

Yes, it is. As I said above “grub has to be installed ‘beside it’ (win loader)’ to the same efi”.

ok perfect, just wanted to make sure I was doing it the correct way. Thanks for the info!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.