Losing keyboard configuration


I was using the Gnome tweak tool to set my compose key, as well as swaping caps-lock with esc.

For a few weeks now, these configurations are lost after my laptop has been locked for a while. If I open the tweaks tool, I get them back.

I tried moving to a setxkbmap on my .xprofile, and the same happens. It works untill I close the lid and come back after a while.

I am running 5.10.2-2 with gnome

Should I go back to some other kernel or maybe just delete some configuration file?

Thanks for the help.


Solved by:

Install dconf-editor, go into /org/gnome/desktop/input-sources/xkb-options

The, you will find a box for “custom values”. I added ‘caps:swapescape’ and ‘compose:ralt’, separated by commas, inside the surrounding bracket (it already had ‘lv3:ralt_switch’)

You can achieve the same with the “gsettings” command.

Now it seems to stick.

Not sure why the other methods didn’t work. A bug maybe?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.