Loosing HDMI audio after turning TV off

A new problem has cropped up since the last updates on how my system. Before the updates i would leave my computer on and allow it to go to sleep 2 hrs after last use, but I would turn my TV on and off and use it as a TV and when I would go back to the computer both the HDMI video and audio would always be there. Now when I turn my TV off, the computer loses the audio connection with the HDMI, but the HDMI video is fine. If I leave my TV on and reboot my computer it will see the TV and both the HDMI Video and Audio will work with no problems.

I have tried switching to and using three different kernels but that didn’t help. The Blue tooth audio when used is working also. I did have a external mixer plugged in via usb that it started to revert to so i removed it and the problem is still with me

The following is the terminal dump using “inxi -Fazy”

[davec@dave-pc ~]$ inxi -Fazy
  Kernel: 5.9.11-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=fd0df351-eda1-43f4-b246-75fe93882b5e rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 
  dm: SDDM Distro: Manjaro Linux 
  Type: Desktop System: GIGABYTE product: GB-BXBT-1900 v: 1.x serial: <filter> 
  Mobo: GIGABYTE model: MZBAYAB-00 v: 1.x serial: <filter> 
  UEFI [Legacy]: American Megatrends v: F9 date: 03/02/2018 
  Device-1: hidpp_battery_0 model: Logitech Wireless Touch Keyboard K400 
  serial: <filter> charge: 100% (should be ignored) rechargeable: yes 
  status: Discharging 
  Info: Quad Core model: Intel Celeron J1900 bits: 64 type: MCP 
  arch: Silvermont family: 6 model-id: 37 (55) stepping: 8 microcode: 838 
  L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 16006 
  Speed: 2362 MHz min/max: 1333/2416 MHz Core speeds (MHz): 1: 2417 2: 2417 
  3: 2417 4: 2417 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass status: Not affected 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display 
  vendor: Gigabyte driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0f31 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: intel 
  unloaded: modesetting alternate: fbdev,vesa display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: HDMI1 res: 1920x1080 hz: 60 dpi: 44 size: 1100x620mm (43.3x24.4") 
  diag: 1263mm (49.7") 
  OpenGL: renderer: Mesa DRI Intel HD Graphics (BYT) v: 4.2 Mesa 20.2.3 
  compat-v: 3.0 direct render: Yes 
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series High Definition Audio 
  vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:0f04 
  Device-2: Texas Instruments PCM2900 Audio Codec type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-1.4:4 chip ID: 08bb:2900 
  Device-3: Logitech CrystalCam type: USB driver: snd-usb-audio,uvcvideo 
  bus ID: 1-4:6 chip ID: 046d:0894 serial: <filter> 
  Sound Server: ALSA v: k5.9.11-3-MANJARO 
  Device-1: Realtek RTL8723BE PCIe Wireless Network Adapter vendor: AzureWave 
  driver: rtl8723be v: kernel port: e000 bus ID: 02:00.0 chip ID: 10ec:b723 
  IF: wlp2s0 state: down mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Gigabyte driver: r8169 v: kernel port: d000 bus ID: 03:00.0 
  chip ID: 10ec:8168 
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Local Storage: total: 465.76 GiB used: 126.29 GiB (27.1%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda vendor: Western Digital model: WDBNCE5000PNC size: 465.76 GiB 
  block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s serial: <filter> 
  rev: 20RL scheme: MBR 
  ID-1: / raw size: 465.76 GiB size: 457.45 GiB (98.22%) 
  used: 126.29 GiB (27.6%) fs: ext4 dev: /dev/sda1 
  Kernel: swappiness: 5 (default 60) cache pressure: 100 (default) 
  ID-1: swap-1 type: file size: 16.00 GiB used: 0 KiB (0.0%) priority: -2 
  file: /swapfile 
  System Temperatures: cpu: 52.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 227 Uptime: 28m Memory: 7.67 GiB used: 1.66 GiB (21.7%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: 1651 pacman: 1641 
  lib: 437 flatpak: 0 snap: 10 Shell: Bash v: 5.0.18 running in: yakuake 
  inxi: 3.1.08

Hopefully this can get corrected somehow, its a pain having to reboot all the time.

Thanks for the help

Dave C

I had the same problem.

What worked for me:
In the file /etc/pulse/default.pa I have deactivated the load-module instruction for the module-switch-on-port-available module.

### Should be after module - * - restore but before module - * - detect
# load-module module-switch-on-port-available


1 Like

That seems to have fixed my problem. Thanks much for the reply and the fix.
Dave C

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.