Looking for a USB Wifi

I got two usb wifi and they both work right out of the box, with Manjaro fresh installation, but they’re old and they’re not mine (borrowed). I got mine today (TL-WN725N - 8188EU V3) and tried to set it up but couldn’t so I kind of gave up.

Anyone here know of a good usb wifi that works right out of the box without any driver installation? Just plug it in and it works, not just with Manjaro, but with many other distro as well? I’m not looking for anything fancy. But I prefer something small, and fast enough to watch stuff on YouTube.

You can use the one you have with either 8188eu-dkms or 8188eu-aircrack-dkms-git from the AUR (Arch User Repository).

I tried all three:

8188eu-dkms v4.3.0.8_13968-15 [warning: error while configuring 8188eu-dkms]
8188eu-aircrack-dkms-git 5.3.9...

Strange that TL-WN723N has no problem working out of the box, but not this TL-WN725N. I’m using Manjaro on a MacBook Pro by the way. What is the proper way to completely remove the built-in Broadcom Wifi? Since it’s not being used, it would be better to completely remove it for Manjaro to see if it helps with the USB wifi detection and also so it doesn’t take up space in the Network widget and confuse me.


:smiley: sorry for not being clear. None of it work. I wonder if there’s a way to completely remove/disable the built-in Broadcom Wifi that is on this macbook since there’s no way to get it to work so might as well disable it completely. One time I managed to get it to work (built-in wifi but that’s another long story).

That doesn’t tell us anything. What’s the output of the following with the adapter connected?

inxi -Nazy

Please post the output between three backticks ` above and below the text:


Those are hard to get by - those just working with anything.

I was on a similar hunt many moons ago.

If you checkout raspberry pi dealers they will most likely have a USB wifi stick - if it works with Raspberry Pi - I am 99% percent sure it works with Manjaro.

When you hunt for one - and you find one that supposedly works with Linux - don’t take their words for it - the Linux driver supplied may be very flaky or not working at all (tp-link Archer T2U - I have a Manjaro package for it - so now it works).

Remember to check the chipset - vendors tends to change without notice and Linux support is up the chimney.

My hunt resulted in a TP-LINK TL-WN722N - but not just any of those - it was with v1.x firmware with is based of an Atheros chipset - this is not the fastest stick but it is plug-n-play no matter what OS - if it works with Kali - it works with everything.

Apple hardware is unsupported by Manjaro - if you find the proper bits to unsrew the back cover - you may find it - but I wouldn’t get my hopes up - it is probably soldered.

Another less intrusive way is to blacklist the Broadcom driver.

1 Like

Fresh installation of Manjaro:

$ inxi -Nazy

Device-1: Broadcom BCM43602 802.11ac Wireless LAN SoC vendor: Apple 
driver: brcmfmac v: kernel port: 3000 bus ID: 03:00.0 chip ID: 14e4:43ba 
Device-2: Realtek RTL8188EUS 802.11n Wireless Network Adapter type: USB
driver: r8188eu bus ID: 1-11:7 chip ID: 0bda:8179 serial: <filter>

After installing 8188eu-dkms v4.3.0.8_13968-15, with behind the scene info:

Error! echo
Error while configuring 8188eu-dkms
Your kernel headers for kernel 5.9.16-1-MANJARO cannot be found at
/usr/lib/modules/5.9.16-1-MANJARO/build or /usr/lib/modules/5.9.16-1-MANJARO/source.
You can use the --kernelsourcedir option to tell DKMS where it's located.
Error: 8188eu-dkms: command failed to execute correctly
Running post-transaction hooks...
Arming ConditionNeedsUpdate...
Install DKMS modules
==> Unable to install module 8188eu/v4.3.0.8_13968 for kernel 5.9.16-1-MANJARO: Missing kernel headers.
Transaction successfully finished.

Apparently, all the 8188 AUR seems to have “Missing kernel headers”

$ inxi -Nazy
Device-2: Realtek RTL8188EUS 802.11n Wireless Network Adapter type: USB 
driver: r8188eu bus-ID: 1-11:9 chip-ID: 0bda:8179 class-ID: 0000 
serial: <filter> 

After a full reboot:

Device-2: Realtek RTL8188EUS 802.11n Wireless Network Adapter type: USB 
driver: N/A bus-ID: 1-11:5 chip-ID: 0bda:8179 class-ID: 0000 
serial: <filter> 

I’m currently on latest Stable of Manjaro. These 8188 packages seem to be for older?

You’ll need to install the kernel headers matching your installed kernel; i.e., linux59-headers for 5.9. Then reinstall the driver and reboot.

FYI, the 5.9 kernel has been EOL (End Of Life) since the end of December. Either install the latest stable kernel (5.11) or an LTS (Long Term Support) kernel like 5.10 or 5.4

This is the FIRST time I got anything like this working. I guess the reason why I gave up initially is because I had no idea how to install the kernel header. There are a lot I still don’t understand and I’m documenting everything as I go. Following the advice of @Yochanan, I looked up for instructions on how to go about it:

Manjaro Kernels
Manjaro Linux kernel headers installation

These are the two articles I read through to install the new kernel (5.11) and header. Then I installed the [8188eu-aircrack-dkms-git 5.3.9…], rebooted and plugged in the TL-WN725N and it works.

Now I just need to figure out how to do all this with a fresh Manjaro installation WITHOUT internet connection. The current Manjaro ISO doesn’t come with Kernel 5.11, but 5.9? Without internet, there would be no possible way to update it to 5.11 or even install the header since this TL-WN725N doesn’t work out of the box. I’m assuming that Manjaro downloads the kernel into /var/cache/pacman/pkg when updating it? If so, then I assume that it can be backup (Updating (-Syu) while offline?) and install offline? The same goes for the header?

If I can get these two into a USB and install it offline, then the next step is to also get the 8188 AUR offline as well. I might need help with this part.

You can grab a newer one from here that ships with 5.10:

Checking, 1, 2, 3. I am currently on a Live USB Manjaro (21.0 rc1) posting this message! Using my mad newbie skill :sweat_smile: I managed to get it to work. Through trials and errors, I documented all the steps. Will post the steps later.

This is exactly what I initially wanted. To be able to access the net without needing access to the net to install the driver.

EDIT: Well, it looks like it wasn’t because of my mad skill, but Manjaro’s default. It’s a hit and miss! Installing kernel header and drive while in Live USB doesn’t work. But it works in a non-live environment.

Anyway, for those looking for a USB Wifi, I suggest you look into ThinkPenguin.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.