Looking for a gnome setting to hide mouse cursor while typing

Just looking for a tweak or dconf setting to make the mouse cursor disappear while typing, like on MacOS.

Thanks all!

inxi system info
$ inxi -Fxxxza --no-host
System:    Kernel: 5.8.3-2-MANJARO x86_64 bits: 64 compiler: N/A 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 root=UUID=c3b1cff2-ed37-4ee0-af3b-d404097c96ef rw quiet 
           root=/dev/mapper/luks-eb7684b1-691d-476a-81d7-9f553231a205 apparmor=1 security=apparmor 
           resume=/dev/mapper/luks-1aa70ee5-d740-4f20-a0ae-699cefa5a54f udev.log_priority=3 
           Desktop: GNOME 3.36.6 tk: GTK 3.24.23 wm: gnome-shell dm: GDM 3.36.3 Distro: Manjaro Linux 
Machine:   Type: Desktop System: Apple product: iMac12,1 v: 1.0 serial: <filter> Chassis: type: 13 v: Mac-942B5BF58194151B 
           serial: <filter> 
           Mobo: Apple model: Mac-942B5BF58194151B serial: <filter> UEFI: Apple v: date: 04/16/2019 
CPU:       Topology: Quad Core model: Intel Core i5-2400S bits: 64 type: MCP arch: Sandy Bridge family: 6 model-id: 2A (42) 
           stepping: 7 microcode: 2F L2 cache: 6144 KiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20007 
           Speed: 1948 MHz min/max: 1600/3300 MHz Core speeds (MHz): 1: 2066 2: 2175 3: 2309 4: 2340 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
           Type: mds mitigation: Clear CPU buffers; SMT disabled 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:0102 
           Device-2: Advanced Micro Devices [AMD/ATI] Whistler [Radeon HD 6630M/6650M/6750M/7670M/7690M] vendor: Apple 
           driver: radeon v: kernel bus ID: 01:00.0 chip ID: 1002:6741 
           Device-3: Apple FaceTime HD Camera (Built-in) type: USB driver: uvcvideo bus ID: 1-2:3 chip ID: 05ac:850b 
           serial: <filter> 
           Display: x11 server: X.Org 1.20.8 compositor: gnome-shell driver: ati,intel,radeon unloaded: modesetting 
           alternate: fbdev,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x286mm (40.0x11.3") s-diag: 1055mm (41.6") 
           Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 103 size: 475x267mm (18.7x10.5") diag: 545mm (21.5") 
           Monitor-2: DisplayPort-0 res: 1920x1080 hz: 60 dpi: 103 size: 475x267mm (18.7x10.5") diag: 545mm (21.5") 
           OpenGL: renderer: AMD TURKS (DRM 2.50.0 / 5.8.3-2-MANJARO LLVM 10.0.1) v: 3.3 Mesa 20.1.7 compat-v: 3.1 
           direct render: Yes 
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           chip ID: 8086:1c20 
           Device-2: AMD Turks HDMI Audio [Radeon HD 6500/6600 / 6700M Series] vendor: Apple driver: snd_hda_intel v: kernel 
           bus ID: 01:00.1 chip ID: 1002:aa90 
           Sound Server: ALSA v: k5.8.3-2-MANJARO 
Network:   Device-1: Broadcom and subsidiaries NetXtreme BCM57765 Gigabit Ethernet PCIe driver: tg3 v: kernel port: 2000 
           bus ID: 02:00.0 chip ID: 14e4:16b4 
           IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Qualcomm Atheros AR93xx Wireless Network Adapter vendor: Apple AirPort Extreme driver: ath9k v: kernel 
           port: 2000 bus ID: 03:00.0 chip ID: 168c:0030 
           IF: wlp3s0 state: down mac: <filter> 
Drives:    Local Storage: total: 1.36 TiB used: 5.98 TiB (438.4%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda vendor: Western Digital model: WD5000AAKS-402AA0 size: 465.76 GiB block size: physical: 512 B 
           logical: 512 B speed: 3.0 Gb/s rotation: 7200 rpm serial: <filter> rev: 1D02 temp: 52 C scheme: GPT 
           ID-2: /dev/sdb model: Mercury Electra 6G SSD size: 931.51 GiB block size: physical: 512 B logical: 512 B 
           speed: 6.0 Gb/s serial: <filter> rev: 7B0 temp: 48 C scheme: GPT 
Partition: ID-1: / raw size: 918.37 GiB size: 902.95 GiB (98.32%) used: 396.25 GiB (43.9%) fs: ext4 dev: /dev/dm-0 
Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 12.85 GiB used: 3.86 GiB (30.0%) priority: -2 dev: /dev/dm-1 
Sensors:   System Temperatures: cpu: 59.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 1197 
Info:      Processes: 313 Uptime: 21d 2h 31m Memory: 11.68 GiB used: 6.65 GiB (56.9%) Init: systemd v: 246 Compilers: 
           gcc: 10.2.0 clang: 10.0.1 Packages: pacman: 1774 lib: 401 flatpak: 0 Shell: Bash v: 5.0.18 running in: guake 
           inxi: 3.1.05 


1 Like

Neat, I’ll check that out!

I’m guessing there isn’t a native gnome setting for it?

Seems there isn’t. I just scrubbed through dconf and searched for “mouse,” “cursor,” and “hide.”

Here’s a little script I wrote to scan through all dconf settings and display the names:


function lister() {                     #lister() is a recursive function
    dconf list "$1" |while read item    #call dconf list and iterate over output
        if echo "$item" |grep -q "\/$"  #if item ends with a slash (is a dir)
            lister "$newitem"           #call recursive function on new item
            echo "$newitem"             #else print what we got (end of branch)

#call the lister function with the 0th level item: / (root)
lister /

P.S. I never quite understood the importance of recursion until I wrote that script. :slight_smile:

Well thanks, @Chrysostomus, that did the trick. It’s working quite well for me. :slight_smile:

Or, you could just use ctrl+f in dconf editor? It’s pretty handy.

HA!!! Oh dang. :smiley:

Gnome likes putting recursive search everywhere. Even if it is not visible somewhere, it is probably still there.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.