Long boot time 18.0.4 Cinnamon (SSD)

boot
#1

Hi, I have a problem with a long boot time. I have SSD and on Windows it’s 10 sec max to desktop. On Manjaro it’s 1 min 35 sec after GRUB. The system is booting a very long time from the first start up after fresh installation so it’s not the third-party apps fault. I tried a different kernels and the same problem.

Configuration from inxi -Fxz:

System:
  Host: rygielPC Kernel: 5.0.3-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: Cinnamon 4.0.9 Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: ASRock model: B85 Killer serial: <filter> 
  BIOS: American Megatrends v: P1.70 date: 09/17/2014 
CPU:
  Topology: Quad Core model: Intel Core i5-4690K bits: 64 type: MCP 
  arch: Haswell rev: 3 L2 cache: 6144 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28005 
  Speed: 4200 MHz min/max: 800/4200 MHz Core speeds (MHz): 1: 4199 2: 4199 
  3: 4199 4: 4199 
Graphics:
  Device-1: AMD Tonga PRO [Radeon R9 285/380] vendor: Micro-Star MSI 
  driver: amdgpu v: kernel bus ID: 01:00.0 
  Display: x11 server: X.Org 1.20.4 driver: amdgpu FAILED: ati 
  unloaded: modesetting resolution: 1440x900~60Hz 
  OpenGL: renderer: AMD Radeon R9 380 Series (TONGA DRM 3.27.0 
  5.0.3-1-MANJARO LLVM 7.0.1) 
  v: 4.5 Mesa 18.3.4 direct render: Yes 
Audio:
  Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: ASRock 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Device-2: AMD Tonga HDMI Audio [Radeon R9 285/380] vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  Device-3: HP type: USB driver: hid-generic,snd-usb-audio,usbhid,uvcvideo 
  bus ID: 2-3:2 
  Sound Server: ALSA v: k5.0.3-1-MANJARO 
Network:
  Device-1: Qualcomm Atheros Killer E220x Gigabit Ethernet vendor: ASRock 
  driver: alx v: kernel port: d000 bus ID: 05:00.0 
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 698.65 GiB used: 39.10 GiB (5.6%) 
  ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB 
  ID-2: /dev/sdb vendor: Crucial model: CT250BX100SSD1 size: 232.89 GiB 
Partition:
  ID-1: / size: 146.65 GiB used: 39.10 GiB (26.7%) fs: ext4 dev: /dev/sda1 
  ID-2: swap-1 size: 16.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 37.0 C mobo: N/A gpu: amdgpu temp: 61 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 940 
Info:
  Processes: 216 Uptime: 19m Memory: 7.71 GiB used: 1.48 GiB (19.2%) 
  Init: systemd Compilers: gcc: 8.2.1 Shell: bash v: 5.0.0 inxi: 3.0.32
[details="Podsumowanie"]
test
[/details]

Info from systemd-analyze blame:

           695ms lightdm.service
           315ms lvm2-monitor.service
           302ms systemd-logind.service
           234ms dev-sda1.device
           196ms upower.service
           193ms tlp.service
           183ms ModemManager.service
            99ms polkit.service
            98ms udisks2.service
            79ms NetworkManager.service
            72ms avahi-daemon.service
            67ms systemd-journal-flush.service
            60ms systemd-udevd.service
            58ms add-autologin-group.service
            56ms grub-boot-indeterminate.service
            37ms systemd-udev-trigger.service
            34ms systemd-journald.service
            31ms user@1000.service
            21ms systemd-timesyncd.service
            18ms systemd-modules-load.service
            15ms colord.service
            15ms systemd-binfmt.service
            15ms org.cups.cupsd.service
            12ms systemd-tmpfiles-setup-dev.service
            11ms systemd-tmpfiles-setup.service
             9ms accounts-daemon.service
             8ms systemd-random-seed.service
             7ms dev-mqueue.mount
             6ms kmod-static-nodes.service
             6ms dev-hugepages.mount
             4ms systemd-remount-fs.service
             4ms user-runtime-dir@1000.service
             4ms proc-sys-fs-binfmt_misc.mount
             4ms systemd-update-utmp.service
             4ms systemd-sysctl.service
             3ms systemd-user-sessions.service
             3ms sys-kernel-config.mount
             2ms sys-fs-fuse-connections.mount
             2ms rtkit-daemon.service
             2ms sys-kernel-debug.mount
             1ms tmp.mount

Info from systemd-analyze critical-chain"

graphical.target @1.248s
└─lightdm.service @553ms +695ms
  └─systemd-user-sessions.service @549ms +3ms
    └─nss-user-lookup.target @1.214s
#2

systemd-analyze
Startup finished in 2.731s (kernel) + 2.510s (userspace) = 5.241s
graphical.target reached after 2.016s in userspace
that is 7.8 secs from pressing the start button to a operational desktop.
Just for reference this is mine with the same CPU using Gnome.
!st I would say win10 time is not a cold boot but booting from hibernation, and that can play havoc when dual booting
So i would turn off fast boot in both win10 and in Bios

1 Like
#3

This may be due to the entropy issue. Try installing haveged.

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

Mine was doing the same thing and haveged solved it.

1 Like
#4

:sweat_smile: Why?
For me it’s:

Startup finished in 1.076s (kernel) + 1.543s (userspace) = 2.619s 
graphical.target reached after 1.370s in userspace

And all boot time is 1 min 35 sec after GRUB. ;x

I had it already included earlier.

#5

They have a newer BIOS that usually helps.
https://www.asrock.com/mb/Intel/Fatal1ty%20B85%20Killer/#BIOS

Cinnamon boots slower than other DE’s on my installs too, so i took it as a given :slight_smile:

You can mask that service:
sudo systemctl mask ModemManager

1 Like
#6

I tried but they didn’t help and the latest ones don’t allow OC. ;/

Maybe you’re right, but it’s too long.