Long Boot Gnome

Hello everyone, I have a problem. My laptop is taking a long time to boot, around 20-40 seconds. It’s running gnome Manjaro with Kernel 6.6.19. I’ve read through some threads before posting this, but it seems nothing relates to my issue. Can you please suggest how to solve this problem? Here are some details that might help:

OS: Manjaro Linux x86_64
Host: Vivobook_ASUSLaptop M1402IA_M1402IA 1.0
Kernel: 6.6.19-MANJARO
CPU: AMD Ryzen 7 4800HS with Radeon Graphics (16) @ 3.600GHz
GPU: AMD ATI Radeon RX Vega 6
Memory: 6121MiB / 15409MiB

dmesg error:

[ 9.973337] amdgpu 0000:04:00.0: amdgpu: Secure display: Generic Failure.
[ 9.973343] amdgpu 0000:04:00.0: amdgpu: SECUREDISPLAY: query securedisplay TA failed. ret 0x0

systemd-analyze:

Startup finished in 3.498s (firmware) + 7.805s (loader) + 1.428s (kernel) + 35.199s (userspace) = 47.932s
graphical.target reached after 34.646s in userspace

critical-chain:

graphical.target @34.646s
└─multi-user.target @34.645s
└─plymouth-quit-wait.service @9.718s +24.921s
└─systemd-user-sessions.service @9.598s +63ms
└─nss-user-lookup.target @13.074s

If your machine is booting within well under a minute, then you have no issue of any consequence to be concerned about; in my humble opinion. Cheers.

I would advise uninstalling plymouth. It’s only a splash screen, and apparently that’s what’s causing the delay. There are other people reporting issues with it as well, so best is to just nuke it. :man_shrugging:

@Aragorn
Thank you for your response. However, I’ve read that there’s usually something hidden behind the boot screen (some unfinished processes). I’m not sure if that’s my case. What do you think? I just can’t recall if I had such a long boot-up time right at the beginning when I first installed the system.

@soundofthunder
Thank you for the advice, but I don’t have an HDD, and I have a computer running Ubuntu that boots several times faster. Although, it seems my laptop is equipped with an NVMe SSD.

Yes. My SSD’s typically boot between 20-30 seconds, depending on whichever OS I happen to be booting at the time (I have a multiboot system). Of course, included in that range are timeouts to allow selecting BIOS actions, and also for Grub; and rEFInd; so the actual range is less.

@Aragorn has already given you the likely cause of your boot delay (Plymouth); and considering others also have the same issue with Plymouth currently, the suggestion to remove it is valid. From your response, it seemed that you might ignore the advice. Please don’t.

Because Plymouth has close ties to boot processes, simply uninstalling the package is insufficient.

The correct procedure to remove Plymouth can be found on the Manjaro Plymouth Wiki page under the heading of REMOVAL.
Additionally, you might appreciate the related information found in Disable or Remove Plymouth (boot splash).

Plymouth isn’t needed for booting Manjaro. Many users (myself included) remove it completely even if it isn’t causing issues; because, sooner or later, it will.

2 Likes

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.