Lollypop crashes when selecting to shuffle all artists on Gnome

Has anyone else found that lollypop crashes when they select to shuffle all artists. I get the following output if I launch Lollypop from the terminal:

Traceback (most recent call last):
  File "/usr/lib/python3.9/site-packages/lollypop/", line 214, in __on_banner_play_all
    album_ids = App().albums.get_ids([], [], self.storage_type,
  File "/usr/lib/python3.9/site-packages/lollypop/", line 1081, in get_ids
    result = sql.execute(request, (storage_type,))
sqlite3.ProgrammingError: Incorrect number of bindings supplied. The current statement uses 2, and there are 1 supplied.

To replicate the bug, launch Lollypop, click on “Artists” on the left hand navigation bar, then click on the shuffle icon in the top right hand corner.

My output for inxi -Fazy is:

  Kernel: 5.10.7-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=f5245ffc-4c91-4b47-b905-1d35123f8237 rw quiet 
  rd.udev.log_priority=3 mitigations=off 
  Desktop: GNOME 3.38.3 tk: GTK 3.24.24 wm: gnome-shell dm: GDM 
  Distro: Manjaro Linux 
  Type: Desktop System: Intel Client Systems product: NUC8i7HVK v: J71485-504 
  serial: <filter> Chassis: Intel Corporation type: 3 v: 2.0 serial: <filter> 
  Mobo: Intel model: NUC8i7HVB v: J68196-504 serial: <filter> UEFI: Intel 
  v: HNKBLi70.86A.0064.2020.1028.1438 date: 10/28/2020 
  Device-1: apple_mfi_fastcharge model: N/A serial: N/A charge: N/A 
  status: N/A 
  Device-2: hidpp_battery_0 model: Logitech MX Keys Wireless Keyboard 
  serial: <filter> charge: 55% (should be ignored) rechargeable: yes 
  status: Discharging 
  Info: Quad Core model: Intel Core i7-8809G bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: 9 microcode: DE 
  L2 cache: 8 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 49618 
  Speed: 900 MHz min/max: 800/8300 MHz Core speeds (MHz): 1: 900 2: 900 3: 900 
  4: 900 5: 900 6: 900 7: 900 8: 900 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf mitigation: PTE Inversion; VMX: vulnerable 
  Type: mds status: Vulnerable; SMT vulnerable 
  Type: meltdown status: Vulnerable 
  Type: spec_store_bypass status: Vulnerable 
  Type: spectre_v1 status: Vulnerable: __user pointer sanitization and 
  usercopy barriers only; no swapgs barriers 
  Type: spectre_v2 status: Vulnerable, IBPB: disabled, STIBP: disabled 
  Type: srbds status: Vulnerable 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel HD Graphics 630 driver: i915 v: kernel bus ID: 00:02.0 
  chip ID: 8086:591b 
  Device-2: AMD Polaris 22 XT [Radeon RX Vega M GH] vendor: Intel 
  driver: amdgpu v: kernel bus ID: 01:00.0 chip ID: 1002:694c 
  Display: wayland server: X.Org compositor: gnome-shell driver: 
  loaded: amdgpu,ati,intel unloaded: modesetting alternate: fbdev,vesa 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x286mm (40.0x11.3") 
  s-diag: 1055mm (41.6") 
  Monitor-1: XWAYLAND0 res: 1920x1080 hz: 50 dpi: 92 
  size: 530x300mm (20.9x11.8") diag: 609mm (24") 
  Monitor-2: XWAYLAND1 res: 1920x1080 hz: 60 dpi: 92 
  size: 530x300mm (20.9x11.8") diag: 609mm (24") 
  OpenGL: renderer: AMD VEGAM (DRM 3.40.0 5.10.7-3-MANJARO LLVM 11.0.1) 
  v: 4.6 Mesa 20.3.3 direct render: Yes 
  Device-1: Intel CM238 HD Audio driver: snd_hda_intel v: kernel 
  bus ID: 00:1f.3 chip ID: 8086:a171 
  Device-2: AMD Polaris 22 HDMI Audio vendor: Intel driver: snd_hda_intel 
  v: kernel bus ID: 01:00.1 chip ID: 1002:ab08 
  Device-3: Logitech Logitech StreamCam type: USB 
  driver: hid-generic,snd-usb-audio,usbhid,uvcvideo bus ID: 6-1:2 
  chip ID: 046d:0893 serial: <filter> 
  Sound Server: ALSA v: k5.10.7-3-MANJARO 
  Device-1: Intel Ethernet I219-LM driver: e1000e v: kernel port: f040 
  bus ID: 00:1f.6 chip ID: 8086:15b7 
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Device-2: Intel I210 Gigabit Network driver: igb v: kernel port: b000 
  bus ID: 05:00.0 chip ID: 8086:157b 
  IF: enp5s0 state: down mac: <filter> 
  Device-3: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: b000 
  bus ID: 06:00.0 chip ID: 8086:24fd 
  IF: wlp6s0 state: down mac: <filter> 
  IF-ID-1: eth0 state: up speed: N/A duplex: N/A mac: <filter> 
  Local Storage: total: 1.86 TiB used: 594.96 GiB (31.2%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 maj-min: 259:2 vendor: Samsung model: SSD 970 PRO 1TB 
  size: 953.87 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 serial: <filter> rev: 1B2QEXP7 temp: 45.9 C 
  ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: A-Data model: SX8200PNP 
  size: 953.87 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 serial: <filter> rev: SS0411B temp: 38.9 C 
  ID-1: / raw size: 953.57 GiB size: 937.61 GiB (98.33%) 
  used: 316.51 GiB (33.8%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:4 
  ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 280 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:3 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: file size: 32 GiB used: 0 KiB (0.0%) priority: -2 
  file: /swapfile 
  System Temperatures: cpu: 61.5 C mobo: 29.8 C gpu: amdgpu temp: 49.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 321 Uptime: 6h 51m wakeups: 13 Memory: 31.28 GiB 
  used: 8.4 GiB (26.9%) Init: systemd v: 247 Compilers: gcc: 10.2.0 Packages: 
  pacman: 1870 lib: 454 Shell: Zsh v: 5.8 running in: gnome-terminal 
  inxi: 3.2.02

I tried to reproduce the issue, but Lollypop 1.4.14 does not crash on my machine. Have you tried lollypop-next-git from the AUR?