Lokalize: top menu bar missing in app

My screenshot of lokalize looks like this:

but if you see this image:

The top menu bar (files, edit, go, sync) is present. This is not present in Lokalize on Manjaro KDE. I tried to configure it by reading the docs and going to “Configure Lokalize” but there is no option to enable this top menu bar.

Try Ctrl+M. For KDE-/Qt-native applications, that shortcut will normally bring back their menu, if they have one.

I tested this, it didn’t work.

Both left/right ctrl + M

Hmm… Have you tried a few other combinations? For instance…

  • Meta+M
  • Alt+M
  • Ctrl+Alt+M

Tested all combos, none worked.

I just checked and this top menu bar is missing from other KDE apps too:

  • Kate
  • Okular

Is this some setting I need to change somewhere else to show this menu bar for all KDE apps?

No, the setting is application-specific — i.e. you can choose to hide the menu in some applications and make it visible in others — but to the best of my knowledge, the Ctrl+M shortcut has always been the way to enable or disable it.

I cannot verify this on my system because I am using the global menu, so my applications all show their menu inside a panel at the top of my screen.

In System Settings, click on Workspace and then on Shortcuts. Scroll down to where you see “View” in the left column. There is an item there labeled “Show Menu bar”. Click the down arrow next to that and make sure that the checkbox for Ctrl+M is ticked. Then click Apply.

I checked and this is already ticked and set, but I am still unable to get this menu bar to display.

On Firefox pressing alt shows it but then as I scroll, it disappears.

On the native KDE apps, ctrl + M doesn’t work at all.

Maybe you had Ctrl+M assigned to a different shortcut already. Normally it should throw up a warning if that is the case, but you can either way try setting it to a different shortcut. Untick the checkbox for Ctrl+M, click on Custom Shortcut and then press the shortcut you would like to use.

Firefox is not a KDE-native application — it’s a GTK application, and for that matter, one that has its user interface statically built in, so that it does not change according to the desktop environment or even operating system that it runs on.

If you want to make the menu permanently visible in Firefox, then right-click the toolbar and tick the “Menu” checkbox. You can also hide or make visible the bookmarks bar this way.

Again, try by setting a custom shortcut for that. But with the Ctrl+M checkbox ticked in the Shortcut settings of System Setttings, it should work in all KDE-native applications.

:man_shrugging:

Found the solution:

https://unix.stackexchange.com/questions/425168/kde-global-menu-disappeared-in-plasma-5-12

Seems like nobody wanted to lose this top menu (global menu) but somebody decided it should go :joy:

In that case, you have not been fair with us. You never mentioned that you were using the global menu instead of having the menu inside the application window, and not even when I mentioned to you higher up that I myself am using the global menu.

Either way, the global menu is not gone — far from it — but the StackExchange link you posted refers to Plasma 5.12, while Manjaro is currently at Plasma version 5.24.

The method for adding a global menu was changed several years ago already, and the way you do it is by first adding a panel to the top of your screen and then adding the global menu widget to it from the list of widgets you get when you right-click the panel and choose “Add widgets”.

:arrow_down:

Note: The Firefox in the above screenshot is not the regular firefox package that’s installed by default, but a specially patched version called firefox-appmenu-bin from the AUR, with global menu support.

The normal firefox package does not support a global menu, because the Mozilla developers insist on giving their applications a uniform look & feel across all operating systems — or so they claim, because the macOS version does have a global menu (and a different look).

In that case, you have not been fair with us. You never mentioned that you were using the global menu instead of having the menu inside the application window, and not even when I mentioned to you higher up that I myself am using the global menu.

I don’t understand why you say this. I was looking for any solution to add that menu. I would have liked to add the menu inside the app window (the default behavior in most distros), but this was the best I could find that sort of answered the issue.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.