Logitech MX Keys not working on grub menu

I believe that’s what the menu is called. I am running i3. When I boot, or reboot, I can’t select a bootmenu option as my keyboard is not ‘connected’. I get the keyboard back on my login screen.

Is this a feature of MX Keys? I have a bluetooth service running, but it doesn’t appear to happen until everything is loaded at the login screen.

Can you access BIOS settings with that keyboard? If not, then that’s the answer. Unless whatever Laptop/Desktop PC can handle paired bluetooth devices from BIOS, then you only have it available once the OS services are started. Check the manufacturer manual. Probably you will also have to set Legacy USB from Auto to Enabled (if the BIOS supports that feature)

1 Like

I have the same keyboard and no such issue on my end. I do use the included dongle though and not Bluetooth.

That’s what I want to use also. How do I link it up?

Or do I just remove the bluetooth connections?

Thank you for the information. I’m researching that now

The_Istar, your solution worked. I had to boot in evil Win11 to use the logitech unifier pairing software, but once I did that, my keyboard works as advertised on the grub menu and manjaro boot.

Thanks for your input

PS I disabled the blue tooth connection to the keyboard also

1 Like

You can use the Solaar application to pair/unpair devices with the Logitech Unifying Receiver so no need for booting Win11. Solaar can also be used to change the functions of the special keys on the MX Keys keyboard.

1 Like

Great, good to hear that it works now. :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.