Logitech K380 (keyboard) needing manual connecting after each reboot

Hey folks,
Not sure that belongs to the Xfce subgroup but since I’m only facing that issue on Manjaro Xfce as opposed to Elementary OS and Pop!_Os I though maybe this could be related to the desktop environment.

I have a bluetooth keyboard (Logitech K380) that although rightly paired, will need manual connection each time I boot my computer.

Not sure that’s related but the K380 has 3 connection profiles sort of. You can pair it with 3 computers so I use this keyboard with my desktop computer, MacBook Pro and my other laptop (pop os)

When I boot into Manjaro, I need to press and hold my f2 key on the K380 (the pairing button) and when the keyboard is in pairing mode, I need to right click on the bluetooth icon in the icon bar and select

Recent connections > Auto connect profiles on Keyboard K380

Not the end of the world but would be great if the keyboard could just be automatically paired at boot time

Any help would be greatly appreciated :smiley:

1 Like

I Have That Keyboard, But I don’t why it’s Doing it?

Are you experiencing the same issue ?

It seems like the reason behind the issue us that the device can’t really be “paired” in the traditional way but only on-off connected if that makes sense.

Would be nice to find a fix though. In eOS and Pop!_os it works seamlessly

Little bit, But I’m on a raspberry pi 4. I haven’t reboot it yet.

I can get a system up and running for testing.

Here is my Blueman info.

Exactly same Keyboard, and the same problem. I am using raspberry pi 4.
Usually you need to enter pin on keyboard to pair it properly, but I never get the notification with a pin. If you type some random numbers and press Enter on keyboard - it instantly fails to connect. Weird that it is working at all, even without pairing. Whenever you reboot, or switch off the keyboard - you have to manually reconnect it, as per OP.

I’m having the same problem. I had not any issues with gnome and Debian.

Make sure that in the file /etc/bluetooth/main.conf the following line is uncommented and set to true:


1 Like

thank you so much. problem solved.

The above did not work for me. What I did was install the “Blueberry” manager and it asked me to enter the PIN. After that it worked perfect. I kept the change to /etc/bluetooth/main.conf as “AutoEnable = true” maybe someone wants to try changing it back to “false” but if it works I won’t touch it.

hay i got the same problem but when i try to change the main.conf but it said it doent exist or i dont have permision as the admin has any one got any idears?

Tried that and that doesn’t work for me, every time when i boot into my system i must press some key and then my keyboard is activated

How can i make it work instantly after login?

same issue for me with the same keyboard! I have AutoEnable=true in my /etc/bluetooth/main.conf