Logitech C-525 webcam not working [Solved]


#1

My Logitech C-525 webcam doesn’t show up when I try to use it with Skype.
It seems like driver for it is already in kernel.
I’ve checked and lsmod returns
uvcvideo 118784 0
so module for webcam is loaded I believe.
I don’t know what else I can check to find out the cause of the problem. Please, help


#2

lsusb

Skype now a days is a web app, does it work with any native applications like v4l, Kamoso, vlc, cheese, etc.?


#3

skype web app included in Manjaro is not good with webcams, and sometimes audio too

suggest install Skype from AUR skypeforlinux-stable-bin


#4

Actually I use exactly that package for installing Skype


#5

I’ve tried to use it with vlc and doesn’t see camera as well


#6

Did you ensure that these applications are pointing at the correct device location for your video stream (example: /dev/video0, etc.)?


#7

Actually I don’t have anything started with video in /dev


#8

What do you mean?
/dev is where all the device files are, from the hard drive to the sound card to the usb ports they are all in there.

Your video application needs to point to the camera’s dev file just as a partition manager or anything that access your hard drive would need to point to your drive’s dev file/s (aka /dev/hda, etc.), or a cd/dvd application would need to point to your removable drive (/dev/cdrom or /dev/sr0). etc.


#9

I just don’t know how to find out what device in /dev represents my web camera (if any)


#10

v4l (video for linux) can be used to tell you, I just don’t remember the commands.
However, this might sound strange, but you can use xsane, skanlight, simplescan, etc. to find out.
Screenshot_20190207_074022

NOTE: /dev/cdrom is a symbolic link to /dev/sr0 typically, or wherever your optical drive is connected to, anyway.


#11

Perhaps try qtcam-git in the AUR.


#12

It turns out that for whatever reason kernel wasn’t pickup webcam. I’ve found out this using lsusb. After probing all the usb ports I have found one port where webcam was picked up by the kernel and showed up in the result of lsusb. So, my problem was solved


#13

Hi
Can you explain more about how did you exactly solved the issue?
Thanks