Login Using Touch Screen


I have a Raspberry Pi 4 running Manjaro. I also have the 7 inch touchscreen connected and it is running fine. But I can only log in via ssh currently.

When it boots it goes to the login screen and requires a password. I wondered if it is possible to get a software keyboard to popup so that a password can be entered?

What DisplayManager ? (or not?)

@cscs Not sure. I’m new to Manjaro. Just default so I presume LightDM is it? I would also be happy with an auto login as it is just for displaying a DAKBoard on the wall.

Can you verify with

pacman -Qs lightdm

That didn’t return anything. But it looks like it might be sddm? Or is it called plasma?

local/sddm 0.18.1-3
QML based X11 and Wayland display manager
local/sddm-breath2-theme 1.0.10-1
breath2 theme for SDDM
local/sddm-kcm 5.19.5-1 (plasma)
KDE Config Module for SDDM

Found this command to find the running Display Manager in Manjaro ->

ls -l /etc/systemd/system/display-manager.service

OK thats fine. I just wanted to know how to direct you.
SDDM has this functionality and theres an entry in the archwiki for it:

That worked! The virtual keyboard button appears. But there is a problem - the keyboard is too small to see what I am typing. :smiley:
Is there any way to make it appear so that it is readable?

There might be a way to augment the keyboard in general.
But the easiest answer I can give is that there are easy declared options in the matchama sddm theme.

So if you install that (its in the repos) you could edit those lines in Main.qml for the size.
(after install should be at /usr/share/sddm/themes/matchama/Main.qml)

Thanks for the info. I tried installing that theme but still the same problem.

When I initially boot up the device and tap into the password box the normal sized virtual keyboard appears over the top half of the screen. So I can type the password but nothing appears in the password text box underneath the keyboard. Then the keyboard disappears and if I tap into the password text box again the tiny keyboard appears. If I then tap on the keyboard keys (that I cannot see the letters/numbers on) it does put characters into the password text box but they are incorrect because I cannot see what I am typing.